aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-08-21 14:33:03 -0600
committerEric Blake <eblake@redhat.com>2012-08-21 14:33:03 -0600
commit4fce1c43ca6b870521037e7fb3a534c2152f52ca (patch)
tree4b9776fae8aa1452efa57711dd1212b36e15710f /src/Makefile.am
parentbuild: network requires location of dbus headers (diff)
downloadlibvirt-4fce1c43ca6b870521037e7fb3a534c2152f52ca.tar.gz
libvirt-4fce1c43ca6b870521037e7fb3a534c2152f52ca.tar.bz2
libvirt-4fce1c43ca6b870521037e7fb3a534c2152f52ca.zip
build: avoid $(builddir) in Makefile
Older automake 1.9.6 (hello there, RHEL 5) did not populate $(builddir), which meant 'make check' failed with: make[3]: *** No rule to make target `/.libs/libvirt.la', needed by `check-symfile'. Stop. For that matter, even newer automake doesn't directly emit rules to build .libs/libvirt.la; we are better off basing our rules on the public ./libvirt.la. * src/Makefile.am (check-symfile): Delete useless variable.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 39cbefda5..2f15a370c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -310,8 +310,11 @@ PDWTAGS = \
echo 'WARNING: install the dwarves package to get pdwtags' >&2; \
fi
-check-symfile: libvirt.syms $(builddir)/.libs/libvirt.la
- $(AM_V_GEN)$(PERL) $(srcdir)/check-symfile.pl libvirt.syms $(builddir)/.libs/libvirt.so
+# .libs/libvirt.so is built by libtool as a side-effect of the Makefile
+# rule for libvirt.la
+check-symfile: libvirt.syms libvirt.la
+ $(AM_V_GEN)$(PERL) $(srcdir)/check-symfile.pl libvirt.syms \
+ .libs/libvirt.so
PROTOCOL_STRUCTS = \
$(srcdir)/remote_protocol-structs \