aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShradha Shah <sshah@solarflare.com>2012-08-16 16:41:06 +0100
committerLaine Stump <laine@laine.org>2012-08-17 15:43:25 -0400
commitf9150c81584112ce884032ee63229c6a3154d1af (patch)
tree0506398a2d19a178ed16d4fc4009b097655d79c4 /src/Makefile.am
parentdocs: Enhance documentation of log_filters (diff)
downloadlibvirt-f9150c81584112ce884032ee63229c6a3154d1af.tar.gz
libvirt-f9150c81584112ce884032ee63229c6a3154d1af.tar.bz2
libvirt-f9150c81584112ce884032ee63229c6a3154d1af.zip
conf: move DevicePCIAddress functions to separate file
Move the functions the parse/format, and validate PCI addresses to their own file so they can be conveniently used in other places besides device_conf.c Refactoring existing code without causing any functional changes to prepare for new code. This patch makes the code reusable. Signed-off-by: Shradha Shah <sshah@solarflare.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3184fb4ee..d35edd639 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -199,6 +199,10 @@ CPU_CONF_SOURCES = \
CONSOLE_CONF_SOURCES = \
conf/virconsole.c conf/virconsole.h
+# Device Helper APIs
+DEVICE_CONF_SOURCES = \
+ conf/device_conf.c conf/device_conf.h
+
CONF_SOURCES = \
$(NETDEV_CONF_SOURCES) \
$(DOMAIN_CONF_SOURCES) \
@@ -211,7 +215,8 @@ CONF_SOURCES = \
$(INTERFACE_CONF_SOURCES) \
$(SECRET_CONF_SOURCES) \
$(CPU_CONF_SOURCES) \
- $(CONSOLE_CONF_SOURCES)
+ $(CONSOLE_CONF_SOURCES) \
+ $(DEVICE_CONF_SOURCES)
# The remote RPC driver, covering domains, storage, networks, etc
REMOTE_DRIVER_GENERATED = \