aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-08-21 14:23:35 -0600
committerEric Blake <eblake@redhat.com>2012-08-21 14:27:38 -0600
commitf97d02d7be53db63aadae3307cc1bcb1c93389a2 (patch)
tree48b63fcd8d6585897fc3edc3b426c59bfc8abfc4 /src/Makefile.am
parentatomic: fix whitespace in previous patch (diff)
downloadlibvirt-f97d02d7be53db63aadae3307cc1bcb1c93389a2.tar.gz
libvirt-f97d02d7be53db63aadae3307cc1bcb1c93389a2.tar.bz2
libvirt-f97d02d7be53db63aadae3307cc1bcb1c93389a2.zip
build: network requires location of dbus headers
Without this patch, RHEL 5 fails to compile, since the dbus files lives under /usr/include/dbus-1.0/dbus/dbus.h, and DBUS_CFLAGS contains -I/usr/include/dbus-1.0. In file included from network/bridge_driver.c:67: ../src/util/virdbus.h:26:25: error: dbus/dbus.h: No such file or directory * src/Makefile.am (libvirt_driver_network_impl_la_CFLAGS): Add DBUS_CFLAGS.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 61b6e09ae..39cbefda5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1006,7 +1006,7 @@ noinst_LTLIBRARIES += libvirt_driver_network.la
endif
libvirt_driver_network_impl_la_CFLAGS = \
- $(LIBNL_CFLAGS) \
+ $(LIBNL_CFLAGS) $(DBUS_CFLAGS) \
-I$(top_srcdir)/src/conf $(AM_CFLAGS) $(DBUS_CFLAGS)
libvirt_driver_network_impl_la_SOURCES = $(NETWORK_DRIVER_SOURCES)
endif