aboutsummaryrefslogtreecommitdiff
path: root/src/lxc
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-07-10 15:43:08 -0600
committerEric Blake <eblake@redhat.com>2012-07-10 15:49:41 -0600
commit0867a87721cc2a6be1ddb90363703f842b687bb3 (patch)
tree76576b3e7732f0da1d94091308537cdd6e374e17 /src/lxc
parentsystemd: start libvirtd after network (diff)
downloadlibvirt-0867a87721cc2a6be1ddb90363703f842b687bb3.tar.gz
libvirt-0867a87721cc2a6be1ddb90363703f842b687bb3.tar.bz2
libvirt-0867a87721cc2a6be1ddb90363703f842b687bb3.zip
build: detect all improper uses of _("%s")
The only useful translation of "%s" as a format string is "%s" (I suppose you could claim "%1$s" is also valid, but why bother). So it is not worth translating; fixing this exposes some instances where we were failing to translate real error messages. This makes the fix of commit 097da1ab more generic, as well as ensuring no future regressions. * cfg.mk (sc_prohibit_useless_translation): New rule. * src/lxc/lxc_driver.c (lxcSetVcpuBWLive): Fix offender. * src/openvz/openvz_conf.c (openvzReadFSConf): Likewise. * src/qemu/qemu_cgroup.c (qemuSetupCgroupForVcpu): Likewise. * src/qemu/qemu_driver.c (qemuSetVcpusBWLive): Likewise. * src/xenapi/xenapi_utils.c (xenapiSessionErrorHandle): Likewise.
Diffstat (limited to 'src/lxc')
-rw-r--r--src/lxc/lxc_driver.c5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/lxc/lxc_driver.c b/src/lxc/lxc_driver.c
index b58aeae63..ae024fe6f 100644
--- a/src/lxc/lxc_driver.c
+++ b/src/lxc/lxc_driver.c
@@ -2965,9 +2965,8 @@ cleanup:
if (period) {
rc = virCgroupSetCpuCfsPeriod(cgroup, old_period);
if (rc < 0)
- virReportSystemError(-rc,
- _("%s"),
- "Unable to rollback cpu bandwidth period");
+ virReportSystemError(-rc, "%s",
+ _("Unable to rollback cpu bandwidth period"));
}
return -1;