summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHu Tao <hutao@cn.fujitsu.com>2012-09-14 15:46:57 +0800
committerLaine Stump <laine@laine.org>2012-09-17 14:59:36 -0400
commit0fc89098a68f0f6962de8be4fc03ddd960ffbf08 (patch)
tree485b460ce771efa3f0fa07a544270a3350663f7c /tests/Makefile.am
parentbitmap: new member variable and function renaming (diff)
downloadlibvirt-0fc89098a68f0f6962de8be4fc03ddd960ffbf08.tar.gz
libvirt-0fc89098a68f0f6962de8be4fc03ddd960ffbf08.tar.bz2
libvirt-0fc89098a68f0f6962de8be4fc03ddd960ffbf08.zip
New functions for virBitmap
In many places we store bitmap info in a chunk of data (pointed to by a char *), and have redundant codes to set/unset bits. This patch extends virBitmap, and convert those codes to use virBitmap in subsequent patches.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c5cecaa38..8dbad97d0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -92,7 +92,8 @@ test_programs = virshtest sockettest \
viratomictest \
utiltest virnettlscontexttest shunloadtest \
virtimetest viruritest virkeyfiletest \
- virauthconfigtest
+ virauthconfigtest \
+ virbitmaptest
if WITH_SECDRIVER_SELINUX
test_programs += securityselinuxtest
@@ -589,6 +590,10 @@ viratomictest_SOURCES = \
viratomictest.c testutils.h testutils.c
viratomictest_LDADD = $(LDADDS)
+virbitmaptest_SOURCES = \
+ virbitmaptest.c testutils.h testutils.c
+virbitmaptest_LDADD = $(LDADDS)
+
jsontest_SOURCES = \
jsontest.c testutils.h testutils.c
jsontest_LDADD = $(LDADDS)