aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2009-04-03 10:55:51 +0000
committerDaniel P. Berrange <berrange@redhat.com>2009-04-03 10:55:51 +0000
commit11b0ed46c57dd8cd5f64e6acd70f402feb162d66 (patch)
tree7666dc7147457b40c5d1136ec70ddac615b1547a /tests/Makefile.am
parentFix mingw32 portability (diff)
downloadlibvirt-11b0ed46c57dd8cd5f64e6acd70f402feb162d66.tar.gz
libvirt-11b0ed46c57dd8cd5f64e6acd70f402feb162d66.tar.bz2
libvirt-11b0ed46c57dd8cd5f64e6acd70f402feb162d66.zip
Improve security label error reporting & verification (Dan Walsh)
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 28b273702..52d5c398e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -64,6 +64,10 @@ if WITH_QEMU
noinst_PROGRAMS += qemuxml2argvtest qemuxml2xmltest
endif
+if WITH_SECDRIVER_SELINUX
+noinst_PROGRAMS += seclabeltest
+endif
+
noinst_PROGRAMS += nodedevxml2xmltest
test_scripts = \
@@ -114,6 +118,10 @@ if WITH_QEMU
TESTS += qemuxml2argvtest qemuxml2xmltest
endif
+if WITH_SECDRIVER_SELINUX
+TESTS += seclabeltest
+endif
+
TESTS += nodedevxml2xmltest
path_add = $$abs_top_builddir/src$(PATH_SEPARATOR)$$abs_top_builddir/qemud
@@ -203,6 +211,14 @@ statstest_SOURCES = \
statstest.c testutils.h testutils.c
statstest_LDADD = $(LDADDS)
+if WITH_SECDRIVER_SELINUX
+seclabeltest_SOURCES = \
+ seclabeltest.c
+seclabeltest_LDADD = ../src/libvirt_driver_security.la $(LDADDS)
+else
+EXTRA_DIST += seclabeltest.c
+endif
+
qparamtest_SOURCES = \
qparamtest.c testutils.h testutils.c
qparamtest_LDADD = $(LDADDS)