aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-09-22 14:29:00 -0600
committerEric Blake <eblake@redhat.com>2011-10-20 16:02:16 -0600
commit27b3b303d966a7dff3bf7219e253dbefd814f97d (patch)
tree00387bd8fcd0b5b83b74b1b7d60458f761cd1075 /tests/Makefile.am
parentsnapshot: indent domain xml when nesting (diff)
downloadlibvirt-27b3b303d966a7dff3bf7219e253dbefd814f97d.tar.gz
libvirt-27b3b303d966a7dff3bf7219e253dbefd814f97d.tar.bz2
libvirt-27b3b303d966a7dff3bf7219e253dbefd814f97d.zip
snapshot: test domainsnapshot indentation
Add a test for the simple parts of my indentation changes, and fix the fallout. * tests/domainsnapshotxml2xmltest.c: New test. * tests/Makefile.am (domainsnapshotxml2xmltest_SOURCES): Build it. * src/conf/domain_conf.c (virDomainSnapshotDefFormat): Avoid NULL deref, match documented order. * src/conf/domain_conf.h (virDomainSnapshotDefFormat): Add const. * tests/domainsnapshotxml2xmlout/all_parameters.xml: Tweak output. * tests/domainsnapshotxml2xmlout/disk_snapshot.xml: Likewise. * tests/domainsnapshotxml2xmlout/full_domain.xml: Likewise. * .gitignore: Exempt new binary.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b52211865..6bff670a9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -109,7 +109,8 @@ check_PROGRAMS += xml2sexprtest sexpr2xmltest \
xmconfigtest xencapstest statstest reconnect
endif
if WITH_QEMU
-check_PROGRAMS += qemuxml2argvtest qemuxml2xmltest qemuxmlnstest qemuargv2xmltest qemuhelptest
+check_PROGRAMS += qemuxml2argvtest qemuxml2xmltest qemuxmlnstest \
+ qemuargv2xmltest qemuhelptest domainsnapshotxml2xmltest
endif
if WITH_OPENVZ
@@ -234,8 +235,8 @@ TESTS += xml2sexprtest \
endif
if WITH_QEMU
-TESTS += qemuxml2argvtest qemuxml2xmltest qemuxmlnstest qemuargv2xmltest qemuhelptest
-TESTS += nwfilterxml2xmltest
+TESTS += qemuxml2argvtest qemuxml2xmltest qemuxmlnstest qemuargv2xmltest \
+ qemuhelptest domainsnapshotxml2xmltest nwfilterxml2xmltest
endif
if WITH_OPENVZ
@@ -362,8 +363,15 @@ qemuargv2xmltest_LDADD = $(qemu_LDADDS) $(LDADDS)
qemuhelptest_SOURCES = qemuhelptest.c testutils.c testutils.h
qemuhelptest_LDADD = $(qemu_LDADDS) $(LDADDS)
+
+domainsnapshotxml2xmltest_SOURCES = \
+ domainsnapshotxml2xmltest.c testutilsqemu.c testutilsqemu.h \
+ testutils.c testutils.h
+domainsnapshotxml2xmltest_LDADD = $(qemu_LDADDS) $(LDADDS)
else
-EXTRA_DIST += qemuxml2argvtest.c qemuxml2xmltest.c qemuxmlnstest.c qemuargv2xmltest.c qemuhelptest.c testutilsqemu.c testutilsqemu.h
+EXTRA_DIST += qemuxml2argvtest.c qemuxml2xmltest.c qemuargv2xmltest.c \
+ qemuxmlnstest.c qemuhelptest.c domainsnapshotxml2xmltest.c \
+ testutilsqemu.c testutilsqemu.h
endif
if WITH_OPENVZ