aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2009-05-12 16:45:14 +0000
committerDaniel P. Berrange <berrange@redhat.com>2009-05-12 16:45:14 +0000
commit37ede4d5f54f2a8be11cb0666fc8587e9ce100ba (patch)
treed8e395ac26b4d44d0ca5a22920b3234f3443abdb /tests/Makefile.am
parentFix watch/timer event deletion (diff)
downloadlibvirt-37ede4d5f54f2a8be11cb0666fc8587e9ce100ba.tar.gz
libvirt-37ede4d5f54f2a8be11cb0666fc8587e9ce100ba.tar.bz2
libvirt-37ede4d5f54f2a8be11cb0666fc8587e9ce100ba.zip
Add test case for exercising the event loop
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 52d5c398e..3cb705619 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -122,6 +122,11 @@ if WITH_SECDRIVER_SELINUX
TESTS += seclabeltest
endif
+if WITH_LIBVIRTD
+noinst_PROGRAMS += eventtest
+TESTS += eventtest
+endif
+
TESTS += nodedevxml2xmltest
path_add = $$abs_top_builddir/src$(PATH_SEPARATOR)$$abs_top_builddir/qemud
@@ -223,4 +228,10 @@ qparamtest_SOURCES = \
qparamtest.c testutils.h testutils.c
qparamtest_LDADD = $(LDADDS)
+if WITH_LIBVIRTD
+eventtest_SOURCES = \
+ eventtest.c testutils.h testutils.c ../qemud/event.c
+eventtest_LDADD = -lrt $(LDADDS)
+endif
+
CLEANFILES = *.cov *.gcov .libs/*.gcda .libs/*.gcno *.gcno *.gcda