aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2009-02-24 14:58:32 +0000
committerMark McLoughlin <markmc@redhat.com>2009-02-24 14:58:32 +0000
commitda61daa2e6dd474f2a6074dc49e1a68597aac14e (patch)
tree3ec572c2477f8eff1becf86d9d9d6e90e71d2305 /tests/Makefile.am
parentAdd virNodeDeviceDefParseString() (diff)
downloadlibvirt-da61daa2e6dd474f2a6074dc49e1a68597aac14e.tar.gz
libvirt-da61daa2e6dd474f2a6074dc49e1a68597aac14e.tar.bz2
libvirt-da61daa2e6dd474f2a6074dc49e1a68597aac14e.zip
Add nodedevxml2xml test
Add a test to check node device XML parsing by first parsing the XML, then re-formatting as XML and finally comparing the resulting XML to the original XML.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 877884f33..bec4f6054 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -64,6 +64,8 @@ if WITH_QEMU
noinst_PROGRAMS += qemuxml2argvtest qemuxml2xmltest
endif
+noinst_PROGRAMS += nodedevxml2xmltest
+
test_scripts = \
capabilityschematest \
networkschematest \
@@ -110,6 +112,8 @@ if WITH_QEMU
TESTS += qemuxml2argvtest qemuxml2xmltest
endif
+TESTS += nodedevxml2xmltest
+
path_add = $$abs_top_builddir/src$(PATH_SEPARATOR)$$abs_top_builddir/qemud
# NB, automake < 1.10 does not provide the real
@@ -175,6 +179,11 @@ else
EXTRA_DIST += qemuxml2argvtest.c qemuxml2xmltest.c testutilsqemu.c testutilsqemu.h
endif
+nodedevxml2xmltest_SOURCES = \
+ nodedevxml2xmltest.c \
+ testutils.c testutils.h
+nodedevxml2xmltest_LDADD = ../src/libvirt_driver_qemu.la $(LDADDS)
+
virshtest_SOURCES = \
virshtest.c \
testutils.c testutils.h