summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-12-10 08:09:13 -0700
committerEric Blake <eblake@redhat.com>2010-12-10 08:44:53 -0700
commit2a5ccbefb0cdce1eb4f23aff39ca04181e068cc3 (patch)
treebbabdb16f7a43e7f7ed7516cf7172f6441369566 /tests/commandtest.c
parentUpdate documentation of watchdog dump option and add test data for it (diff)
downloadlibvirt-2a5ccbefb0cdce1eb4f23aff39ca04181e068cc3.tar.gz
libvirt-2a5ccbefb0cdce1eb4f23aff39ca04181e068cc3.tar.bz2
libvirt-2a5ccbefb0cdce1eb4f23aff39ca04181e068cc3.zip
build: distribute commandtest files
* tests/Makefile.am (SUBDIRS): Add commanddata. * tests/commandtest.c (checkoutput): Delete correct file. (test4): Delete pid file. (mymain): Delete unused variable. * tests/commanddata/Makefile.am: New file. * configure.ac (AC_OUTPUT): Build new makefile. Reported by Dominik Klein.
Diffstat (limited to 'tests/commandtest.c')
-rw-r--r--tests/commandtest.c9
1 files changed, 2 insertions, 7 deletions
diff --git a/tests/commandtest.c b/tests/commandtest.c
index e95620500..a1bcf688e 100644
--- a/tests/commandtest.c
+++ b/tests/commandtest.c
@@ -86,7 +86,7 @@ static int checkoutput(const char *testname)
ret = 0;
cleanup:
- unlink(actuallog);
+ unlink(actualname);
VIR_FREE(actuallog);
VIR_FREE(actualname);
VIR_FREE(expectlog);
@@ -248,6 +248,7 @@ static int test4(const void *unused ATTRIBUTE_UNUSED)
cleanup:
virCommandFree(cmd);
+ unlink(pidfile);
VIR_FREE(pidfile);
return ret;
}
@@ -707,12 +708,6 @@ mymain(int argc, char **argv)
1, NAME, NULL) < 0) \
ret = -1
- char *actualname;
- if (virAsprintf(&actualname, "%s/commandhelper.log", abs_builddir) < 0)
- return EXIT_FAILURE;
- unlink(actualname);
- VIR_FREE(actualname);
-
DO_TEST(test0);
DO_TEST(test1);
DO_TEST(test2);