summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2010-12-06 17:03:35 +0000
committerDaniel P. Berrange <berrange@redhat.com>2011-06-24 11:48:18 +0100
commit58b5b14e5e19839885342bc43da8de4129dd3548 (patch)
tree5890da80067dabbe366e38e99d685212efb6ad98 /tests/ssh.c
parentProvide a simple object for encoding/decoding RPC messages (diff)
downloadlibvirt-58b5b14e5e19839885342bc43da8de4129dd3548.tar.gz
libvirt-58b5b14e5e19839885342bc43da8de4129dd3548.tar.bz2
libvirt-58b5b14e5e19839885342bc43da8de4129dd3548.zip
Introduce a generic object for using network sockets
Introduces a simple wrapper around the raw POSIX sockets APIs and name resolution APIs. Allows for easy creation of client and server sockets with correct usage of name resolution APIs for protocol agnostic socket setup. It can listen for UNIX and TCP stream sockets. It can connect to UNIX, TCP streams directly, or indirectly to UNIX sockets via an SSH tunnel or external command * src/Makefile.am: Add to libvirt-net-rpc.la * src/rpc/virnetsocket.c, src/rpc/virnetsocket.h: Generic sockets APIs * tests/Makefile.am: Add socket test * tests/virnetsockettest.c: New test case * tests/testutils.c: Avoid overriding LIBVIRT_DEBUG settings * tests/ssh.c: Dumb helper program for SSH tunnelling tests
Diffstat (limited to 'tests/ssh.c')
-rw-r--r--tests/ssh.c54
1 files changed, 54 insertions, 0 deletions
diff --git a/tests/ssh.c b/tests/ssh.c
new file mode 100644
index 000000000..08bb63d8a
--- /dev/null
+++ b/tests/ssh.c
@@ -0,0 +1,54 @@
+/*
+ * Copyright (C) 2011 Red Hat, Inc.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ *
+ * Author: Daniel P. Berrange <berrange@redhat.com>
+ */
+
+#include <config.h>
+
+#include <stdio.h>
+#include "internal.h"
+
+int main(int argc, char **argv)
+{
+ int i;
+ int failConnect = 0; /* Exit -1, with no data on stdout, msg on stderr */
+ int dieEarly = 0; /* Exit -1, with partial data on stdout, msg on stderr */
+
+ for (i = 1 ; i < argc ; i++) {
+ if (STREQ(argv[i], "nosuchhost"))
+ failConnect = 1;
+ else if (STREQ(argv[i], "crashinghost"))
+ dieEarly = 1;
+ }
+
+ if (failConnect) {
+ fprintf(stderr, "%s", "Cannot connect to host nosuchhost\n");
+ return -1;
+ }
+
+ if (dieEarly) {
+ printf("%s\n", "Hello World");
+ fprintf(stderr, "%s", "Hangup from host\n");
+ return -1;
+ }
+
+ for (i = 1 ; i < argc ; i++)
+ printf("%s%c", argv[i], i == (argc -1) ? '\n' : ' ');
+
+ return 0;
+}