summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-11-14 10:35:58 +0000
committerJim Meyering <meyering@redhat.com>2007-11-14 10:35:58 +0000
commit5a6571eba978a727ff9e5429bcef7e374d503414 (patch)
treef36070aad469d380d059d030922e675af054c459 /tests/test_conf.sh
parentremove all trailing white space (diff)
downloadlibvirt-5a6571eba978a727ff9e5429bcef7e374d503414.tar.gz
libvirt-5a6571eba978a727ff9e5429bcef7e374d503414.tar.bz2
libvirt-5a6571eba978a727ff9e5429bcef7e374d503414.zip
Arrange for tests to pass in a non-srcdir build.
* tests/Makefile.am: Include the contents of the *data directories in the make-dist-built tarball by adding each of that *data directories to EXTRA_DIST. Also add int-overflow (via $(test_scripts)) to EXTRA_DIST. * tests/nodeinfotest.c: Prepend "$abs_top_srcdir/tests" to each input file name. * tests/qemuxml2argvtest.c: Likewise. * tests/qemuxml2xmltest.c: Likewise. * tests/sexpr2xmltest.c: Likewise. * tests/test_conf.sh: Likewise. * tests/virshtest.c: Likewise. * tests/xencapstest.c: Likewise. * tests/xmconfigtest.c: Likewise. * tests/xml2sexprtest.c: Likewise. Author: Jim Meyering <meyering@redhat.com>
Diffstat (limited to 'tests/test_conf.sh')
-rwxr-xr-xtests/test_conf.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/test_conf.sh b/tests/test_conf.sh
index b5a636633..7735a666a 100755
--- a/tests/test_conf.sh
+++ b/tests/test_conf.sh
@@ -1,9 +1,10 @@
#!/bin/bash
+set -x
NOK=0
-for f in confdata/*.conf
+for f in $abs_top_srcdir/tests/confdata/*.conf
do
./conftest $f > conftest.$$
- outfile=`echo $f | sed s+\.conf+\.out+`
+ outfile=`echo "$f" | sed s+\.conf$+\.out+`
diff $outfile conftest.$$ > /dev/null
if [ $? != 0 ]
then