aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-02-02 16:16:43 -0700
committerEric Blake <eblake@redhat.com>2012-02-03 10:41:46 -0700
commit8fe454ce90899945b1d16674668a0208657b6e61 (patch)
tree80cf4fbffcfab6e8d6ff43b1064e111cbafefdc9 /tests/testutils.h
parentbuild: prohibit raw malloc and free (diff)
downloadlibvirt-8fe454ce90899945b1d16674668a0208657b6e61.tar.gz
libvirt-8fe454ce90899945b1d16674668a0208657b6e61.tar.bz2
libvirt-8fe454ce90899945b1d16674668a0208657b6e61.zip
build: expand rule to cover testsuite
The bulk of this patch was done with: sed -i 's/\(\bfree *(/VIR_FREE(/g' tests/*.c followed by fixing the few compile errors that resulted. * cfg.mk (exclude_file_name_regexp--sc_prohibit_raw_allocation): Remove tests from exemption. * tests/testutils.h: Add common header. * tests/commandhelper.c: Fix offenders. * tests/cputest.c: Likewise. * tests/domainsnapshotxml2xmltest.c: Likewise. * tests/interfacexml2xmltest.c: Likewise. * tests/networkxml2argvtest.c: Likewise. * tests/networkxml2xmltest.c: Likewise. * tests/nodedevxml2xmltest.c: Likewise. * tests/nodeinfotest.c: Likewise. * tests/nwfilterxml2xmltest.c: Likewise. * tests/qemuargv2xmltest.c: Likewise. * tests/qemuxml2argvtest.c: Likewise. * tests/qemuxml2xmltest.c: Likewise. * tests/qemuxmlnstest.c: Likewise. * tests/qparamtest.c: Likewise. * tests/sexpr2xmltest.c: Likewise. * tests/storagepoolxml2xmltest.c: Likewise. * tests/storagevolxml2xmltest.c: Likewise. * tests/testutils.c: Likewise. * tests/virshtest.c: Likewise. * tests/xencapstest.c: Likewise. * tests/xmconfigtest.c: Likewise. * tests/xml2sexprtest.c: Likewise.
Diffstat (limited to 'tests/testutils.h')
-rw-r--r--tests/testutils.h3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/testutils.h b/tests/testutils.h
index 03d8dc688..2fde1b575 100644
--- a/tests/testutils.h
+++ b/tests/testutils.h
@@ -1,7 +1,7 @@
/*
* utils.c: test utils
*
- * Copyright (C) 2005, 2008-2011 Red Hat, Inc.
+ * Copyright (C) 2005, 2008-2012 Red Hat, Inc.
*
* See COPYING.LIB for the License of this software
*
@@ -12,6 +12,7 @@
# define __VIT_TEST_UTILS_H__
# include <stdio.h>
+# include "memory.h"
# define EXIT_AM_SKIP 77 /* tell Automake we're skipping a test */
# define EXIT_AM_HARDFAIL 99 /* tell Automake that the framework is broken */