summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2007-11-26 12:03:34 +0000
committerRichard W.M. Jones <rjones@redhat.com>2007-11-26 12:03:34 +0000
commitb7641686a6844415d38b5930d1e3d2dacea44d42 (patch)
treeee193ffb599f58f548328f6a56b4a0f9f7282600 /tests/xencapstest.c
parentMon Nov 26 11:56:00 UTC 2007 Richard W.M. Jones <rjones@redhat.com> (diff)
downloadlibvirt-b7641686a6844415d38b5930d1e3d2dacea44d42.tar.gz
libvirt-b7641686a6844415d38b5930d1e3d2dacea44d42.tar.bz2
libvirt-b7641686a6844415d38b5930d1e3d2dacea44d42.zip
Mon Nov 26 12:03:00 UTC 2007 Richard W.M. Jones <rjones@redhat.com>
* tests/Makefile.am, tests/nodeinfotest.c, tests/qemuxml2argvtest.c, tests/qemuxml2xmltest.c, tests/sexpr2xmltest.c, tests/virshtest.c, tests/xencapstest.c, tests/xmconfigtest.c, tests/xml2sexprtest.c: Miscellaneous fixes to the tests to compile under Cygwin.
Diffstat (limited to 'tests/xencapstest.c')
-rw-r--r--tests/xencapstest.c6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/xencapstest.c b/tests/xencapstest.c
index 5744262bc..bbf5976e2 100644
--- a/tests/xencapstest.c
+++ b/tests/xencapstest.c
@@ -1,7 +1,11 @@
+#include "config.h"
+
#include <stdio.h>
#include <stdlib.h>
-#include "config.h"
+#ifdef HAVE_SYS_SYSLIMITS_H
+#include <sys/syslimits.h>
+#endif
#ifdef WITH_XEN