summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-12-16 11:24:00 -0700
committerEric Blake <eblake@redhat.com>2010-12-17 11:57:11 -0700
commit65532f4558abf88f80204762e29cfa8f8ee47ca3 (patch)
treeea9acec6f7d4844d303475bf0e47f6b62194a656 /tests
parentbuild: fix typo that broke 'make dist' (diff)
downloadlibvirt-65532f4558abf88f80204762e29cfa8f8ee47ca3.tar.gz
libvirt-65532f4558abf88f80204762e29cfa8f8ee47ca3.tar.bz2
libvirt-65532f4558abf88f80204762e29cfa8f8ee47ca3.zip
maint: improve tests distribution
* tests/Makefile.am (EXTRA_DIST): Sort, and add directories. (SUBDIRS): Drop automake recursion into subdirs. * tests/commanddata/Makefile.am: Delete. * tests/confdata/Makefile.am: Likewise. * tests/sexpr2xmldata/Makefile.am: Likewise. * tests/xencapsdata/Makefile.am: Likewise. * tests/xmconfigdata/Makefile.am: Likewise. * tests/xml2sexprdata/Makefile.am: Likewise.
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am57
-rw-r--r--tests/commanddata/Makefile.am2
-rw-r--r--tests/confdata/Makefile.am2
-rw-r--r--tests/sexpr2xmldata/Makefile.am2
-rw-r--r--tests/xencapsdata/Makefile.am3
-rw-r--r--tests/xmconfigdata/Makefile.am2
-rw-r--r--tests/xml2sexprdata/Makefile.am2
7 files changed, 30 insertions, 40 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0a235cfcc..de2ff913d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,9 +2,6 @@
SHELL = $(PREFERABLY_POSIX_SHELL)
-SUBDIRS = commanddata confdata sexpr2xmldata \
- xml2sexprdata xmconfigdata xencapsdata
-
INCLUDES = \
-I$(top_srcdir)/gnulib/lib -I../gnulib/lib \
-I$(top_builddir)/include \
@@ -39,38 +36,44 @@ LDADDS = \
$(COVERAGE_LDFLAGS)
EXTRA_DIST = \
- oomtrace.pl \
- test-lib.sh \
- qemuxml2argvdata \
- qemuxml2xmloutdata \
- nodeinfodata \
- schematestutils.sh \
- capabilityschematest \
capabilityschemadata \
- networkschematest \
- networkxml2xmlout \
- networkxml2xmlin \
- domainschematest \
+ capabilityschematest \
+ commanddata \
+ confdata \
+ cputestdata \
domainschemadata \
+ domainschematest \
+ domainsnapshotschematest \
+ domainsnapshotxml2xmlin \
+ domainsnapshotxml2xmlout \
interfaceschemadata \
+ networkschematest \
+ networkxml2xmlin \
+ networkxml2xmlout \
+ nodedevschemadata \
+ nodedevschematest \
+ nodeinfodata \
+ nwfilterschematest \
+ nwfilterxml2xmlin \
+ nwfilterxml2xmlout \
+ oomtrace.pl \
+ qemuhelpdata \
+ qemuxml2argvdata \
+ qemuxml2xmloutdata \
+ schematestutils.sh \
+ sexpr2xmldata \
storagepoolschematest \
- storagepoolxml2xmlout \
storagepoolxml2xmlin \
+ storagepoolxml2xmlout \
storagevolschematest \
- storagevolxml2xmlout \
storagevolxml2xmlin \
- nodedevschematest \
- nodedevschemadata \
+ storagevolxml2xmlout \
+ test-lib.sh \
vmx2xmldata \
- xml2vmxdata \
- nwfilterxml2xmlout \
- nwfilterxml2xmlin \
- nwfilterschematest \
- domainsnapshotschematest \
- domainsnapshotxml2xmlout \
- domainsnapshotxml2xmlin \
- qemuhelpdata \
- cputestdata
+ xencapsdata \
+ xmconfigdata \
+ xml2sexprdata \
+ xml2vmxdata
check_PROGRAMS = virshtest conftest sockettest \
nodeinfotest qparamtest virbuftest \
diff --git a/tests/commanddata/Makefile.am b/tests/commanddata/Makefile.am
deleted file mode 100644
index ea0f8e11f..000000000
--- a/tests/commanddata/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/*.log))
diff --git a/tests/confdata/Makefile.am b/tests/confdata/Makefile.am
deleted file mode 100644
index eaaadbc8b..000000000
--- a/tests/confdata/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/*.out $(srcdir)/*.conf))
diff --git a/tests/sexpr2xmldata/Makefile.am b/tests/sexpr2xmldata/Makefile.am
deleted file mode 100644
index db43109dd..000000000
--- a/tests/sexpr2xmldata/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/*.xml $(srcdir)/*.sexpr))
diff --git a/tests/xencapsdata/Makefile.am b/tests/xencapsdata/Makefile.am
deleted file mode 100644
index ed08bc421..000000000
--- a/tests/xencapsdata/Makefile.am
+++ /dev/null
@@ -1,3 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard \
- $(srcdir)/*.xml $(srcdir)/*.cpuinfo $(srcdir)/*.caps))
diff --git a/tests/xmconfigdata/Makefile.am b/tests/xmconfigdata/Makefile.am
deleted file mode 100644
index af0cb0917..000000000
--- a/tests/xmconfigdata/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/*.xml $(srcdir)/*.cfg))
diff --git a/tests/xml2sexprdata/Makefile.am b/tests/xml2sexprdata/Makefile.am
deleted file mode 100644
index 20028bbb2..000000000
--- a/tests/xml2sexprdata/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = \
- $(patsubst $(srcdir)/%,%,$(wildcard $(srcdir)/*.xml $(srcdir)/*.sexpr))