summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--configure.in2
-rw-r--r--m4/.cvsignore3
-rw-r--r--m4/Makefile.am3
-rw-r--r--m4/compiler-flags.m434
5 files changed, 42 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 630762356..e1e688416 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = src qemud proxy include docs @PYTHON_SUBDIR@ tests po scripts
+SUBDIRS = src qemud proxy include docs @PYTHON_SUBDIR@ tests po m4 scripts
ACLOCAL_AMFLAGS = -I m4
diff --git a/configure.in b/configure.in
index 2cb1e98d9..21168d128 100644
--- a/configure.in
+++ b/configure.in
@@ -305,7 +305,7 @@ AC_OUTPUT(Makefile src/Makefile include/Makefile docs/Makefile \
po/Makefile.in scripts/Makefile \
include/libvirt/Makefile include/libvirt/libvirt.h \
python/Makefile python/tests/Makefile \
- qemud/Makefile \
+ qemud/Makefile m4/Makefile \
tests/Makefile proxy/Makefile \
tests/xml2sexprdata/Makefile \
tests/sexpr2xmldata/Makefile \
diff --git a/m4/.cvsignore b/m4/.cvsignore
new file mode 100644
index 000000000..0063d7a83
--- /dev/null
+++ b/m4/.cvsignore
@@ -0,0 +1,3 @@
+*.m4
+Makefile
+Makefile.in
diff --git a/m4/Makefile.am b/m4/Makefile.am
new file mode 100644
index 000000000..188b2fe01
--- /dev/null
+++ b/m4/Makefile.am
@@ -0,0 +1,3 @@
+
+EXTRA_DIST = compiler-flags.m4
+
diff --git a/m4/compiler-flags.m4 b/m4/compiler-flags.m4
new file mode 100644
index 000000000..cf4cba938
--- /dev/null
+++ b/m4/compiler-flags.m4
@@ -0,0 +1,34 @@
+# serial 3
+# Find valid warning flags for the C Compiler. -*-Autoconf-*-
+#
+# Copyright (C) 2001, 2002, 2006 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+# 02110-1301 USA
+
+# Written by Jesse Thilo.
+
+AC_DEFUN([gl_COMPILER_FLAGS],
+ [AC_MSG_CHECKING(whether compiler accepts $1)
+ AC_SUBST(COMPILER_FLAGS)
+ ac_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $1"
+ AC_TRY_COMPILE(,
+ [int x;],
+ COMPILER_FLAGS="$COMPILER_FLAGS $1"
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no))
+ CFLAGS="$ac_save_CFLAGS"
+ ])