aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--AUTHORS1
-rw-r--r--src/Makefile.am1
-rw-r--r--src/cpu/cpu.c2
-rw-r--r--src/cpu/cpu_arm.c75
-rw-r--r--src/cpu/cpu_arm.h31
5 files changed, 110 insertions, 0 deletions
diff --git a/AUTHORS b/AUTHORS
index 7eaeb26d4..43cc0a17f 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -248,6 +248,7 @@ Patches have also been contributed by:
Thang Pham <thang.pham@us.ibm.com>
Eiichi Tsukata <eiichi.tsukata.xh@hitachi.com>
Sascha Peilicke <saschpe@suse.de>
+ Chuck Short <chuck.short@canonical.com>
[....send patches to get your name here....]
diff --git a/src/Makefile.am b/src/Makefile.am
index 6c3eaa75c..bfe74d39f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -567,6 +567,7 @@ CPU_SOURCES = \
cpu/cpu_generic.h cpu/cpu_generic.c \
cpu/cpu_x86.h cpu/cpu_x86.c cpu/cpu_x86_data.h \
cpu/cpu_s390.h cpu/cpu_s390.c \
+ cpu/cpu_arm.h cpu/cpu_arm.c \
cpu/cpu_map.h cpu/cpu_map.c cpu/cpu_powerpc.h \
cpu/cpu_powerpc.c
diff --git a/src/cpu/cpu.c b/src/cpu/cpu.c
index 70a1da5c4..0ccbd4cfd 100644
--- a/src/cpu/cpu.c
+++ b/src/cpu/cpu.c
@@ -30,6 +30,7 @@
#include "cpu_x86.h"
#include "cpu_powerpc.h"
#include "cpu_s390.h"
+#include "cpu_arm.h"
#include "cpu_generic.h"
@@ -40,6 +41,7 @@ static struct cpuArchDriver *drivers[] = {
&cpuDriverX86,
&cpuDriverPowerPC,
&cpuDriverS390,
+ &cpuDriverArm,
/* generic driver must always be the last one */
&cpuDriverGeneric
};
diff --git a/src/cpu/cpu_arm.c b/src/cpu/cpu_arm.c
new file mode 100644
index 000000000..d6c991f36
--- /dev/null
+++ b/src/cpu/cpu_arm.c
@@ -0,0 +1,75 @@
+/*
+ * cpu_arm.c: CPU driver for arm CPUs
+ *
+ * Copyright (C) Canonical Ltd. 2012
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ *
+ * Authors:
+ * Chuck Short <chuck.short@canonical.com>
+ */
+
+#include <config.h>
+
+#include "memory.h"
+#include "cpu.h"
+
+#define VIR_FROM_THIS VIR_FROM_CPU
+
+static const char *archs[] = { "armv7l" };
+
+static union cpuData *
+ArmNodeData(void)
+{
+ union cpuData *data;
+
+ if (VIR_ALLOC(data) < 0) {
+ virReportOOMError();
+ return NULL;
+ }
+
+ return data;
+}
+
+static int
+ArmDecode(virCPUDefPtr cpu ATTRIBUTE_UNUSED,
+ const union cpuData *data ATTRIBUTE_UNUSED,
+ const char **models ATTRIBUTE_UNUSED,
+ unsigned int nmodels ATTRIBUTE_UNUSED,
+ const char *preferred ATTRIBUTE_UNUSED)
+{
+ return 0;
+}
+
+static void
+ArmDataFree(union cpuData *data)
+{
+ VIR_FREE(data);
+}
+
+struct cpuArchDriver cpuDriverArm = {
+ .name = "arm",
+ .arch = archs,
+ .narch = ARRAY_CARDINALITY(archs),
+ .compare = NULL,
+ .decode = ArmDecode,
+ .encode = NULL,
+ .free = ArmDataFree,
+ .nodeData = ArmNodeData,
+ .guestData = NULL,
+ .baseline = NULL,
+ .update = NULL,
+ .hasFeature = NULL,
+};
diff --git a/src/cpu/cpu_arm.h b/src/cpu/cpu_arm.h
new file mode 100644
index 000000000..6c3b3d384
--- /dev/null
+++ b/src/cpu/cpu_arm.h
@@ -0,0 +1,31 @@
+/*
+ * cpu_arm.h: CPU driver for arm CPUs
+ *
+ * Copyright (C) Canonical Ltd. 2012
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ *
+ * Authors:
+ * Chuck Short <chuck.short@canonical.com>
+ */
+
+#ifndef __VIR_CPU_ARM_H__
+# define __VIR_CPU_ARM_H__
+
+# include "cpu.h"
+
+extern struct cpuArchDriver cpuDriverArm;
+
+#endif /* __VIR_CPU_ARM_H__ */