summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-11-01 15:48:10 -0400
committerMike Pagano <mpagano@gentoo.org>2022-11-01 15:48:10 -0400
commit3b94aa7caf5c24407c43d7d510eae189a18f1bf8 (patch)
tree24b30585d3bd41d32cbf968d3535665e3b042758
parentLinux patch 4.19.262 (diff)
downloadlinux-patches-3b94aa7caf5c24407c43d7d510eae189a18f1bf8.tar.gz
linux-patches-3b94aa7caf5c24407c43d7d510eae189a18f1bf8.tar.bz2
linux-patches-3b94aa7caf5c24407c43d7d510eae189a18f1bf8.zip
Linux patch 4.19.2634.19-262
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1262_linux-4.19.263.patch26
2 files changed, 30 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 6baf37a1..b1528289 100644
--- a/0000_README
+++ b/0000_README
@@ -1091,6 +1091,10 @@ Patch: 1261_linux-4.19.262.patch
From: https://www.kernel.org
Desc: Linux 4.19.262
+Patch: 1262_linux-4.19.263.patch
+From: https://www.kernel.org
+Desc: Linux 4.19.263
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1262_linux-4.19.263.patch b/1262_linux-4.19.263.patch
new file mode 100644
index 00000000..af6440db
--- /dev/null
+++ b/1262_linux-4.19.263.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index 08c9d316e5c21..8a517dd456f4c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 4
+ PATCHLEVEL = 19
+-SUBLEVEL = 262
++SUBLEVEL = 263
+ EXTRAVERSION =
+ NAME = "People's Front"
+
+diff --git a/include/linux/once.h b/include/linux/once.h
+index bb58e1c3aa034..3a6671d961b98 100644
+--- a/include/linux/once.h
++++ b/include/linux/once.h
+@@ -64,7 +64,7 @@ void __do_once_slow_done(bool *done, struct static_key_true *once_key,
+ #define DO_ONCE_SLOW(func, ...) \
+ ({ \
+ bool ___ret = false; \
+- static bool __section(".data.once") ___done = false; \
++ static bool __section(.data.once) ___done = false; \
+ static DEFINE_STATIC_KEY_TRUE(___once_key); \
+ if (static_branch_unlikely(&___once_key)) { \
+ ___ret = __do_once_slow_start(&___done); \