summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/kicktoo/ChangeLog5
-rw-r--r--sys-apps/kicktoo/Manifest3
-rw-r--r--sys-apps/kicktoo/kicktoo-0.4.4.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/kicktoo/ChangeLog b/sys-apps/kicktoo/ChangeLog
index 6a58f34..aa14253 100644
--- a/sys-apps/kicktoo/ChangeLog
+++ b/sys-apps/kicktoo/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*kicktoo-0.4.4 (02 08 2012)
+
+ 02 08 2012; Wim Muskee wimmuskee@gmail.com kicktoo-0.4.4.ebuild:
+ Version bump
+
27 07 2012; Wim Muskee wimmuskee@gmail.com kicktoo-0.4.3.ebuild:
Stable for amd64 and x86.
diff --git a/sys-apps/kicktoo/Manifest b/sys-apps/kicktoo/Manifest
index a6160cf..ba0563c 100644
--- a/sys-apps/kicktoo/Manifest
+++ b/sys-apps/kicktoo/Manifest
@@ -1,3 +1,4 @@
EBUILD kicktoo-0.4.3.ebuild 1210 RMD160 494d60d9e5e70dbed93959740bdf6844e34fdc07 SHA1 226ef3a99a7341fa8092d5e6aca1e24656832eaa SHA256 5fc5567c347489a19966c765090e033227f561b0da7a85559682f0f4ce6bd216
-MISC ChangeLog 1242 RMD160 5bcbfeb1514112b356733cdccdf4aac0defad3e1 SHA1 bb9aa7c559de80c053d59e1f9eb912577146c1f0 SHA256 ba8fac9b86e7ef7e77511f2d87c28543f30083b6ec2096538ec3121e7cfb756e
+EBUILD kicktoo-0.4.4.ebuild 1212 RMD160 e63518826ab8ed364dc74ebdfcbb7a4086b4ceb8 SHA1 376585b4f73fee5aa14ac8af3d934cfc195f6168 SHA256 b2f28a89057f0c852e3753b09d0dcfee38f143e4925e65e36be1f7d386d9c5ab
+MISC ChangeLog 1354 RMD160 42521c8d65484152fd350d585417f89463b6488a SHA1 d0538a7d9b9faf4911e0fb13c80aa6cca439b53f SHA256 5af31552e54c52550bbcd4e60e260ab54d1b1a7b1ba92be20b4cabde28e3b33d
MISC metadata.xml 382 RMD160 7d0454eadd2e9753a6333c15e38ac99789cc96a5 SHA1 d18cc8ace105794a16037ca03146220127233b44 SHA256 fc0543d621cee14dbdb91a2003b86b803966ab496252752130f99056c2887c83
diff --git a/sys-apps/kicktoo/kicktoo-0.4.4.ebuild b/sys-apps/kicktoo/kicktoo-0.4.4.ebuild
new file mode 100644
index 0000000..037c8dd
--- /dev/null
+++ b/sys-apps/kicktoo/kicktoo-0.4.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit git-2
+
+EGIT_REPO_URI="git://github.com/r1k0/kicktoo.git"
+EGIT_COMMIT="3f88a45fc3"
+DESCRIPTION="A Portage based installer/profiler for Gentoo/Funtoo (/Exherbo RIP)"
+HOMEPAGE="https://github.com/r1k0/kicktoo"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# making the profiles optional, included by default
+# they are not required for the tool
+IUSE="crypt doc +examples server"
+RDEPEND="sys-block/parted
+ net-misc/curl
+ crypt? (
+ dev-libs/libgcrypt
+ dev-libs/popt
+ dev-libs/libgpg-error
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ )
+ server? (
+ dev-perl/HTTP-Daemon
+ )"
+
+src_install() {
+ ktdir=/usr/share/kicktoo
+
+ insinto ${ktdir}/modules
+ doins modules/*
+
+ dobin kicktoo
+
+ if use server; then
+ dobin daemon/kicktood
+
+ insinto /etc/kicktoo
+ doins daemon/kicktood.conf
+ fi
+
+ if use doc; then
+ dodoc README
+ dodoc TODO
+ newdoc profiles/config.txt profile-config.txt
+ fi
+
+ if use examples; then
+ insinto ${ktdir}/kbin
+ doins kbin/*
+ insinto ${ktdir}/kconfig
+ doins kconfig/*
+ insinto ${ktdir}/profiles
+ rm profiles/config.txt
+ doins -r profiles/*
+ fi
+}