summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kicktoo/kicktoo-0.4.3.ebuild')
-rw-r--r--sys-apps/kicktoo/kicktoo-0.4.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/kicktoo/kicktoo-0.4.3.ebuild b/sys-apps/kicktoo/kicktoo-0.4.3.ebuild
new file mode 100644
index 0000000..037c8dd
--- /dev/null
+++ b/sys-apps/kicktoo/kicktoo-0.4.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit git-2
+
+EGIT_REPO_URI="git://github.com/r1k0/kicktoo.git"
+EGIT_COMMIT="3f88a45fc3"
+DESCRIPTION="A Portage based installer/profiler for Gentoo/Funtoo (/Exherbo RIP)"
+HOMEPAGE="https://github.com/r1k0/kicktoo"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# making the profiles optional, included by default
+# they are not required for the tool
+IUSE="crypt doc +examples server"
+RDEPEND="sys-block/parted
+ net-misc/curl
+ crypt? (
+ dev-libs/libgcrypt
+ dev-libs/popt
+ dev-libs/libgpg-error
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ )
+ server? (
+ dev-perl/HTTP-Daemon
+ )"
+
+src_install() {
+ ktdir=/usr/share/kicktoo
+
+ insinto ${ktdir}/modules
+ doins modules/*
+
+ dobin kicktoo
+
+ if use server; then
+ dobin daemon/kicktood
+
+ insinto /etc/kicktoo
+ doins daemon/kicktood.conf
+ fi
+
+ if use doc; then
+ dodoc README
+ dodoc TODO
+ newdoc profiles/config.txt profile-config.txt
+ fi
+
+ if use examples; then
+ insinto ${ktdir}/kbin
+ doins kbin/*
+ insinto ${ktdir}/kconfig
+ doins kconfig/*
+ insinto ${ktdir}/profiles
+ rm profiles/config.txt
+ doins -r profiles/*
+ fi
+}