summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-02-16 01:44:18 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-02-16 01:45:06 +0700
commit240f299b118581b97778cc9e0a8d9a4618d71492 (patch)
tree92b55a8d675ec9b6b25e6f9e5055ac4fb051892b
parentdiscount: fix (diff)
downloadlua-240f299b118581b97778cc9e0a8d9a4618d71492.tar.gz
lua-240f299b118581b97778cc9e0a8d9a4618d71492.tar.bz2
lua-240f299b118581b97778cc9e0a8d9a4618d71492.zip
lyaml: supposed to be fix, but it is still brainfucking packages from @gvvaughan which can`t just work and aren`t easy to just fix them
-rw-r--r--dev-lua/lyaml/files/Makefile2
-rw-r--r--dev-lua/lyaml/lyaml-9999.ebuild1
2 files changed, 2 insertions, 1 deletions
diff --git a/dev-lua/lyaml/files/Makefile b/dev-lua/lyaml/files/Makefile
index d1f3027..3667fe6 100644
--- a/dev-lua/lyaml/files/Makefile
+++ b/dev-lua/lyaml/files/Makefile
@@ -1,4 +1,4 @@
all:
- $(LUA) build-aux/luke package=$(package) version=$(version) LUA_INCDIR="$(LUA_INCDIR)"
+ $(LUA) build-aux/luke package=$(package) version=$(version) LUA_INCDIR="$(LUA_INCDIR)" LYAML_DIR="$(LYAML_DIR)"
doc:
ldoc -c build-aux/config.ld.in .
diff --git a/dev-lua/lyaml/lyaml-9999.ebuild b/dev-lua/lyaml/lyaml-9999.ebuild
index 30e956c..1a35f58 100644
--- a/dev-lua/lyaml/lyaml-9999.ebuild
+++ b/dev-lua/lyaml/lyaml-9999.ebuild
@@ -54,6 +54,7 @@ each_lua_configure() {
package="${PN}"
version="${ver}"
LUA_INCDIR="$(lua_get_incdir)"
+ LYAML_DIR="${EROOT}usr"
)
lua_default
}