aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-12-23 16:05:03 -0500
committerIan Stakenvicius <axs@gentoo.org>2015-12-23 16:05:03 -0500
commit28e74fb7424b07df279c04dde353aeb69affe9be (patch)
tree6cfa525b01dc4fcd4d22f9919356618ca6331d2b
parentwww-client/firefox: make metadata.xml match gentoo repo (diff)
downloadmozilla-28e74fb7424b07df279c04dde353aeb69affe9be.tar.gz
mozilla-28e74fb7424b07df279c04dde353aeb69affe9be.tar.bz2
mozilla-28e74fb7424b07df279c04dde353aeb69affe9be.zip
migrate arm neon/softfp/hardfp config fixes to the eclass
The firefox ebuild received fixes for various arm configurations (neon, hardfp/softfp) but these fixes should also be applied to the other mozilla packages. This commit removes them from firefox and adds them to mozconfig.
-rw-r--r--eclass/mozconfig-v6.38.eclass20
-rw-r--r--eclass/mozconfig-v6.42.eclass18
-rw-r--r--www-client/firefox/firefox-42.0-r2.ebuild18
-rw-r--r--www-client/firefox/firefox-43.0.ebuild18
4 files changed, 37 insertions, 37 deletions
diff --git a/eclass/mozconfig-v6.38.eclass b/eclass/mozconfig-v6.38.eclass
index f7b4d9b4..ecd4578c 100644
--- a/eclass/mozconfig-v6.38.eclass
+++ b/eclass/mozconfig-v6.38.eclass
@@ -45,7 +45,7 @@ esac
# Set the variable to any value if the use flag should exist but not be default-enabled.
# use-flags common among all mozilla ebuilds
-IUSE="${IUSE} dbus debug gstreamer gstreamer-0 +jemalloc3 pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
+IUSE="${IUSE} dbus debug gstreamer gstreamer-0 +jemalloc3 neon pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
# some notes on deps:
# gtk:2 minimum is technically 2.10 but gio support (enabled by default) needs 2.14
@@ -207,8 +207,8 @@ mozconfig_config() {
mozconfig_annotate 'Gentoo default' --with-system-png
mozconfig_annotate '' --enable-system-ffi
mozconfig_annotate 'Gentoo default to honor system linker' --disable-gold
- mozconfig_annotate 'Gentoo default' --disable-skia
mozconfig_annotate '' --disable-gconf
+ mozconfig_annotate 'Gentoo default' --disable-skia
# Use jemalloc unless libc is not glibc >= 2.4
# at this time the minimum glibc in the tree is 2.9 so we should be safe.
@@ -237,4 +237,20 @@ mozconfig_config() {
mozconfig_use_with system-icu
mozconfig_use_enable system-icu intl-api
mozconfig_use_with system-libvpx
+
+ # Modifications to better support ARM, bug 553364
+ if use neon ; then
+ mozconfig_annotate '' --with-fpu=neon
+ mozconfig_annotate '' --with-thumb=yes
+ mozconfig_annotate '' --with-thumb-interwork=no
+ fi
+ if [[ ${CHOST} == armv* ]] ; then
+ mozconfig_annotate '' --with-float-abi=hard
+ mozconfig_annotate '' --enable-skia
+
+ if ! use system-libvpx ; then
+ sed -i -e "s|softfp|hard|" \
+ "${S}"/media/libvpx/moz.build
+ fi
+ fi
}
diff --git a/eclass/mozconfig-v6.42.eclass b/eclass/mozconfig-v6.42.eclass
index 7ed72831..1feea383 100644
--- a/eclass/mozconfig-v6.42.eclass
+++ b/eclass/mozconfig-v6.42.eclass
@@ -55,7 +55,7 @@ esac
# Set the variable to any value if the use flag should exist but not be default-enabled.
# use-flags common among all mozilla ebuilds
-IUSE="${IUSE} dbus debug +gstreamer gstreamer-0 +jemalloc3 pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
+IUSE="${IUSE} dbus debug +gstreamer gstreamer-0 +jemalloc3 neon pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
# some notes on deps:
# gtk:2 minimum is technically 2.10 but gio support (enabled by default) needs 2.14
@@ -263,4 +263,20 @@ mozconfig_config() {
mozconfig_use_with system-icu
mozconfig_use_enable system-icu intl-api
mozconfig_use_with system-libvpx
+
+ # Modifications to better support ARM, bug 553364
+ if use neon ; then
+ mozconfig_annotate '' --with-fpu=neon
+ mozconfig_annotate '' --with-thumb=yes
+ mozconfig_annotate '' --with-thumb-interwork=no
+ fi
+ if [[ ${CHOST} == armv* ]] ; then
+ mozconfig_annotate '' --with-float-abi=hard
+ mozconfig_annotate '' --enable-skia
+
+ if ! use system-libvpx ; then
+ sed -i -e "s|softfp|hard|" \
+ "${S}"/media/libvpx/moz.build
+ fi
+ fi
}
diff --git a/www-client/firefox/firefox-42.0-r2.ebuild b/www-client/firefox/firefox-42.0-r2.ebuild
index 4f7f2cd0..962b10c8 100644
--- a/www-client/firefox/firefox-42.0-r2.ebuild
+++ b/www-client/firefox/firefox-42.0-r2.ebuild
@@ -43,7 +43,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linu
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist egl hardened +minimal neon pgo selinux +gmp-autoupdate test"
+IUSE="bindist egl hardened +minimal pgo selinux +gmp-autoupdate test"
RESTRICT="!bindist? ( bindist )"
# More URIs appended below...
@@ -218,22 +218,6 @@ src_configure() {
# Add full relro support for hardened
use hardened && append-ldflags "-Wl,-z,relro,-z,now"
- if use neon ; then
- mozconfig_annotate '' --with-fpu=neon
- mozconfig_annotate '' --with-thumb=yes
- mozconfig_annotate '' --with-thumb-interwork=no
- fi
-
- if [[ ${CHOST} == armv* ]] ; then
- mozconfig_annotate '' --with-float-abi=hard
- mozconfig_annotate '' --enable-skia
-
- if ! use system-libvpx ; then
- sed -i -e "s|softfp|hard|" \
- "${S}"/media/libvpx/moz.build
- fi
- fi
-
use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
# Setup api key for location services
diff --git a/www-client/firefox/firefox-43.0.ebuild b/www-client/firefox/firefox-43.0.ebuild
index d63e5b26..24ec37a9 100644
--- a/www-client/firefox/firefox-43.0.ebuild
+++ b/www-client/firefox/firefox-43.0.ebuild
@@ -43,7 +43,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linu
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist egl hardened +hwaccel +minimal neon pgo selinux +gmp-autoupdate test"
+IUSE="bindist egl hardened +hwaccel +minimal pgo selinux +gmp-autoupdate test"
RESTRICT="!bindist? ( bindist )"
# More URIs appended below...
@@ -220,22 +220,6 @@ src_configure() {
# Add full relro support for hardened
use hardened && append-ldflags "-Wl,-z,relro,-z,now"
- if use neon ; then
- mozconfig_annotate '' --with-fpu=neon
- mozconfig_annotate '' --with-thumb=yes
- mozconfig_annotate '' --with-thumb-interwork=no
- fi
-
- if [[ ${CHOST} == armv* ]] ; then
- mozconfig_annotate '' --with-float-abi=hard
- mozconfig_annotate '' --enable-skia
-
- if ! use system-libvpx ; then
- sed -i -e "s|softfp|hard|" \
- "${S}"/media/libvpx/moz.build
- fi
- fi
-
use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
# Setup api key for location services