aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2019-08-29 13:46:35 -0500
committerJory Pratt <anarchy@gentoo.org>2019-08-29 13:46:35 -0500
commit4ec9c1922cf1cc48649dc1dbf85bb7088867ec35 (patch)
treedd53423578472e2c05c4d773ec1b1d51565e26be
parentmail-client/thunderbird: add 68.0 initial ebuild with p.mask (diff)
downloadmozilla-4ec9c1922cf1cc48649dc1dbf85bb7088867ec35.tar.gz
mozilla-4ec9c1922cf1cc48649dc1dbf85bb7088867ec35.tar.bz2
mozilla-4ec9c1922cf1cc48649dc1dbf85bb7088867ec35.zip
mail-client/thunderbird: misc cleanup to 68.0-r1
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--mail-client/thunderbird/metadata.xml21
-rw-r--r--mail-client/thunderbird/thunderbird-68.0-r1.ebuild19
2 files changed, 25 insertions, 15 deletions
diff --git a/mail-client/thunderbird/metadata.xml b/mail-client/thunderbird/metadata.xml
index 4f210969..4a67d290 100644
--- a/mail-client/thunderbird/metadata.xml
+++ b/mail-client/thunderbird/metadata.xml
@@ -6,13 +6,24 @@
<name>Gentoo Mozilla Team</name>
</maintainer>
<use>
- <flag name="bindist">Disable official Thunderbird branding (icons, name) which
+ <flag name="bindist">Disable official Firefox branding (icons, name) which
are not binary-redistributable according to upstream.</flag>
<flag name="clang">Use Clang compiler instead of GCC</flag>
- <flag name="lightning">Enable app-global calendar support
- (note 38.0 and above bundles calendar support when this flag is off)</flag>
<flag name="custom-optimization">Build with user-specified compiler optimizations
(-Os, -O0, -O1, -O2, -O3) from CFLAGS (unsupported)</flag>
+ <flag name="eme-free">Disable EME (DRM plugin) cabability at build time</flag>
+ <flag name="geckodriver">Enable WebDriver support</flag>
+ <flag name="gmp-autoupdate">Allow Gecko Media Plugins (binary blobs) to be automatically
+ downloaded and kept up-to-date in user profiles</flag>
+ <flag name="lightning">Enable app-global calendar support
+ (note 38.0 and above bundles calendar support when this flag is off)</flag>
+ <flag name="lto">Enable Link Time Optimization (LTO). Requires Gold linker when using GCC
+ or LDD linker when using Clang</flag>
+ <flag name="pgo">Add support for profile-guided optimization using gcc-4.5,
+ for faster binaries. This option will double the compile time.</flag>
+ <flag name="screenshot">Allow to disable screenshot extension in global profile</flag>
+ <flag name="system-av1">Use the system-wide <pkg>media-libs/dav1d</pkg>
+ and <pkg>media-libs/libaom</pkg> library instead of bundled.</flag>
<flag name="system-harfbuzz">Use the system-wide <pkg>media-libs/harfbuzz</pkg>
and <pkg>media-gfx/graphite2</pkg> instead of bundled.</flag>
<flag name="system-icu">Use the system-wide <pkg>dev-libs/icu</pkg>
@@ -25,5 +36,9 @@
instead of bundled.</flag>
<flag name="system-sqlite">Use the system-wide <pkg>dev-db/sqlite</pkg>
installation with secure-delete enabled</flag>
+ <flag name="system-webp">Use the system-wide <pkg>media-libs/libwebp</pkg>
+ instead of bundled.</flag>
+
+
</use>
</pkgmetadata>
diff --git a/mail-client/thunderbird/thunderbird-68.0-r1.ebuild b/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
index 16c70923..51e31754 100644
--- a/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
+++ b/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
@@ -39,10 +39,13 @@ HOMEPAGE="https://www.mozilla.org/thunderbird"
KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist clang dbus debug hardened jack lightning neon pulseaudio
- selinux startup-notification system-harfbuzz system-icu system-jpeg
- system-libevent system-libvpx system-sqlite wifi"
-RESTRICT="!bindist? ( bindist )"
+IUSE="bindist clang cpu_flags_x86_avx2 dbus debug eme-free geckodriver
+ +gmp-autoupdate hardened jack lightning lto neon pgo pulseaudio
+ +screenshot selinux startup-notification +system-av1 +system-harfbuzz
+ +system-icu +system-jpeg +system-libevent +system-sqlite +system-libvpx
+ +system-webp test wayland wifi"
+RESTRICT="!bindist? ( bindist )
+ !test? ( test )"
PATCH_URIS=( https://dev.gentoo.org/~{anarchy,axs,polynomial-c,whissi}/mozilla/patchsets/${PATCHFF}.tar.xz )
SRC_URI="${SRC_URI}
@@ -51,18 +54,10 @@ SRC_URI="${SRC_URI}
lightning? ( https://dev.gentoo.org/~axs/distfiles/gdata-provider-${MOZ_LIGHTNING_GDATA_VER}.tar.xz )
${PATCH_URIS[@]}"
-
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
autotools mozlinguas-v2 virtualx
-IUSE="bindist clang cpu_flags_x86_avx2 dbus debug eme-free geckodriver
- +gmp-autoupdate hardened hwaccel jack lightning lto neon pgo pulseaudio
- +screenshot selinux startup-notification +system-av1 +system-harfbuzz
- +system-icu +system-jpeg +system-libevent +system-sqlite +system-libvpx
- +system-webp test wayland wifi"
-RESTRICT="!bindist? ( bindist )"
-
CDEPEND="
>=dev-libs/nss-3.44.1
>=dev-libs/nspr-4.21