aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:25:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:25:25 +0100
commitc8e13f0ddf2812355c107dd82262138b5e35c91d (patch)
treeb31a2c0fdb868ee3a42e3d4c224047ed145ea2ad
parentwww-client/firefox, mail-client/thunderbird, eclass/mozconfig-v6.52 : (diff)
downloadmozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.tar.gz
mozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.tar.bz2
mozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.zip
seamonkey: Fix build with libevent-2.1
-rw-r--r--eclass/mozconfig-v6.49.eclass12
-rw-r--r--www-client/seamonkey/files/firefox-52-curve.patch34
-rw-r--r--www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch14
-rw-r--r--www-client/seamonkey/seamonkey-2.46-r1.ebuild6
4 files changed, 5 insertions, 61 deletions
diff --git a/eclass/mozconfig-v6.49.eclass b/eclass/mozconfig-v6.49.eclass
index 7f9ed15c..bc6e7d3b 100644
--- a/eclass/mozconfig-v6.49.eclass
+++ b/eclass/mozconfig-v6.49.eclass
@@ -94,6 +94,7 @@ RDEPEND=">=app-text/hunspell-1.2:=
dev-libs/atk
dev-libs/expat
>=x11-libs/cairo-1.10[X]
+ >=x11-libs/gtk+-2.18:2
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
>=media-libs/libpng-1.6.21:0=[apng]
@@ -120,7 +121,7 @@ RDEPEND=">=app-text/hunspell-1.2:=
system-cairo? ( >=x11-libs/cairo-1.12[X,xcb] >=x11-libs/pixman-0.19.2 )
system-icu? ( >=dev-libs/icu-56.1:= )
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
- system-libevent? ( =dev-libs/libevent-2.0*:0= )
+ system-libevent? ( >=dev-libs/libevent-2.0:0= )
system-sqlite? ( >=dev-db/sqlite-3.13.0:3[secure-delete,debug=] )
system-libvpx? ( >=media-libs/libvpx-1.5.0:0=[postproc] )
system-harfbuzz? ( >=media-libs/harfbuzz-1.2.6:0=[graphite,icu] >=media-gfx/graphite2-1.3.8 )
@@ -134,8 +135,7 @@ if [[ -n ${MOZCONFIG_OPTIONAL_GTK3} ]]; then
IUSE+=" gtk3"
fi
RDEPEND+="
- gtk3? ( >=x11-libs/gtk+-3.4.0:3 )
- !gtk3? ( >=x11-libs/gtk+-2.18:2 )"
+ gtk3? ( >=x11-libs/gtk+-3.4.0:3 )"
elif [[ -n ${MOZCONFIG_OPTIONAL_GTK2ONLY} ]]; then
if [[ ${MOZCONFIG_OPTIONAL_GTK2ONLY} = "enabled" ]]; then
IUSE+=" +gtk2"
@@ -143,11 +143,7 @@ elif [[ -n ${MOZCONFIG_OPTIONAL_GTK2ONLY} ]]; then
IUSE+=" gtk2"
fi
RDEPEND+="
- gtk2? ( >=x11-libs/gtk+-2.18:2 )
!gtk2? ( >=x11-libs/gtk+-3.4.0:3 )"
-else
- RDEPEND+="
- >=x11-libs/gtk+-2.18:2"
fi
if [[ -n ${MOZCONFIG_OPTIONAL_QT5} ]]; then
inherit qmake-utils
@@ -239,8 +235,6 @@ mozconfig_config() {
fi
fi
- # Enable position independent executables
- mozconfig_annotate 'enabled by Gentoo' --enable-pie
mozconfig_use_enable debug
mozconfig_use_enable debug tests
diff --git a/www-client/seamonkey/files/firefox-52-curve.patch b/www-client/seamonkey/files/firefox-52-curve.patch
deleted file mode 100644
index 508d5805..00000000
--- a/www-client/seamonkey/files/firefox-52-curve.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-# HG changeset patch
-# User Franziskus Kiefer <franziskuskiefer@gmail.com>
-# Date 1469717280 -7200
-# Thu Jul 28 16:48:00 2016 +0200
-# Node ID 95aa61f1e3562e526bf88179d9d078fd90ad1bda
-# Parent d42aacfe34af25e2f5110e2ca3d24a210eabeb33
-Update keybits in H2, r=mt
-
-MozReview-Commit-ID: 35oWoDMqe1Y
-
-diff --git a/netwerk/protocol/http/Http2Session.cpp b/netwerk/protocol/http/Http2Session.cpp
---- a/netwerk/protocol/http/Http2Session.cpp
-+++ b/netwerk/protocol/http/Http2Session.cpp
-@@ -3544,18 +3544,18 @@ Http2Session::ConfirmTLSProfile()
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
- }
-
- uint32_t keybits = ssl->GetKEAKeyBits();
- if (kea == ssl_kea_dh && keybits < 2048) {
- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
- this, keybits));
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
-- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
-- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
-+ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
-+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
- this, keybits));
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
- }
-
- int16_t macAlgorithm = ssl->GetMACAlgorithmUsed();
- LOG3(("Http2Session::ConfirmTLSProfile %p MAC Algortihm (aead==6) %d\n",
- this, macAlgorithm));
- if (macAlgorithm != nsISSLSocketControl::SSL_MAC_AEAD) {
diff --git a/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch b/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch
deleted file mode 100644
index 6928f84d..00000000
--- a/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/604696
-https://bugzilla.mozilla.org/show_bug.cgi?id=1329252
-
---- seamonkey-2.46/mozilla/build/autoconf/icu.m4
-+++ seamonkey-2.46/mozilla/build/autoconf/icu.m4
-@@ -70,7 +70,7 @@
- fi
- fi
-
-- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
-+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
- if test x"$version" = x; then
- AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
- fi
diff --git a/www-client/seamonkey/seamonkey-2.46-r1.ebuild b/www-client/seamonkey/seamonkey-2.46-r1.ebuild
index 2876ebfd..7630d0e8 100644
--- a/www-client/seamonkey/seamonkey-2.46-r1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.46-r1.ebuild
@@ -61,8 +61,8 @@ MOZCONFIG_OPTIONAL_WIFI=1
MOZCONFIG_OPTIONAL_JIT="enabled"
inherit check-reqs flag-o-matic toolchain-funcs eutils mozconfig-v6.49 multilib pax-utils fdo-mime autotools mozextension nsplugins mozlinguas-v2
-PATCHFF="firefox-49.0-patches-03"
-PATCH="${PN}-2.46-patches-01"
+PATCHFF="firefox-49.0-patches-04"
+PATCH="${PN}-2.46-patches-02"
EMVER="1.9.6.1"
DESCRIPTION="Seamonkey Web Browser"
@@ -135,13 +135,11 @@ src_unpack() {
src_prepare() {
# Apply our patches
eapply "${WORKDIR}"/seamonkey
- eapply "${FILESDIR}"/${PN}-2.46-configure_regexp.patch
# browser patches go here
pushd "${S}"/mozilla &>/dev/null || die
rm -f "${WORKDIR}"/firefox/2000-firefox_gentoo_install_dirs.patch
eapply "${WORKDIR}"/firefox
- eapply "${FILESDIR}"/firefox-52-curve.patch
popd &>/dev/null || die
# Shell scripts sometimes contain DOS line endings; bug 391889