aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-05-29 10:54:21 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-05-29 10:54:21 -0400
commit3cfdbdb9bb7fa8e6fed22658ba2dc7f6900ade3e (patch)
tree5a5d0621b2c8455f340abf26c14cea878678351e /dev-libs
parentfirefox: bump to 52.1.2 (diff)
downloadmozilla-3cfdbdb9bb7fa8e6fed22658ba2dc7f6900ade3e.tar.gz
mozilla-3cfdbdb9bb7fa8e6fed22658ba2dc7f6900ade3e.tar.bz2
mozilla-3cfdbdb9bb7fa8e6fed22658ba2dc7f6900ade3e.zip
jemalloc: add src_prepare to call eautoreconf for build system patches
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jemalloc/jemalloc-4.5.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/jemalloc/jemalloc-4.5.0.ebuild b/dev-libs/jemalloc/jemalloc-4.5.0.ebuild
index 9f7906ea..9b1c134e 100644
--- a/dev-libs/jemalloc/jemalloc-4.5.0.ebuild
+++ b/dev-libs/jemalloc/jemalloc-4.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit toolchain-funcs multilib-build multilib-minimal
+inherit autotools toolchain-funcs multilib-minimal
DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
HOMEPAGE="http://www.canonware.com/jemalloc/"
@@ -23,6 +23,11 @@ MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
# supress the warnings until automagic is removed from the eclass
QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myconf=()