aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-05-15 11:39:21 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-05-15 11:39:21 -0400
commit27e6f1bf268d6c413c50e3e43851e807655e8a22 (patch)
treef511ce59687d15cb06c96d4b13ed356d2ea7218d /x11-plugins
parentrevbump firefox-53 due to previous commit (diff)
downloadmozilla-27e6f1bf268d6c413c50e3e43851e807655e8a22.tar.gz
mozilla-27e6f1bf268d6c413c50e3e43851e807655e8a22.tar.bz2
mozilla-27e6f1bf268d6c413c50e3e43851e807655e8a22.zip
Dropped enigmail ebuilds that match what is in the gentoo-repo, add -9999 ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/Manifest2
-rw-r--r--x11-plugins/enigmail/enigmail-1.9.6.1.ebuild70
-rw-r--r--x11-plugins/enigmail/enigmail-9999.ebuild (renamed from x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild)18
3 files changed, 11 insertions, 79 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
deleted file mode 100644
index dd3772f..0000000
--- a/x11-plugins/enigmail/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST enigmail-1.9.5.tar.gz 1744278 SHA256 831e53a4add0f465241f075be9475103367aa1452675adae054d8fb272e5d3ad SHA512 4db7e52d3c9b192b1de72bffd62430a6b02c117b11847bd9cf196fd226ace6f587f20dd21c82f9ff109cd1bee69c50bfdf7e12b78dd2684d08ced86771096d0c WHIRLPOOL 5ed576a86fa5c9fa718c1917c985619b5c3ec1e6ccfd003681c9314d4b9855c31d5075fd920f86d7365dc6146ec877d93dfbb52091417ae52c011cbe47815e9c
-DIST enigmail-1.9.6.1.tar.gz 1745021 SHA256 3874331e981aed864443d3c965d856e003fd84f73e5a89fd5004ced9dc29b96f SHA512 e6ab69734a39a4953e0167e07b06f0d5c83fb42956515392319a1cd9d665ca274f6a12b4141e2dfa373ef074f0526f3d7330a48d29d600fc38f724d26518ff84 WHIRLPOOL e89b0e5857564cc2f7ebf3ab46b110c6bbb1b16e7c0e045750119fd02e693b9bd9667c2932e7a65f9c8fb2c7c835ed048f6df2613d12b25d961894f47f67cf48
diff --git a/x11-plugins/enigmail/enigmail-1.9.6.1.ebuild b/x11-plugins/enigmail/enigmail-1.9.6.1.ebuild
deleted file mode 100644
index 974d097..0000000
--- a/x11-plugins/enigmail/enigmail-1.9.6.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-SLOT="0"
-LICENSE="MPL-2.0 GPL-2"
-IUSE="+thunderbird seamonkey"
-SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
-
-DEPEND="app-arch/zip"
-
-RDEPEND="thunderbird? ( mail-client/thunderbird[-crypt(-)] )
- seamonkey? ( www-client/seamonkey[-crypt(-)] )
- || (
- ( >=app-crypt/gnupg-2.0
- || (
- app-crypt/pinentry[gtk(-)]
- app-crypt/pinentry[qt4(-)]
- app-crypt/pinentry[qt5(-)]
- )
- )
- =app-crypt/gnupg-1.4*
- ) "
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- emake -j1
- emake -j1 xpi
-}
-
-src_install() {
- local emid impl
- local enigmail_xpipath="${S}"/build
-
- cd "${T}" || die
- unzip "${enigmail_xpipath}"/enigmail*.xpi install.rdf || die
- emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
-
- for impl in thunderbird seamonkey ; do
- if use ${impl} ; then
- dodir /usr/$(get_libdir)/${impl}/extensions/${emid}
- cd "${ED}"/usr/$(get_libdir)/${impl}/extensions/${emid} || die
- unzip "${enigmail_xpipath}"/enigmail*.xpi || die
- fi
- done
- if ! use thunderbird && ! use seamonkey ; then
- dodir /usr/share/${PN}
- cd "${ED}"/usr/share/${PN} || die
- unzip "${enigmail_xpipath}"/enigmail*.xpi || die
- fi
-}
-
-pkg_postinst() {
- local peimpl=$(eselect --brief --colour=no pinentry show)
- case "${peimpl}" in
- *gtk*|*qt*) ;;
- *) ewarn "The pinentry front-end currently selected is not one supported."
- ewarn "You may be prompted for your password in an inaccessible shell!!"
- ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
- ;;
- esac
-}
diff --git a/x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild b/x11-plugins/enigmail/enigmail-9999.ebuild
index eb31d73..edffcc2 100644
--- a/x11-plugins/enigmail/enigmail-1.9.6.1-r1.ebuild
+++ b/x11-plugins/enigmail/enigmail-9999.ebuild
@@ -1,19 +1,25 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1
+inherit git-r3 python-any-r1
DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
HOMEPAGE="http://www.enigmail.net/"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS=""
SLOT="0"
LICENSE="MPL-2.0 GPL-3"
IUSE=""
-SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+fi
RDEPEND="|| (
( >=app-crypt/gnupg-2.0
@@ -31,10 +37,8 @@ DEPEND="${RDEPEND}
dev-lang/perl
"
-S="${WORKDIR}/${PN}"
-
src_compile() {
- emake ipc public ui package lang
+ emake ipc public ui package lang stdlib
emake xpi
}