aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/Manifest2
-rw-r--r--mail-client/thunderbird/files/mozilla-bug1554949-linux-headers-5.2.patch46
-rw-r--r--mail-client/thunderbird/thunderbird-68.0-r1.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/mail-client/thunderbird/Manifest b/mail-client/thunderbird/Manifest
index 38785ee7..6e01583c 100644
--- a/mail-client/thunderbird/Manifest
+++ b/mail-client/thunderbird/Manifest
@@ -1,5 +1,5 @@
DIST firefox-60.6-patches-07.tar.xz 37404 BLAKE2B 5516ff768bee0253131381fdba3e08785ab31bb29e44ad7f7e2956fb7624fafc9bf22f892ddbd0617e5e7d18500686a9975a60ea77d23a2853f35936cd142030 SHA512 3c4160e632155b0a239e22d0c1b1c701545b0f6d0915f9bdcf3b8431cee1abf650191ffafc5c3224a61279c8b1b52a80444c811a3914e16127411991c963292b
-DIST firefox-68.0-patches-10.tar.xz 14668 BLAKE2B 071e3377c0be2035e3f16c0b4492ebc681e6bf9da929d9a565d80a0d1c1f85a81330418a1b30fbaa0a6d7eecb9b2f189416882dafdb879feea98c9911c52493f SHA512 d424be80d68c84d3f561cbdfb487344308ba6af84d07cc16fe0631bfd609dce0e81fd2f7516c5fc1e1e359eacb3e06a4bde83cebf3909427f7e641b17e28f3d5
+DIST firefox-68.0-patches-11.tar.xz 15404 BLAKE2B 5322c64f7605e30aa1daf650cea19b66ce6c305d2862d76c4a4103676392cbd3029a8f35cbe8ed8077ac7cfe8194c08a0cd3cf25fef75c62a086077d0c5a419a SHA512 1897303b6864ca941afe6ee1d95fd975fb29a01f52d68f9f42c1a9a62d7e4fee0a797aa169b58dc4cf068916e01edaf5c9ad8ade23a997e52c37bd393a142ade
DIST gdata-provider-4.4.1.tar.xz 78728 BLAKE2B bfe04d714334c38c932d2186ffd859583176ef455b283534c5f8f9e1ab7dc13bdfb8c15db6007de482ab015afc2b8524aad725380bec75ee5f59ea81d6307ba9 SHA512 6c9b5ac41a1064bd1799d2a2f633c3064b27f1294ac3c8908cdef6c1d2eea7b602f2f7bf240b71f507fe9ad286588f030e12f49a41b3bed7bbcc99f3021369f9
DIST lightning-6.2.5.tar.xz 1745976 BLAKE2B 31e237f8d34ab2a2ac522767460467257d1f49d15fbe24f5b80dde9fb709ffafd0c0442d99c6643ce434cf7bdf0d670447f86da9fcdadc7ada6814431ef41e8a SHA512 1e997bb91d484908f225cc6e971874d308e8a8e2451a3e678f8a74bcb9e360babbd1f8aebcafb3e628ef5b10eb697ee47af2bfedbc956fee71d99084c8816235
DIST thunderbird-60.0-patches-0.tar.xz 10292 BLAKE2B a81ac6708389baff21accccac1511c1fc372324cac8bb3ee0f3b5d2a0690b6e22ef658b41c887b99168b43c4ea4bb0947d3e48ad9b7e80db558db22c976df868 SHA512 1dae465676b2ff4faae08ebf69e6bac46552bc0331659bf5f444c45b026e4c8d2fc46cd3758e3bd121716aa85d5dcc56de6483919f7f0077b9d9720574dbd1aa
diff --git a/mail-client/thunderbird/files/mozilla-bug1554949-linux-headers-5.2.patch b/mail-client/thunderbird/files/mozilla-bug1554949-linux-headers-5.2.patch
new file mode 100644
index 00000000..2de12500
--- /dev/null
+++ b/mail-client/thunderbird/files/mozilla-bug1554949-linux-headers-5.2.patch
@@ -0,0 +1,46 @@
+# HG changeset patch
+# User Emilio Cobos Álvarez <emilio@crisal.io>
+# Date 1559048542 0
+# Node ID 03fe96d5969ac6885ca539bf7759780ed75a1375
+# Parent e6cf9d0df0793e7f76cb2877989fc5aeca98e530
+Bug 1554949 - Fix WebRTC build failure with newer linux kernel. r=dminor, a=RyanVM DONTBUILD
+
+Recent kernel commit[1] moved a bit the define for this constant. This revealed
+a missing include in WebRTC.
+
+I filed this upstream in:
+
+ * https://bugs.chromium.org/p/webrtc/issues/detail?id=10677
+
+And sent a patch in:
+
+ * https://webrtc-review.googlesource.com/c/src/+/138270
+
+[1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0768e17073dc5
+
+Differential Revision: https://phabricator.services.mozilla.com/D32809
+
+diff --git a/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc b/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc
+--- a/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc
++++ b/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc
+@@ -56,16 +56,19 @@
+ #if defined(WEBRTC_POSIX)
+ #include <netinet/tcp.h> // for TCP_NODELAY
+ #define IP_MTU 14 // Until this is integrated from linux/in.h to netinet/in.h
+ typedef void* SockOptArg;
+
+ #endif // WEBRTC_POSIX
+
+ #if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(WEBRTC_BSD) && !defined(__native_client__)
++#if defined(WEBRTC_LINUX)
++#include <linux/sockios.h>
++#endif
+
+ int64_t GetSocketRecvTimestamp(int socket) {
+ struct timeval tv_ioctl;
+ int ret = ioctl(socket, SIOCGSTAMP, &tv_ioctl);
+ if (ret != 0)
+ return -1;
+ int64_t timestamp =
+ rtc::kNumMicrosecsPerSec * static_cast<int64_t>(tv_ioctl.tv_sec) +
+
diff --git a/mail-client/thunderbird/thunderbird-68.0-r1.ebuild b/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
index 10755b94..813aba39 100644
--- a/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
+++ b/mail-client/thunderbird/thunderbird-68.0-r1.ebuild
@@ -21,7 +21,7 @@ sv-SE tr uk vi zh-CN zh-TW )
MOZ_PV="${PV/_beta/b}"
# Patches
-PATCHFF="firefox-68.0-patches-10"
+PATCHFF="firefox-68.0-patches-11"
MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
@@ -252,6 +252,7 @@ src_unpack() {
src_prepare() {
# Apply firefox patchset then apply thunderbird patches
eapply "${WORKDIR}/firefox"
+ eapply "${FILESDIR}/mozilla-bug1554949-linux-headers-5.2.patch"
pushd "${S}"/comm &>/dev/null || die
eapply "${FILESDIR}/1000_fix_gentoo_preferences.patch"
popd &>/dev/null || die