aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch37
-rw-r--r--mail-client/thunderbird/thunderbird-60.0-r3.ebuild4
2 files changed, 41 insertions, 0 deletions
diff --git a/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch b/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch
new file mode 100644
index 0000000..6fbd13f
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/666898
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1479540
+--- a/build/moz.configure/init.configure
++++ b/build/moz.configure/init.configure
+@@ -572,17 +572,26 @@ option('--target', nargs=1,
+ @imports(_from='__builtin__', _import='KeyError')
+ @imports(_from='__builtin__', _import='ValueError')
+ def split_triplet(triplet, allow_unknown=False):
+ # The standard triplet is defined as
+ # CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
+ # There is also a quartet form:
+ # CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
+ # But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
+- cpu, manufacturer, os = triplet.split('-', 2)
++ # Additionally, some may omit "unknown" when the manufacturer
++ # is not specified and emit
++ # CPU_TYPE-OPERATING_SYSTEM
++ parts = triplet.split('-', 2)
++ if len(parts) == 3:
++ cpu, _, os = parts
++ elif len(parts) == 2:
++ cpu, os = parts
++ else:
++ die("Unexpected triplet string: %s" % triplet)
+
+ # Autoconf uses config.sub to validate and canonicalize those triplets,
+ # but the granularity of its results has never been satisfying to our
+ # use, so we've had our own, different, canonicalization. We've also
+ # historically not been very consistent with how we use the canonicalized
+ # values. Hopefully, this will help us make things better.
+ # The tests are inherited from our decades-old autoconf-based configure,
+ # which can probably be improved/cleaned up because they are based on a
+
+
+
+
diff --git a/mail-client/thunderbird/thunderbird-60.0-r3.ebuild b/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
index f9ecfc8..246f6b1 100644
--- a/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
+++ b/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
@@ -8,6 +8,9 @@ MOZ_ESR=""
MOZ_LIGHTNING_VER="6.2"
MOZ_LIGHTNING_GDATA_VER="4.4.1"
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='ncurses,sqlite,ssl,threads'
+
# This list can be updated using scripts/get_langs.sh from the mozilla overlay
MOZ_LANGS=(ar ast be bg br ca cs cy da de el en en-GB en-US es-AR
es-ES et eu fi fr fy-NL ga-IE gd gl he hr hsb hu hy-AM id is it ja ko lt
@@ -195,6 +198,7 @@ src_prepare() {
|| die
eapply "${WORKDIR}/firefox"
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
+ eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
# Ensure that are plugins dir is enabled as default
sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \