summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-06-01 19:34:15 +0200
committerFlorian Fischer <vlooe@web.de>2009-06-01 19:34:15 +0200
commita2deb9b5e3f870dd8c9b34d32e127abd9d73e527 (patch)
treea23aa9f5631754b54adb13febe148097461888cc /bin
parentMerge branch 'master' of git@github.com:sjnewbury/multilib-overlay (diff)
downloadmultilib-portage-a2deb9b5e3f870dd8c9b34d32e127abd9d73e527.tar.gz
multilib-portage-a2deb9b5e3f870dd8c9b34d32e127abd9d73e527.tar.bz2
multilib-portage-a2deb9b5e3f870dd8c9b34d32e127abd9d73e527.zip
speed up bin/show_outdated_ebuilds
Diffstat (limited to 'bin')
-rwxr-xr-xbin/show_outdated_ebuilds3
1 files changed, 2 insertions, 1 deletions
diff --git a/bin/show_outdated_ebuilds b/bin/show_outdated_ebuilds
index e98d3e8bc..0439c1c81 100755
--- a/bin/show_outdated_ebuilds
+++ b/bin/show_outdated_ebuilds
@@ -24,7 +24,8 @@ for EBUILD in $(find . -name "*.ebuild" -a -not -path "./main_tree*"); do
done
for EBUILD in ${IGNORED_EBUILD}; do
- EBUILDS_NOT_IN_SOURCE="${EBUILDS_NOT_IN_SOURCE/"${EBUILD}"/}"
+# EBUILDS_NOT_IN_SOURCE="${EBUILDS_NOT_IN_SOURCE/"${EBUILD}"/}"
+ EBUILDS_NOT_IN_SOURCE=$(echo -e "${EBUILDS_NOT_IN_SOURCE}" | sed "s@${EBUILD}@@" )
done
EBUILDS_NOT_IN_SOURCE="$(tr ' ' '\n' <<< "${EBUILDS_NOT_IN_SOURCE}" | sort -u)"