summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@localhost.localdomain>2009-04-08 04:14:28 +0100
committerroot <root@localhost.localdomain>2009-04-08 04:14:28 +0100
commitd7360e2065441fee5b374ec0a2272fb137c2b40d (patch)
tree58d1c153b0ccef84dc5cbe4b2deaa0c476982be7 /net-wireless
parentOnly look in ${D}/usr/bin for config scripts if ${D}/usr/bin exists (diff)
downloadmultilib-portage-d7360e2065441fee5b374ec0a2272fb137c2b40d.tar.gz
multilib-portage-d7360e2065441fee5b374ec0a2272fb137c2b40d.tar.bz2
multilib-portage-d7360e2065441fee5b374ec0a2272fb137c2b40d.zip
Add missing patch to net-wireless/bluez
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/Manifest1
-rw-r--r--net-wireless/bluez/files/4.34-conditional_libsbc.patch39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-wireless/bluez/Manifest b/net-wireless/bluez/Manifest
index 99f8c1005..544dd1ead 100644
--- a/net-wireless/bluez/Manifest
+++ b/net-wireless/bluez/Manifest
@@ -4,6 +4,7 @@ AUX 4.18/conf.d-hidd 89 RMD160 31407e00bcb00eb0b9c1adeb7434a922bfb967e9 SHA1 dc6
AUX 4.18/cups-location.patch 480 RMD160 3da74418b140c2ea05d2c9e0d743eaf004deba5d SHA1 3605b1633c92b2b7eefc7e6b78e98df3e12088a8 SHA256 cede5fed7e4ece7cf4977d40e7fd8f9a22200660b06cca15d39c9c40542ab33d
AUX 4.18/init.d-hidd 779 RMD160 8dc919f4d0aa2df8464e3326c14b6f5a9f0c360f SHA1 45901988313787db4f1d5a0fdc44009ffa3d650b SHA256 d5816349cc85313a8f7f1b79112918aeda863ff59f298b99462611860605c737
AUX 4.31-as_needed.patch 1129 RMD160 16d12e4466cebbc37183c73791c957655452e17b SHA1 3f98b061f91b3875c7b7035625f1d7b22c4aa6e5 SHA256 4f59a2f1dfb4567e5d5254720ebc2dbb5cfa7bacdf962801040eb7596922d698
+AUX 4.34-conditional_libsbc.patch 1511 RMD160 c76d7515f8433e6fc73a3043b31a9ee63c5baf97 SHA1 ab58528c58cf3ce6b01758beec488035ea5ad309 SHA256 8202c8d94dc3688072a750fcf287684b1e6ee5f7ac108af604f354cc0ba97707
AUX bluez-4.18-udev.rules 228 RMD160 ab9b4ce8907c62eb9d1f14406cc2ff3f5ec69a19 SHA1 14e652de6cfed28f215727800460e600129007c2 SHA256 7577c2ed295b67f960f17ac65a44889c6536c125b34e33860d6d9f128a59fa82
AUX bluez-4.18-udev.script 752 RMD160 d8f60749dbe497bef7362a4c3f56b2b83ca079cb SHA1 0c39b4b4f4c57fb334daa793f89c0ffac046b956 SHA256 cb41a4eeea5137fb27d82d74f34e5e7dd725ddf8442c39ea623afe0d3c041fcf
DIST bluez-4.21.tar.gz 933080 RMD160 4a451ab0370fab0bfc8ba7750b9298f1b3700308 SHA1 d1eb361a93860b34cea5cc72a449047d6d8a5c63 SHA256 b4ca270ded5d2e9aa77d5c0e5e2bd987122751fe48fae0ebd90de42ab136de37
diff --git a/net-wireless/bluez/files/4.34-conditional_libsbc.patch b/net-wireless/bluez/files/4.34-conditional_libsbc.patch
new file mode 100644
index 000000000..e4924c79b
--- /dev/null
+++ b/net-wireless/bluez/files/4.34-conditional_libsbc.patch
@@ -0,0 +1,39 @@
+The configure stuff is a inconsequent:
+- even if neither alsa nor gstreamer support is enabled, SBC_LIBS gets substituted by libsbc.la
+ which doesn't get build without alsa or gstreamer. Making this conditional helps.
+- ipctest needs both libipc.la and libsbc.la and fails if SBC_LIBS/SBC_CFLAGS are empty,
+ making the build conditional helps again.
+--- acinclude.m4.orig 2009-04-06 16:26:14.570780241 +0200
++++ acinclude.m4 2009-04-06 16:26:59.540779148 +0200
+@@ -330,8 +330,10 @@
+ AC_SUBST([GDBUS_CFLAGS], ['-I$(top_srcdir)/gdbus'])
+ AC_SUBST([GDBUS_LIBS], ['$(top_builddir)/gdbus/libgdbus.la'])
+
+- AC_SUBST([SBC_CFLAGS], ['-I$(top_srcdir)/sbc'])
+- AC_SUBST([SBC_LIBS], ['$(top_builddir)/sbc/libsbc.la'])
++ if (test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes"); then
++ AC_SUBST([SBC_CFLAGS], ['-I$(top_srcdir)/sbc'])
++ AC_SUBST([SBC_LIBS], ['$(top_builddir)/sbc/libsbc.la'])
++ fi
+
+ AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
+ AM_CONDITIONAL(NETLINK, test "${netlink_enable}" = "yes" && test "${netlink_found}" = "yes")
+--- audio/Makefile.am.orig 2009-04-06 16:47:21.240681272 +0200
++++ audio/Makefile.am 2009-04-06 17:42:27.240597715 +0200
+@@ -60,10 +60,16 @@
+
+ libipc_la_SOURCES = ipc.h ipc.c
+
++if AUDIOPLUGIN
++if SBC
++
+ noinst_PROGRAMS = ipctest
+
+ ipctest_LDADD= libipc.la @SBC_LIBS@ @GLIB_LIBS@
+
++endif
++endif
++
+ AM_CFLAGS = -fvisibility=hidden @SBC_CFLAGS@ \
+ @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+