summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-04-19 15:39:53 +0200
committerFlorian Fischer <vlooe@web.de>2009-04-19 15:39:53 +0200
commitc6ff2dfa0561ad0f6df4692f90b4f2fd72fdac15 (patch)
tree60bf9834d3c919f52360b70c9654c62c02e9a32d /sys-apps
parentSync with main tree (diff)
downloadmultilib-portage-c6ff2dfa0561ad0f6df4692f90b4f2fd72fdac15.tar.gz
multilib-portage-c6ff2dfa0561ad0f6df4692f90b4f2fd72fdac15.tar.bz2
multilib-portage-c6ff2dfa0561ad0f6df4692f90b4f2fd72fdac15.zip
added a abi-wrapper script
to setup the abi wrapper call prep_ml_binaries at the end of the install phase
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/abi-wrapper/Manifest2
-rw-r--r--sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild21
-rw-r--r--sys-apps/abi-wrapper/files/abi-wrapper24
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/abi-wrapper/Manifest b/sys-apps/abi-wrapper/Manifest
new file mode 100644
index 000000000..ccee91cf9
--- /dev/null
+++ b/sys-apps/abi-wrapper/Manifest
@@ -0,0 +1,2 @@
+AUX abi-wrapper 644 RMD160 17fde92ac21ec8fcec35f09162890073673711ad SHA1 407f493c424dc2047d4a0b611b9f9d4b9d81aae4 SHA256 a1705379c45570fc2175e32eddac1343391db64988c7479a1338fed653193dad
+EBUILD abi-wrapper-1.0.ebuild 353 RMD160 e8406096a605fc5f884b574b4c24502ea2f81471 SHA1 e700ea91e43fd6207c07cc274559fc71191a65e6 SHA256 09a78dea2ae7bdb4360a51c7d9ccef33b1fa237790b83f596e73e2f8213940a3
diff --git a/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild b/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild
new file mode 100644
index 000000000..0756454c1
--- /dev/null
+++ b/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Wraps binarys that behave abi dependand"
+HOMEPAGE="www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install()
+{
+ exeinto /usr/bin
+ doexe ${FILESDIR}/abi-wrapper
+}
diff --git a/sys-apps/abi-wrapper/files/abi-wrapper b/sys-apps/abi-wrapper/files/abi-wrapper
new file mode 100644
index 000000000..01fdb309e
--- /dev/null
+++ b/sys-apps/abi-wrapper/files/abi-wrapper
@@ -0,0 +1,24 @@
+#!/bin/bash
+# ${PN}-config is a link to this abi-wrapper on multilib-systems to
+# assure options like --libs return the correct ABI-specific values.
+# This must match the multilib-behaviour of the set profile!
+
+if [[ -n ${ABI} ]] ; then
+ abi=${ABI}
+elif [[ -n ${DEFAULT_ABI} ]] ; then
+ abi=${DEFAULT_ABI}
+else
+ # we're called from outside portage, so try default first
+ abis=$(portageq envvar DEFAULT_ABI MULTILIB_ABIS)
+ for abi in ${abis} ; do
+ [[ -f ${0}-${abi} ]] && break
+ unset abi
+ done
+fi
+
+if [[ -f ${0}-${abi} ]] ; then
+ exec ${0}-${abi} ${@}
+else
+ echo "${0}: abi-wrapper-config couldn't find script for current abi" >&2
+ exit 1
+fi