aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-06-03 19:11:40 +0300
committerJory Pratt <anarchy@gentoo.org>2021-06-07 11:55:05 -0500
commit06a98075d12c26a650d045c73d22654924d0796f (patch)
tree3b7608135401a8ab7f986adf1f5ea2f0cba1639f
parentnet-fs/samba: sync with ::gentoo (diff)
downloadmusl-06a98075d12c26a650d045c73d22654924d0796f.tar.gz
musl-06a98075d12c26a650d045c73d22654924d0796f.tar.bz2
musl-06a98075d12c26a650d045c73d22654924d0796f.zip
sys-libs/tevent: sync with ::gentoo
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://github.com/gentoo/musl/pull/439 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--sys-libs/tevent/tevent-0.10.2.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/sys-libs/tevent/tevent-0.10.2.ebuild b/sys-libs/tevent/tevent-0.10.2.ebuild
index 3306abf5..f079f8f2 100644
--- a/sys-libs/tevent/tevent-0.10.2.ebuild
+++ b/sys-libs/tevent/tevent-0.10.2.ebuild
@@ -1,27 +1,33 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8} )
-PYTHON_REQ_USE="threads(+)"
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
inherit waf-utils multilib-minimal python-single-r1
DESCRIPTION="Samba tevent library"
HOMEPAGE="https://tevent.samba.org/"
-SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+SRC_URI="https://samba.org/ftp/tevent/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
- >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
- python? ( ${PYTHON_DEPS} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
+ python? (
+ ${PYTHON_DEPS}
+ sys-libs/talloc[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig
elibc_glibc? (
net-libs/libtirpc[${MULTILIB_USEDEP}]
|| (
@@ -29,15 +35,13 @@ DEPEND="${RDEPEND}
<sys-libs/glibc-2.26[rpc(+)]
)
)
- ${PYTHON_DEPS}
"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
WAF_BINARY="${S}/buildtools/bin/waf"
-RESTRICT="test"
-
PATCHES=(
"${FILESDIR}/${PN}-add-missing-header.patch"
)