aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-06-14 18:35:24 -0500
committerJory Pratt <anarchy@gentoo.org>2020-06-14 18:35:24 -0500
commit56a091a5dbe033db184f0abe502352fb0ccd7889 (patch)
treea93527bd22361eff68647c527d02d9d9ca565cda
parentsys-devel/gcc: sync update with tree (diff)
downloadmusl-56a091a5dbe033db184f0abe502352fb0ccd7889.tar.gz
musl-56a091a5dbe033db184f0abe502352fb0ccd7889.tar.bz2
musl-56a091a5dbe033db184f0abe502352fb0ccd7889.zip
media-libs/mesa: mark 20.0.8 stable for all archs
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-20.0.8.ebuild (renamed from media-libs/mesa/mesa-20.0.4-r1.ebuild)28
2 files changed, 22 insertions, 8 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index a0d5e877..d4b8a714 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -1,2 +1,2 @@
DIST mesa-19.3.5.tar.xz 12064980 BLAKE2B a20ebfb149624f13951795e07154ab70dc1856a7a1261b339b0bdf0009511111756c88439e7b8729f768b0b4b298301b9a3c0c10d7f2fab3abd91649c12ba51c SHA512 413929573fab31e1bb2a1a04c0c770161c2db464a5aab3f0567d27603fff889ede70e1f6e197e7ff1c1639dc4cc543457bcf45761f0f8e6dffafccfa773a4e3f
-DIST mesa-20.0.4.tar.xz 12292888 BLAKE2B a14b747045ee4ff3bc07e527ad43d5b22047d6c9700cf290ba9c95e07bd88b9252bdd14380d4f0033dcb8fb652664987889d972db09462bcc69c8a7e843b606f SHA512 17d8bc3b56779a8e5648d81da9ee97b66bcec015710801edce4e8055fbb314cd9ebc1d112e3035480ba844c7d9ae6b5b1f1eac0cc0817e69e9253a7748451a55
+DIST mesa-20.0.8.tar.xz 12360736 BLAKE2B 19e3f8a40b34b5f17ed76077c5d92f728a134b2479c43d86674ed1818ab99639a9b732041f67488251df808564f6abe5b587d756ef9c7c13dcada87cd0fc05de SHA512 d906330c412899907dd05a84034a929107fccaf3044814c4b1f30ba5690cbcf1587b5f17534c6345111f3cb7cf292afd5984a60486643ff6f534b57cec615374
diff --git a/media-libs/mesa/mesa-20.0.4-r1.ebuild b/media-libs/mesa/mesa-20.0.8.ebuild
index 0f4c37a7..c378ffa8 100644
--- a/media-libs/mesa/mesa-20.0.4-r1.ebuild
+++ b/media-libs/mesa/mesa-20.0.8.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit llvm meson multilib-minimal pax-utils python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
OPENGL_DIR="xorg-x11"
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://mesa.freedesktop.org/archive/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
fi
LICENSE="MIT"
@@ -44,7 +44,6 @@ REQUIRED_USE="
gles1? ( egl )
gles2? ( egl )
vulkan? ( dri3
- || ( video_cards_i965 video_cards_iris video_cards_radeonsi )
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
@@ -147,9 +146,10 @@ RDEPEND="${RDEPEND}
# 1. List all the working slots (with min versions) in ||, newest first.
# 2. Update the := to specify *max* version, e.g. < 10.
# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_MAX_SLOT="9"
+LLVM_MAX_SLOT="10"
LLVM_DEPSTR="
|| (
+ sys-devel/llvm:10[${MULTILIB_USEDEP}]
sys-devel/llvm:9[${MULTILIB_USEDEP}]
sys-devel/llvm:8[${MULTILIB_USEDEP}]
)
@@ -248,7 +248,6 @@ x86? (
PATCHES=(
"${FILESDIR}"/${PN}-19.3.0-add-disable-tls-support.patch
- "${FILESDIR}"/${P}-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
)
llvm_check_deps() {
@@ -265,6 +264,14 @@ llvm_check_deps() {
}
pkg_pretend() {
+ if use vulkan; then
+ if ! use video_cards_i965 &&
+ ! use video_cards_iris &&
+ ! use video_cards_radeonsi; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, or radeonsi"
+ fi
+ fi
+
if use opencl; then
if ! use video_cards_r600 &&
! use video_cards_radeonsi; then
@@ -331,6 +338,15 @@ pkg_setup() {
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
+ # os_same_file_description requires the kcmp syscall,
+ # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+ # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+ # get a spooky warning message if the syscall fails.
+ if use gallium && use video_cards_radeonsi; then
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ linux-info_pkg_setup
+ fi
+
if use gallium && use llvm; then
llvm_pkg_setup
fi
@@ -510,8 +526,6 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
-
- use libglvnd && rm -f "${D}"/usr/$(get_libdir)/pkgconfig/{egl,gl}.pc
}
multilib_src_install_all() {