aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2018-06-17 10:40:30 +0200
committerAnthony G. Basile <blueness@gentoo.org>2018-06-17 05:37:31 -0400
commitedbb471dd26af5ef52ce9fba2a0e5f7642032299 (patch)
treef44c156b0ceb2962c4dd98a03b0fc2bf13dd470e
parentnet-misc/networkmanager: fix metadata (diff)
downloadmusl-edbb471dd26af5ef52ce9fba2a0e5f7642032299.tar.gz
musl-edbb471dd26af5ef52ce9fba2a0e5f7642032299.tar.bz2
musl-edbb471dd26af5ef52ce9fba2a0e5f7642032299.zip
media-sound/mpd: revbump
-rw-r--r--media-sound/mpd/Manifest2
-rw-r--r--media-sound/mpd/files/mpd-0.20.4.init32
-rw-r--r--media-sound/mpd/files/mpd-0.20.4.logrotate6
-rw-r--r--media-sound/mpd/files/mpd-0.9.15-systemd.patch106
-rw-r--r--media-sound/mpd/files/mpd.logrotate7
-rw-r--r--media-sound/mpd/files/mpd2.init36
-rw-r--r--media-sound/mpd/metadata.xml2
-rw-r--r--media-sound/mpd/mpd-0.20.10.ebuild (renamed from media-sound/mpd/mpd-0.19.19.ebuild)207
8 files changed, 147 insertions, 251 deletions
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
index 55f46f00..f6e5dde4 100644
--- a/media-sound/mpd/Manifest
+++ b/media-sound/mpd/Manifest
@@ -1 +1 @@
-DIST mpd-0.19.19.tar.xz 707356 SHA256 bc856cda4136403446d53d11576f86990b61d1fe4668f6008e9eae47450d4e1d SHA512 949bfab2aa5dffb4089ce2023accc934648091d36768f8e4c75f62b4038e21db1e2ef3bb07a0f1cf6a91d0532cac8e7146be948d84dc4d7cdc5b252b7d815b64 WHIRLPOOL 1b2c68d998a26de41bca25cbeab0c6478406c831ac4322162d2c258622224137a1a2dcd88b690ee1869c7f2652201fd534ee773a6e51f6e61bdb5926783f4d75
+DIST mpd-0.20.10.tar.xz 778828 BLAKE2B c16b955ace770cf3d5da2ccad81fd3089cf2e60bf47774745d75babcff38fa344646b26dd32617fa2fe86ee0c785b9c8272ea6c90f77266b1a0cba2d48145236 SHA512 bac6a71e5b85600c590eae6b785474574cf0d7b03d9add537161b968a2997a975a597639a9fece119a01a7e27b5207523e4ae30b2f4f35791eff8c3ff26d107c
diff --git a/media-sound/mpd/files/mpd-0.20.4.init b/media-sound/mpd/files/mpd-0.20.4.init
new file mode 100644
index 00000000..0a4c6167
--- /dev/null
+++ b/media-sound/mpd/files/mpd-0.20.4.init
@@ -0,0 +1,32 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+: CFGFILE=${CFGFILE:=/etc/mpd.conf}
+
+depend() {
+ need localmount
+ use net netmount nfsmount alsasound esound pulseaudio
+ config ${CFGFILE}
+}
+
+get_config() {
+ x=$1
+ test -e ${CFGFILE} || return 1
+ sed -n \
+ -e '/^[ \t]*'${x}'/{s:^[ \t]*'${x}'[ \t]\+"\?\([^#"]\+\)[^"]*"\?$:\1: ; p }' \
+ ${CFGFILE}
+}
+
+extra_started_commands='reload'
+command=/usr/bin/mpd
+command_args=${CFGFILE}
+required_files=${CFGFILE}
+pidfile=$(get_config pid_file)
+description="Music Player Daemon"
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ kill -HUP `cat ${pidfile}`
+ eend $?
+}
diff --git a/media-sound/mpd/files/mpd-0.20.4.logrotate b/media-sound/mpd/files/mpd-0.20.4.logrotate
new file mode 100644
index 00000000..ff47d109
--- /dev/null
+++ b/media-sound/mpd/files/mpd-0.20.4.logrotate
@@ -0,0 +1,6 @@
+/var/lib/mpd/log {
+ missingok
+ postrotate
+ /etc/init.d/mpd reload
+ endscript
+}
diff --git a/media-sound/mpd/files/mpd-0.9.15-systemd.patch b/media-sound/mpd/files/mpd-0.9.15-systemd.patch
deleted file mode 100644
index cd03ebe1..00000000
--- a/media-sound/mpd/files/mpd-0.9.15-systemd.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-Description: transition to libsystemd from deprecated libsystemd-daemon
- systemd 209 merged the various libsystemd-* libraries into a single
- libsystemd.so, so we check for that instead and rename the configure
- option, define, etc accordingly.
-Author: Florian Schlichting <fsfs@debian.org>
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779762
-Forwarded: not-needed (solved in a less invasive and backward-compatible way upstream)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -572,10 +572,10 @@
- MPD_DEPENDS([enable_sqlite], [enable_glib],
- [Cannot use --enable-sqlite with --disable-glib])
-
--AC_ARG_ENABLE(systemd-daemon,
-- AS_HELP_STRING([--enable-systemd-daemon],
-- [use the systemd daemon library (default=auto)]),,
-- [enable_systemd_daemon=$linux_auto])
-+AC_ARG_ENABLE(systemd,
-+ AS_HELP_STRING([--enable-systemd],
-+ [use the systemd library (default=auto)]),,
-+ [enable_systemd=$linux_auto])
-
- AC_ARG_ENABLE(tcp,
- AS_HELP_STRING([--disable-tcp],
-@@ -762,11 +762,11 @@
- AC_MSG_ERROR([No client interfaces configured!])
- fi
-
--MPD_AUTO_PKG(systemd_daemon, SYSTEMD_DAEMON, libsystemd-daemon,
-- [systemd activation], [libsystemd-daemon not found])
--AM_CONDITIONAL(ENABLE_SYSTEMD_DAEMON, test x$enable_systemd_daemon = xyes)
--if test x$enable_systemd_daemon = xyes; then
-- AC_DEFINE([ENABLE_SYSTEMD_DAEMON], 1, [Define to use the systemd daemon library])
-+MPD_AUTO_PKG(systemd, SYSTEMD, libsystemd,
-+ [systemd activation], [libsystemd not found])
-+AM_CONDITIONAL(ENABLE_SYSTEMD, test x$enable_systemd = xyes)
-+if test x$enable_systemd = xyes; then
-+ AC_DEFINE([ENABLE_SYSTEMD], 1, [Define to use the systemd library])
- fi
-
- dnl ---------------------------------------------------------------------------
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -58,7 +58,7 @@
- $(ICU_LDADD) \
- libutil.a \
- $(FS_LIBS) \
-- $(SYSTEMD_DAEMON_LIBS) \
-+ $(SYSTEMD_LIBS) \
- $(GLIB_LIBS)
-
- src_mpd_SOURCES = \
---- a/config.h.in
-+++ b/config.h.in
-@@ -75,8 +75,8 @@
- /* Define to enable sqlite database support */
- #undef ENABLE_SQLITE
-
--/* Define to use the systemd daemon library */
--#undef ENABLE_SYSTEMD_DAEMON
-+/* Define to use the systemd library */
-+#undef ENABLE_SYSTEMD
-
- /* Define to enable the TwoLAME encoder plugin */
- #undef ENABLE_TWOLAME_ENCODER
---- a/src/Listen.cxx
-+++ b/src/Listen.cxx
-@@ -32,7 +32,7 @@
- #include <string.h>
- #include <assert.h>
-
--#ifdef ENABLE_SYSTEMD_DAEMON
-+#ifdef ENABLE_SYSTEMD
- #include <systemd/sd-daemon.h>
- #endif
-
-@@ -77,7 +77,7 @@
- }
- }
-
--#ifdef ENABLE_SYSTEMD_DAEMON
-+#ifdef ENABLE_SYSTEMD
-
- static bool
- listen_systemd_activation(Error &error_r)
-@@ -109,7 +109,7 @@
-
- listen_socket = new ClientListener(loop, partition);
-
--#ifdef ENABLE_SYSTEMD_DAEMON
-+#ifdef ENABLE_SYSTEMD
- if (listen_systemd_activation(error))
- return true;
-
---- a/doc/user.xml
-+++ b/doc/user.xml
-@@ -110,7 +110,7 @@
- libupnp-dev \
- libavahi-client-dev \
- libsqlite3-dev \
-- libsystemd-daemon-dev libwrap0-dev \
-+ libsystemd-dev libwrap0-dev \
- libcppunit-dev xmlto \
- libboost-dev \
- libglib2.0-dev libicu-dev
diff --git a/media-sound/mpd/files/mpd.logrotate b/media-sound/mpd/files/mpd.logrotate
deleted file mode 100644
index c913c1fa..00000000
--- a/media-sound/mpd/files/mpd.logrotate
+++ /dev/null
@@ -1,7 +0,0 @@
-/var/lib/mpd/log {
- missingok
- postrotate
- [ -f /var/run/mpd.pid ] && cat /var/run/mpd.pid | xargs /bin/kill -HUP
- [ -f /var/lib/mpd/pid ] && cat /var/lib/mpd/pid | xargs /bin/kill -HUP
- endscript
-}
diff --git a/media-sound/mpd/files/mpd2.init b/media-sound/mpd/files/mpd2.init
deleted file mode 100644
index ae5a2cce..00000000
--- a/media-sound/mpd/files/mpd2.init
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount
- use net netmount nfsmount alsasound esound pulseaudio
-}
-
-checkconfig() {
- if ! [ -f /etc/mpd.conf ]; then
- eerror "Configuration file /etc/mpd.conf does not exist."
- return 1
- fi
-
- if ! grep -q '^\s*pid_file' /etc/mpd.conf; then
- eerror "Invalid configuration: pid_file needs to be set."
- return 1
- fi
-
- return 0
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting Music Player Daemon"
- start-stop-daemon --start --quiet --exec /usr/bin/mpd -- /etc/mpd.conf 2>/dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping Music Player Daemon"
- /usr/bin/mpd --kill
- eend $?
-}
diff --git a/media-sound/mpd/metadata.xml b/media-sound/mpd/metadata.xml
index dc07436a..23086d35 100644
--- a/media-sound/mpd/metadata.xml
+++ b/media-sound/mpd/metadata.xml
@@ -17,7 +17,6 @@
<flag name="faad">Use external faad library for AAC decoding</flag>
<flag name="fifo">Support writing audio to a FIFO</flag>
<flag name="fluidsynth">Enables Fluidsynth MIDI software synthesis (discouraged)</flag>
- <flag name="glib">Enable GLib usage</flag>
<flag name="gme">Enables support for <pkg>media-libs/game-music-emu</pkg> for playing various video game music formats.</flag>
<flag name="id3tag">Support for ID3 tags</flag>
<flag name="inotify">Use the Linux kernel inotify subsystem to notice changes to mpd music library</flag>
@@ -35,6 +34,7 @@
<flag name="soundcloud">Build plugin to access soundcloud</flag>
<flag name="systemd">Enable support for systemd socket activation</flag>
<flag name="twolame">Support twolame MPEG-2 encoding</flag>
+ <flag name="webdav">Enable using music from a WebDAV share</flag>
<flag name="wildmidi">Enable MIDI support via wildmidi</flag>
<flag name="zip">Support for ZIP files</flag>
</use>
diff --git a/media-sound/mpd/mpd-0.19.19.ebuild b/media-sound/mpd/mpd-0.20.10.ebuild
index 34e2a692..2b985cff 100644
--- a/media-sound/mpd/mpd-0.19.19.ebuild
+++ b/media-sound/mpd/mpd-0.20.10.ebuild
@@ -1,49 +1,45 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils flag-o-matic linux-info multilib systemd user
+inherit autotools flag-o-matic linux-info systemd user
DESCRIPTION="The Music Player Daemon (mpd)"
-HOMEPAGE="https://www.musicpd.org"
+HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/MPD"
SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm ppc ~sh x86"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 ~sh x86 ~x86-fbsd ~x64-macos"
IUSE="adplug +alsa ao audiofile bzip2 cdio +curl debug +eventfd expat faad
- +fifo +ffmpeg flac fluidsynth +glib gme +icu +id3tag +inotify +ipv6 jack
+ +fifo +ffmpeg flac fluidsynth gme +icu +id3tag +inotify +ipv6 jack
lame mms libav libmpdclient libsamplerate libsoxr +mad mikmod modplug
mpg123 musepack +network nfs ogg openal opus oss pipe pulseaudio recorder
samba selinux sid +signalfd sndfile soundcloud sqlite systemd tcpd twolame
- unicode upnp vorbis wavpack wildmidi zeroconf zip zlib"
+ unicode upnp vorbis wavpack wildmidi zeroconf zip zlib webdav"
OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio recorder"
DECODER_PLUGINS="adplug audiofile faad ffmpeg flac fluidsynth mad mikmod
modplug mpg123 musepack ogg flac sid vorbis wavpack wildmidi"
ENCODER_PLUGINS="audiofile flac lame twolame vorbis"
-REQUIRED_USE="|| ( ${OUTPUT_PLUGINS} )
+REQUIRED_USE="
+ || ( ${OUTPUT_PLUGINS} )
|| ( ${DECODER_PLUGINS} )
- ao? ( glib )
- gme? ( glib )
- jack? ( glib )
- network? ( || ( ${ENCODER_PLUGINS} )
- glib )
+ network? ( || ( ${ENCODER_PLUGINS} ) )
recorder? ( || ( ${ENCODER_PLUGINS} ) )
- sid? ( glib )
- soundcloud? ( glib )
- sqlite? ( glib )
opus? ( ogg )
upnp? ( expat )
- vorbis? ( glib )
- wavpack? ( glib )"
+ webdav? ( curl expat )
+"
CDEPEND="!<sys-cluster/mpich2-1.4_rc2
adplug? ( media-libs/adplug )
- alsa? ( media-sound/alsa-utils
- media-libs/alsa-lib )
+ alsa? (
+ media-sound/alsa-utils
+ media-libs/alsa-lib
+ )
ao? ( media-libs/libao[alsa?,pulseaudio?] )
audiofile? ( media-libs/audiofile )
bzip2? ( app-arch/bzip2 )
@@ -57,37 +53,38 @@ CDEPEND="!<sys-cluster/mpich2-1.4_rc2
)
flac? ( media-libs/flac[ogg?] )
fluidsynth? ( media-sound/fluidsynth )
- glib? ( dev-libs/glib:2 )
gme? ( >=media-libs/game-music-emu-0.6.0_pre20120802 )
icu? ( dev-libs/icu:= )
id3tag? ( media-libs/libid3tag )
- jack? ( media-sound/jack-audio-connection-kit )
+ jack? ( virtual/jack )
lame? ( network? ( media-sound/lame ) )
libmpdclient? ( media-libs/libmpdclient )
libsamplerate? ( media-libs/libsamplerate )
+ libsoxr? ( media-libs/soxr )
mad? ( media-libs/libmad )
mikmod? ( media-libs/libmikmod:0 )
mms? ( media-libs/libmms )
modplug? ( media-libs/libmodplug )
mpg123? ( >=media-sound/mpg123-1.12.2 )
musepack? ( media-sound/musepack-tools )
- network? ( >=media-libs/libshout-2
- !lame? ( !vorbis? ( media-libs/libvorbis ) ) )
+ network? (
+ >=media-libs/libshout-2
+ !lame? ( !vorbis? ( media-libs/libvorbis ) )
+ )
nfs? ( net-fs/libnfs )
ogg? ( media-libs/libogg )
openal? ( media-libs/openal )
opus? ( media-libs/opus )
pulseaudio? ( media-sound/pulseaudio )
- samba? ( || ( <net-fs/samba-4.0.25[smbclient] >=net-fs/samba-4.0.25 ) )
+ samba? ( >=net-fs/samba-4.0.25 )
sid? ( || ( media-libs/libsidplay:2 media-libs/libsidplayfp ) )
sndfile? ( media-libs/libsndfile )
- soundcloud? ( >=dev-libs/yajl-2 )
- libsoxr? ( media-libs/soxr )
+ soundcloud? ( >=dev-libs/yajl-2:= )
sqlite? ( dev-db/sqlite:3 )
systemd? ( sys-apps/systemd )
tcpd? ( sys-apps/tcp-wrappers )
twolame? ( media-sound/twolame )
- upnp? ( net-libs/libupnp )
+ upnp? ( net-libs/libupnp:= )
vorbis? ( media-libs/libvorbis )
wavpack? ( media-sound/wavpack )
wildmidi? ( media-sound/wildmidi )
@@ -103,7 +100,6 @@ RDEPEND="${CDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-0.18.conf.patch
- "${FILESDIR}"/${PN}-0.9.15-systemd.patch # bug 584742
"${FILESDIR}"/fix-mpd-stacksize.patch
)
@@ -140,86 +136,100 @@ src_prepare() {
}
src_configure() {
- local mpdconf="--enable-database --disable-roar --disable-documentation
+ local myeconfargs=(
+ --enable-database --disable-roar --disable-documentation
--enable-dsd --enable-largefile --disable-osx --disable-shine-encoder
--disable-solaris-output --enable-tcp --enable-un --disable-werror
- --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ )
if use network; then
- mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
- --enable-httpd-output $(use_enable lame lame-encoder)
+ myeconfargs+=(
+ --enable-shout
+ $(use_enable vorbis vorbis-encoder)
+ --enable-httpd-output
+ $(use_enable lame lame-encoder)
$(use_enable twolame twolame-encoder)
- $(use_enable audiofile wave-encoder)"
+ $(use_enable audiofile wave-encoder)
+ )
else
- mpdconf+=" --disable-shout --disable-vorbis-encoder
- --disable-httpd-output --disable-lame-encoder
- --disable-twolame-encoder --disable-wave-encoder"
+ myeconfargs+=(
+ --disable-shout
+ --disable-vorbis-encoder
+ --disable-httpd-output
+ --disable-lame-encoder
+ --disable-twolame-encoder
+ --disable-wave-encoder
+ )
fi
if use samba || use upnp; then
- mpdconf+=" --enable-neighbor-plugins"
+ myeconfargs+=( --enable-neighbor-plugins )
fi
append-lfs-flags
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders"
- econf \
- $(use_enable eventfd) \
- $(use_enable signalfd) \
- $(use_enable libmpdclient) \
- $(use_enable expat) \
- $(use_enable upnp) \
- $(use_enable adplug) \
- $(use_enable alsa) \
- $(use_enable ao) \
- $(use_enable audiofile) \
- $(use_enable zlib) \
- $(use_enable bzip2) \
- $(use_enable cdio cdio-paranoia) \
- $(use_enable curl) \
- $(use_enable samba smbclient) \
- $(use_enable nfs) \
- $(use_enable debug) \
- $(use_enable ffmpeg) \
- $(use_enable fifo) \
- $(use_enable flac) \
- $(use_enable fluidsynth) \
- $(use_enable gme) \
- $(use_enable id3tag id3) \
- $(use_enable inotify) \
- $(use_enable ipv6) \
- $(use_enable cdio iso9660) \
- $(use_enable jack) \
- $(use_enable soundcloud) \
- $(use_enable tcpd libwrap) \
- $(use_enable libsamplerate lsr) \
- $(use_enable libsoxr soxr) \
- $(use_enable mad) \
- $(use_enable mikmod) \
- $(use_enable mms) \
- $(use_enable modplug) \
- $(use_enable musepack mpc) \
- $(use_enable mpg123) \
- $(use_enable openal) \
- $(use_enable opus) \
- $(use_enable oss) \
- $(use_enable pipe pipe-output) \
- $(use_enable pulseaudio pulse) \
- $(use_enable recorder recorder-output) \
- $(use_enable sid sidplay) \
- $(use_enable sndfile sndfile) \
- $(use_enable sqlite) \
- $(use_enable systemd) \
- $(use_enable vorbis) \
- $(use_enable wavpack) \
- $(use_enable wildmidi) \
- $(use_enable zip zzip) \
- $(use_enable icu) \
- $(use_enable glib) \
- $(use_enable faad aac) \
- $(use_with zeroconf zeroconf avahi) \
- --with-systemdsystemunitdir=$(systemd_get_systemunitdir) \
- ${mpdconf}
+ myeconfargs+=(
+ $(use_enable eventfd)
+ $(use_enable signalfd)
+ $(use_enable libmpdclient)
+ $(use_enable expat)
+ $(use_enable upnp)
+ $(use_enable adplug)
+ $(use_enable alsa)
+ $(use_enable ao)
+ $(use_enable audiofile)
+ $(use_enable zlib)
+ $(use_enable bzip2)
+ $(use_enable cdio cdio-paranoia)
+ $(use_enable curl)
+ $(use_enable samba smbclient)
+ $(use_enable nfs)
+ $(use_enable debug)
+ $(use_enable ffmpeg)
+ $(use_enable fifo)
+ $(use_enable flac)
+ $(use_enable fluidsynth)
+ $(use_enable gme)
+ $(use_enable id3tag id3)
+ $(use_enable inotify)
+ $(use_enable ipv6)
+ $(use_enable cdio iso9660)
+ $(use_enable jack)
+ $(use_enable soundcloud)
+ $(use_enable tcpd libwrap)
+ $(use_enable libsamplerate lsr)
+ $(use_enable libsoxr soxr)
+ $(use_enable mad)
+ $(use_enable mikmod)
+ $(use_enable mms)
+ $(use_enable modplug)
+ $(use_enable musepack mpc)
+ $(use_enable mpg123)
+ $(use_enable openal)
+ $(use_enable opus)
+ $(use_enable oss)
+ $(use_enable pipe pipe-output)
+ $(use_enable pulseaudio pulse)
+ $(use_enable recorder recorder-output)
+ $(use_enable sid sidplay)
+ $(use_enable sndfile sndfile)
+ $(use_enable sqlite)
+ $(use_enable systemd systemd_daemon)
+ $(use_enable vorbis)
+ $(use_enable wavpack)
+ $(use_enable wildmidi)
+ $(use_enable zip zzip)
+ $(use_enable icu)
+ $(use_enable webdav)
+ $(use_enable faad aac)
+ $(use_with zeroconf zeroconf avahi)
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+ --with-systemduserunitdir=$(systemd_get_userunitdir)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -228,11 +238,7 @@ src_install() {
insinto /etc
newins doc/mpdconf.dist mpd.conf
- newinitd "${FILESDIR}"/${PN}2.init ${PN}
-
- systemd_newuserunit systemd/${PN}.service ${PN}.service
- sed -i '/WantedBy=/c WantedBy=default.target' \
- "${ED}"/usr/lib/systemd/user/mpd.service || die "sed failed"
+ newinitd "${FILESDIR}"/${PN}-0.20.4.init ${PN}
if use unicode; then
sed -i -e 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
@@ -240,7 +246,7 @@ src_install() {
fi
insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ newins "${FILESDIR}"/${PN}-0.20.4.logrotate ${PN}
use prefix || diropts -m0755 -o mpd -g audio
dodir /var/lib/mpd
@@ -255,3 +261,4 @@ pkg_postinst() {
# also change the homedir if the user has existed before
usermod -d "/var/lib/mpd" mpd
}
+