summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-12 15:54:00 -0400
committerBrian Evans <grknight@gentoo.org>2018-03-12 15:54:00 -0400
commit3e8cb1fb6e9b2aa83bee3c0eacfd957d144c8982 (patch)
treeede6b8b3fcb50fac2430908ea2961922bf9f08eb
parentclient-libs: Dont install pkgconfig file (diff)
downloadmysql-extras-3e8cb1fb6e9b2aa83bee3c0eacfd957d144c8982.tar.gz
mysql-extras-3e8cb1fb6e9b2aa83bee3c0eacfd957d144c8982.tar.bz2
mysql-extras-3e8cb1fb6e9b2aa83bee3c0eacfd957d144c8982.zip
client-libs: Dont install m4 when not neededmysql-extras-20180312-2011Z
-rw-r--r--20018_all_mysql-5.7.21-without-clientlibs-tools.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/20018_all_mysql-5.7.21-without-clientlibs-tools.patch b/20018_all_mysql-5.7.21-without-clientlibs-tools.patch
index 05f5328..0ca8f48 100644
--- a/20018_all_mysql-5.7.21-without-clientlibs-tools.patch
+++ b/20018_all_mysql-5.7.21-without-clientlibs-tools.patch
@@ -154,3 +154,16 @@ diff -aurN a/libmysql/CMakeLists.txt b/libmysql/CMakeLists.txt
IF(UNIX)
# libtool compatability
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
+--- a/support-files/CMakeLists.txt 2018-03-12 14:11:44.931656906 -0400
++++ b/support-files/CMakeLists.txt 2018-03-12 15:44:53.381846650 -0400
+@@ -59,8 +59,9 @@
+ IF(INSTALL_SUPPORTFILESDIR)
+ INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
+ ENDIF()
+-
++IF(NOT WITHOUT_CLIENTLIBS)
+ INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
++ENDIF(NOT WITHOUT_CLIENTLIBS)
+
+ SET(bindir ${prefix}/${INSTALL_BINDIR})
+ SET(sbindir ${prefix}/${INSTALL_SBINDIR})