summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Lucas <sascha_lucas@web.de>2008-11-14 12:12:22 +0100
committerSascha Lucas <sascha_lucas@web.de>2008-11-14 12:12:22 +0100
commit5def5f3d589a85c1c3d59fe5dc02f19074a5fa31 (patch)
tree1a1815c01349b95ed7e9b55ab0b500ff00c965f2
parentStart with a repo_name (diff)
downloadnet-mail-5def5f3d589a85c1c3d59fe5dc02f19074a5fa31.tar.gz
net-mail-5def5f3d589a85c1c3d59fe5dc02f19074a5fa31.tar.bz2
net-mail-5def5f3d589a85c1c3d59fe5dc02f19074a5fa31.zip
initial import of alpine-2.00
-rw-r--r--mail-client/alpine/Manifest3
-rw-r--r--mail-client/alpine/alpine-2.00.ebuild136
2 files changed, 139 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
new file mode 100644
index 0000000..fc2e7c7
--- /dev/null
+++ b/mail-client/alpine/Manifest
@@ -0,0 +1,3 @@
+DIST all.patch.gz 175441 RMD160 61a305811c9d12596eacd66d21aee8edccec469d SHA1 701be50ee37cc1e35ae1df49f9228244197cb91b SHA256 2c66cf76ad413aefd31e5eb8e00198a2739e3816e9f676fa84f2186bf2ea084d
+DIST alpine-2.00.tar.bz2 5222673 RMD160 9e67704b23b3973d8b878e65ad9e6f5026c10d13 SHA1 dcbd3c5419954f484ccf706feaba31ce48cdebc4 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
+EBUILD alpine-2.00.ebuild 3772 RMD160 2d82f187d08815c7321e8428409968da310c3973 SHA1 a788dc1dcf2b3a54cdcb108d51f80874001e2b44 SHA256 861ba737f908a7add43f880a82b66a4e4d08f4e5bfc37205d74b8c78b8eeb80c
diff --git a/mail-client/alpine/alpine-2.00.ebuild b/mail-client/alpine/alpine-2.00.ebuild
new file mode 100644
index 0000000..54d143b
--- /dev/null
+++ b/mail-client/alpine/alpine-2.00.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="alpine is the successor of the famous mail and news reader pine"
+HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
+SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
+ chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~x86-fbsd"
+IUSE="chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal userland_BSD"
+RESTRICT="nomirror"
+
+DEPEND="virtual/pam
+ >=sys-libs/ncurses-5.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+ topal? ( >=mail-client/topal-62 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ !onlyalpine? ( !app-editors/pico )
+ !onlyalpine? ( !mail-client/pine )
+ !<=net-mail/uw-imap-2004g"
+
+maildir_warn() {
+ elog
+ elog "This build of ${PN} has Maildir support built in as"
+ elog "part of the chappa-all patch."
+ elog
+ elog "If you have a maildir at ~/Maildir it will be your"
+ elog "default INBOX. The path may be changed with the"
+ elog "\"maildir-location\" setting in alpine."
+ elog
+ elog "To use /var/spool/mail INBOX again, set"
+ elog "\"disable-these-drivers=md\" in your .pinerc file."
+ elog
+ elog "Alternately, you might want to read following webpage, which explains how to"
+ elog "use multiple mailboxes simultaneously:"
+ elog
+ elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+ elog
+}
+
+src_unpack() {
+ unpack ${A}
+ use chappa && epatch "${WORKDIR}"/all.patch
+ # topal needs updating for alpine 2.00
+ #use topal && epatch /usr/share/topal/patches/${P}.patch
+ use topal && die "topal needs updating for ${P}. Please disable it for now."
+}
+
+src_compile() {
+ local myconf="--without-tcl
+ --with-system-pinerc=/etc/pine.conf
+ --with-system-fixed-pinerc=/etc/pine.conf.fixed
+ --with-ssl-certs-dir=/etc/ssl/certs"
+
+ use ssl || myconf="${myconf} --without-ssl"
+ use ldap || myconf="${myconf} --without-ldap"
+ use passfile && myconf="${myconf} --with-passfile=.pinepwd"
+ use kerberos || myconf="${myconf} --without-krb5"
+ use threads || myconf="${myconf} --without-pthread"
+ use spell && myconf="${myconf} --with-interactive-spellcheck=/usr/bin/aspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use ipv6 || myconf="${myconf} --without-ipv6"
+ use smime || myconf="${myconf} --without-smime"
+
+ # fixme
+ # --with-system-mail-directory=DIR?
+
+ econf ${myconf} || die "configure problem"
+
+ use userland_BSD && make || emake
+}
+
+src_install() {
+ if use onlyalpine; then
+ dobin alpine/alpine
+ doman doc/alpine.1
+ else
+ if use userland_BSD; then
+ make DESTDIR="${D}" install
+ else
+ emake DESTDIR="${D}" install
+ fi
+
+ doman doc/rpdump.1 doc/rpload.1
+ fi
+
+ dodoc NOTICE
+ if use chappa; then
+ dodoc README.maildir
+ fi
+
+ if use doc; then
+ dodoc README doc/brochure.txt doc/tech-notes.txt
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+ fi
+}
+
+pkg_postinst() {
+ use chappa && maildir_warn
+ if use spell; then
+ elog
+ elog "In order to use spell checking"
+ elog " emerge app-dicts/aspell-\<your_langs\>"
+ elog "and setup alpine with:"
+ elog " Speller = /usr/bin/aspell -c"
+ elog
+ fi
+ if use topal; then
+ elog
+ elog "In order to use gpg with topal"
+ elog " read /usr/doc/topal/README.txt"
+ elog
+ fi
+ if use passfile ; then
+ elog
+ elog "${PN} will cache passwords between connections."
+ elog "File ~/.pinepwd will be used for this."
+ elog
+ fi
+}