summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <torsten@veller.net>2009-04-15 12:24:23 +0200
committerTorsten Veller <torsten@veller.net>2009-04-15 12:24:23 +0200
commita7eae94c319cddc2a5af474f4b406b2ee19cc531 (patch)
tree0eebc31a6db26020414e075c05256dacc54e508b /net-mail/topal/topal-64.ebuild
parentFix as-needed failure (diff)
downloadnet-mail-a7eae94c319cddc2a5af474f4b406b2ee19cc531.tar.gz
net-mail-a7eae94c319cddc2a5af474f4b406b2ee19cc531.tar.bz2
net-mail-a7eae94c319cddc2a5af474f4b406b2ee19cc531.zip
Move mail-client/topal -> net-mail/topal.
Diffstat (limited to 'net-mail/topal/topal-64.ebuild')
-rw-r--r--net-mail/topal/topal-64.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/topal/topal-64.ebuild b/net-mail/topal/topal-64.ebuild
new file mode 100644
index 0000000..ad4a566
--- /dev/null
+++ b/net-mail/topal/topal-64.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Topal is a 'glue' program that links GnuPG and Pine/Alpine."
+HOMEPAGE="http://homepage.ntlworld.com/phil.brooke/topal/"
+SRC_URI="http://homepage.ntlworld.com/phil.brooke/topal/rel-${PV}/topal-package-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=virtual/gnat-4.2"
+RDEPEND=">=app-crypt/gnupg-2.0.7-r1
+ net-mail/metamail"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake install \
+ INSTALLPATH="${D}"/usr \
+ INSTALLPATHDOC="${D}"/usr/share/doc/${PF} \
+ || die "make install failed"
+ dohtml "${S}"/README.html ||ide
+}
+