summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/alpine/alpine-2.00.ebuild')
-rw-r--r--mail-client/alpine/alpine-2.00.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/mail-client/alpine/alpine-2.00.ebuild b/mail-client/alpine/alpine-2.00.ebuild
index 9ee3db9..e146775 100644
--- a/mail-client/alpine/alpine-2.00.ebuild
+++ b/mail-client/alpine/alpine-2.00.ebuild
@@ -4,10 +4,10 @@
EAPI="2"
-inherit eutils
+inherit eutils flag-o-matic
# http://staff.washington.edu/chappa/alpine/patches/${P}/log.txt
-CHAPPA_PL="17"
+CHAPPA_PL="18"
DESCRIPTION="alpine is an easy to use text-based based mail and news client"
HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
@@ -67,13 +67,6 @@ src_configure() {
--with-ssl-certs-dir=/etc/ssl/certs"
# fixme
# --with-system-mail-directory=DIR?
- # smime should be off if topal is on
- # fixme
- # --as-needed breaks linking of c-client for executables
- # filter-ldflags --as-needed does not work for
- # "-Wl,-O1,--as-needed,-z,now" ??
- #LDFLAGS=`echo $LDFLAGS | sed s/--as-needed//g | sed s/,,/,/g`
- #econf ${myconf} LDFLAGS="$LDFLAGS" || die "configure problem"
econf $(use_with ssl) \
$(use_with ldap) \
$(use_with passfile passfile .pinepwd) \
@@ -82,7 +75,7 @@ src_configure() {
$(use_with spell interactive-spellcheck /usr/bin/aspell) \
$(use_enable nls) \
$(use_with ipv6) \
- $(use_with smime) \
+ $(use topal || use_with smime) \
${myconf} || die "configure problem"
}
@@ -117,6 +110,18 @@ src_install() {
fi
}
+pkg_setup() {
+ if use smime && use topal ; then
+ ewarn "You can not have USE='smime topal'. Assuming topal is more important."
+ fi
+ # untill someone finds the right solution, we filter --as-needed
+ # see http://www.gentoo.org/proj/en/qa/asneeded.xml section "Importance of linking order"
+ # it seems that "-lpam -ldl -lcrypto" get fed into link command to early
+ # imap/src/osdep/unix/Makefile
+ # imap/Makefile
+ append-ldflags -Wl,--no-as-needed
+}
+
pkg_postinst() {
use chappa && maildir_warn
if use spell; then