summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 9302f27..5b20643 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ else
PN=nxml-gentoo-schemas-$(shell date '+%Y%m%d')
endif
-TARBALL=$(PN).tar.bz2
+TARBALL=$(PN).tar.xz
.SUFFIXES: .dtd .rnc .dep
.PHONY: depend all clean
@@ -30,7 +30,7 @@ clean:
$(TARBALL): Makefile LICENCE DONATING schemas.xml $(RNCS)
mkdir -p $(PN)
cp $^ $(PN)
- tar jcf $@ $(PN)
+ tar cJf $@ $(PN)
.dtd.dep:
echo > $@
@@ -44,7 +44,11 @@ $(TARBALL): Makefile LICENCE DONATING schemas.xml $(RNCS)
.dtd.rnc:
trang -I dtd -O rnc $< $@
+metadata.rnc: metadata.dtd
+ trang -I dtd -O rnc -i no-generate-start $< $@
+ echo 'start = catmetadata | pkgmetadata' >> $@
+
%.dtd:
- wget -N --no-verbose http://www.gentoo.org/dtd/$@
+ wget -N --no-verbose https://www.gentoo.org/dtd/$@
-include .depend