aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-02-21 21:18:41 +0100
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-02-21 21:18:41 +0100
commitb495bec1de526405fabb2ad237cd696e50d138fa (patch)
tree23a7fc9194297dcb4c3e8580d4e502804e8039b6
parentCleanup whitespace. (diff)
downloadpambase-b495bec1de526405fabb2ad237cd696e50d138fa.tar.gz
pambase-b495bec1de526405fabb2ad237cd696e50d138fa.tar.bz2
pambase-b495bec1de526405fabb2ad237cd696e50d138fa.zip
Add support for optional GNOME Keyring module.pambase-2008022120080221
-rw-r--r--Makefile4
-rw-r--r--system-login.in9
2 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0772ae5..d898678 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,10 @@ ifeq "$(CONSOLEKIT)" "yes"
PAMFLAGS += -DHAVE_CONSOLEKIT
endif
+ifeq "$(GNOME_KEYRING)" "yes"
+PAMFLAGS += -DHAVE_GNOME_KEYRING
+endif
+
ifeq "$(SELINUX)" "yes"
PAMFLAGS += -DHAVE_SELINUX=1
endif
diff --git a/system-login.in b/system-login.in
index 89fb084..cdbee54 100644
--- a/system-login.in
+++ b/system-login.in
@@ -1,3 +1,6 @@
+#if HAVE_GNOME_KEYRING
+auth optional pam_gnome_keyring.so
+#endif
#if HAVE_TALLY
auth required pam_tally.so file=/var/log/faillog onerr=succeed DEBUG
#endif
@@ -16,11 +19,17 @@ account include system-auth
account required pam_tally.so file=/var/log/faillog onerr=succeed DEBUG
#endif
+#if HAVE_GNOME_KEYRING
+password optional pam_gnome_keyring.so
+#endif
password include system-auth
#if HAVE_SELINUX
session required pam_selinux.so close
#endif
+#if HAVE_GNOME_KEYRING
+session optional pam_gnome_keyring.so auto_start
+#endif
#if HAVE_ENV
session required pam_env.so DEBUG
#endif