aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-07-21 18:40:27 +0200
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-07-21 18:40:27 +0200
commitc3217660fc2bbab18e907a28982b476aa66f9261 (patch)
tree26f4d292b074f600aa7b4a1d23bd1f70a9d97ee9
parentMake sure gnome-keyring is always ran after system-auth has completed. (diff)
downloadpambase-c3217660fc2bbab18e907a28982b476aa66f9261.tar.gz
pambase-c3217660fc2bbab18e907a28982b476aa66f9261.tar.bz2
pambase-c3217660fc2bbab18e907a28982b476aa66f9261.zip
Add support for pam_ssh module.
The pam_ssh module allows you to type in your SSH key passphrase to login in the system, and also spawns an ssh-agent that has the passphrase cached in.
-rw-r--r--Makefile4
-rw-r--r--system-auth.in6
2 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 13398ff..651b641 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,10 @@ ifeq "$(MKTEMP)" "yes"
PAMFLAGS += -DHAVE_MKTEMP=1
endif
+ifeq "$(PAM_SSH)" "yes"
+PAMFLAGS += -DHAVE_PAM_SSH=1
+endif
+
ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif
diff --git a/system-auth.in b/system-auth.in
index 6cc19d1..eeba9ac 100644
--- a/system-auth.in
+++ b/system-auth.in
@@ -1,6 +1,9 @@
#if HAVE_ENV
auth required pam_env.so DEBUG
#endif
+#ifdef HAVE_PAM_SSH
+auth sufficient pam_ssh.so
+#endif
auth required pam_unix.so try_first_pass LIKEAUTH nullok DEBUG
account required pam_unix.so DEBUG
@@ -22,5 +25,8 @@ session required pam_env.so DEBUG
#if HAVE_MKTEMP
session optional pam_mktemp.so
#endif
+#ifdef HAVE_PAM_SSH
+session optional pam_ssh.so
+#endif
session required pam_unix.so DEBUG