aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-15 20:14:41 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-15 20:14:41 +0000
commitff55c4dbcec2f6f55dae6e620549eb25098e280f (patch)
tree47756a7b0ed511cb708ec9f5b5a214a18881c548 /Makefile
parentlddtree.py: break ldpath setup out so other modules can use it, fix set handl... (diff)
downloadpax-utils-ff55c4dbcec2f6f55dae6e620549eb25098e280f.tar.gz
pax-utils-ff55c4dbcec2f6f55dae6e620549eb25098e280f.tar.bz2
pax-utils-ff55c4dbcec2f6f55dae6e620549eb25098e280f.zip
install lddtree.py if USE_PYTHON=yes is set
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 23714ed..c8b7157 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003-2006 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.79 2012/02/04 18:22:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.80 2012/11/15 20:14:41 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -105,6 +105,9 @@ strip-more:
install: all
$(MKDIR) $(PREFIX)/bin/ $(MANDIR)/man1/ $(PKGDOCDIR)/
for sh in *.sh ; do $(INS_EXE) $$sh $(PREFIX)/bin/$${sh%.sh} || exit $$? ; done
+ifeq ($(USE_PYTHON),yes)
+ for py in *.py ; do $(INS_EXE) $$py $(PREFIX)/bin/$${py%.py} || exit $$? ; done
+endif
$(INS_EXE) $(TARGETS) $(PREFIX)/bin/
$(INS_DATA) README BUGS TODO $(PKGDOCDIR)/
$(INS_DATA) $(MPAGES) $(MANDIR)/man1/