aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 03:09:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 03:09:51 +0000
commit1bc1597a2c207976e95b62446dc695daf75dbe66 (patch)
tree7e9d95b9a3a05e5acc145c829fac172c13199dbf /Makefile
parentshould fix align warnings on ia64 (diff)
downloadpax-utils-1bc1597a2c207976e95b62446dc695daf75dbe66.tar.gz
pax-utils-1bc1597a2c207976e95b62446dc695daf75dbe66.tar.bz2
pax-utils-1bc1597a2c207976e95b62446dc695daf75dbe66.zip
tweak version output to include $PV
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4d0ed2d..73564f7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.30 2005/06/09 14:57:33 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.31 2005/06/13 03:09:51 vapier Exp $
####################################################################
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -38,6 +38,10 @@ STRIP := strip
MKDIR := mkdir -p
CP := cp
+ifdef PV
+HFLAGS += -DVERSION=\"$(PV)\"
+endif
+
# Build with -Werror while emerging
ifneq ($(S),)
WFLAGS += -Werror
@@ -57,7 +61,7 @@ debug: all
%.o: %.c
@echo $(CC) $(CFLAGS) -c $<
- @$(CC) $(CFLAGS) $(WFLAGS) -c $<
+ @$(CC) $(CFLAGS) $(WFLAGS) $(HFLAGS) -c $<
%: %.o paxelf.o
$(CC) $(CFLAGS) paxelf.o -o $@ $< $(LDFLAGS)