aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2008-09-08 07:02:56 +0000
committerFabian Groffen <grobian@gentoo.org>2008-09-08 07:02:56 +0000
commitb14fee9febef245dc43042a0feaa8620dbcc02ee (patch)
treeea12455d0f2c7d6cc029172cb3425656f52647e1 /Makefile
parent- add OSABI/EABI support to scanelf --osabi/--eabi to scanelf. Update elf.h (diff)
downloadpax-utils-b14fee9febef245dc43042a0feaa8620dbcc02ee.tar.gz
pax-utils-b14fee9febef245dc43042a0feaa8620dbcc02ee.tar.bz2
pax-utils-b14fee9febef245dc43042a0feaa8620dbcc02ee.zip
Initial commit of Mach-O related files. (bug #236512)
- added macho.h (Mach-O definitions) and scanmacho.c (the scanelf equivalent for Mach-O files) - changed the Makefile to compile scanmacho (tested compilation on Darwin and Solaris) - changed paxinc.h to include macho.h and paxmacho.h - extended paxmacho.[ch] with relevant code to read meta information from Mach-O files
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index e8af398..ec41560 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003-2006 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.67 2008/04/19 22:31:49 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.68 2008/09/08 07:02:56 grobian Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -50,11 +50,6 @@ TARGETS = $(ELF_TARGETS) $(MACH_TARGETS)
MPAGES = $(TARGETS:%=man/%.1)
SOURCES = $(OBJS:%.o=%.c)
-ifneq ($(MACH),1)
-MACH_TARGETS =
-MACH_OBJS =
-endif
-
all: $(OBJS) $(TARGETS)
@: