aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-03 21:08:04 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-03 21:08:04 +0000
commitfb2055cc8ad4386b6b3e09f38caa87a448d4eeed (patch)
tree2a4f8a660473dd7c487c184348c5409634b6c36c /Makefile
parentlddtree: handle "include" in ld.so.conf and LD_LIBRARY_PATH (diff)
downloadpax-utils-fb2055cc8ad4386b6b3e09f38caa87a448d4eeed.tar.gz
pax-utils-fb2055cc8ad4386b6b3e09f38caa87a448d4eeed.tar.bz2
pax-utils-fb2055cc8ad4386b6b3e09f38caa87a448d4eeed.zip
make xz tarballs
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 088f785..1f372a6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003-2006 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.75 2010/06/08 05:51:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.76 2011/03/03 21:08:04 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -122,14 +122,14 @@ dist:
cd pax-utils-$(PV) && cvs up
echo "<releaseinfo>$(PV)</releaseinfo>" > pax-utils-$(PV)/man/fragment/version
$(MAKE) -C pax-utils-$(PV)/man
- tar jcf pax-utils-$(PV).tar.bz2 pax-utils-$(PV) --exclude=CVS --exclude=.cvsignore
+ tar cf - pax-utils-$(PV) --exclude=CVS --exclude=.cvsignore | xz > pax-utils-$(PV).tar.xz
@printf "\n ..... Making sure clean cvs build works ..... \n\n"
unset CFLAGS; \
for t in all check clean debug check ; do \
$(MAKE) -C pax-utils-$(PV) $$t || exit $$? ; \
done
rm -rf pax-utils-$(PV)
- du -b pax-utils-$(PV).tar.bz2
+ du -b pax-utils-$(PV).tar.xz
-include .depend