summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Beltrame <mb@italpro.net>2008-08-13 19:36:34 +0000
committerMichele Beltrame <mb@italpro.net>2008-08-13 19:36:34 +0000
commit26475df18b1173c7faf656e719597fea6755d5de (patch)
treee481b05b31994cab77df861822a1d8e706d19156
parentBumpz (diff)
downloadperl-overlay-26475df18b1173c7faf656e719597fea6755d5de.tar.gz
perl-overlay-26475df18b1173c7faf656e719597fea6755d5de.tar.bz2
perl-overlay-26475df18b1173c7faf656e719597fea6755d5de.zip
Added CGI::Application
-rw-r--r--dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.12.ebuild23
-rw-r--r--dev-perl/CGI-Application-Plugin-Authentication/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-Authentication/metadata.xml9
-rw-r--r--dev-perl/CGI-Application-Plugin-AutoRunmode/CGI-Application-Plugin-AutoRunmode-0.15.ebuild19
-rw-r--r--dev-perl/CGI-Application-Plugin-AutoRunmode/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-AutoRunmode/metadata.xml9
-rw-r--r--dev-perl/CGI-Application-Plugin-Config-General/CGI-Application-Plugin-Config-General-0.07.ebuild20
-rw-r--r--dev-perl/CGI-Application-Plugin-Config-General/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-Config-General/metadata.xml9
-rw-r--r--dev-perl/CGI-Application-Plugin-Redirect/CGI-Application-Plugin-Redirect-1.00.ebuild19
-rw-r--r--dev-perl/CGI-Application-Plugin-Redirect/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-Redirect/metadata.xml9
-rw-r--r--dev-perl/CGI-Application-Plugin-Session/CGI-Application-Plugin-Session-1.03.ebuild20
-rw-r--r--dev-perl/CGI-Application-Plugin-Session/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-Session/metadata.xml9
-rw-r--r--dev-perl/CGI-Application-Plugin-TT/CGI-Application-Plugin-TT-1.04.ebuild20
-rw-r--r--dev-perl/CGI-Application-Plugin-TT/Manifest2
-rw-r--r--dev-perl/CGI-Application-Plugin-TT/metadata.xml9
-rw-r--r--dev-perl/Config-General-Match/Config-General-Match-0.05.ebuild19
-rw-r--r--dev-perl/Config-General-Match/Manifest2
-rw-r--r--dev-perl/Config-General-Match/metadata.xml9
21 files changed, 217 insertions, 0 deletions
diff --git a/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.12.ebuild b/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.12.ebuild
new file mode 100644
index 000000000..9a2cd6c77
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Authentication framework for CGI::Application"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/C/CE/CEESHEK/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ >=dev-perl/CGI-Application-4
+ dev-perl/Digest-SHA1
+ dev-perl/UNIVERSAL-require
+ dev-perl/Test-Warn
+ dev-perl/Test-Exception
+"
diff --git a/dev-perl/CGI-Application-Plugin-Authentication/Manifest b/dev-perl/CGI-Application-Plugin-Authentication/Manifest
new file mode 100644
index 000000000..529958b63
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Authentication/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-Authentication-0.12.tar.gz 47778 RMD160 12500b77e5958a96185dbc0be80077be4d43bf70 SHA1 13ef8f85c3820b2bff206573fba6b2b063db0fe7 SHA256 b99c2a3cb5ecb50bacbaacc46585379e88e5023126f2babe1e20682a5f798fcf
+EBUILD CGI-Application-Plugin-Authentication-0.12.ebuild 618 RMD160 9a6f5422610e19f933ab9a67e9408cb3bbcd89ca SHA1 92c8677bffceed1d5cc728a0c6ca369778a2f6d8 SHA256 00f1869e44bead2432ee2d58bfc84f75d4bc0367dc0068cfb7ea6cfa7a325844
diff --git a/dev-perl/CGI-Application-Plugin-Authentication/metadata.xml b/dev-perl/CGI-Application-Plugin-Authentication/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Authentication/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/CGI-Application-Plugin-AutoRunmode/CGI-Application-Plugin-AutoRunmode-0.15.ebuild b/dev-perl/CGI-Application-Plugin-AutoRunmode/CGI-Application-Plugin-AutoRunmode-0.15.ebuild
new file mode 100644
index 000000000..c7b247ef9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-AutoRunmode/CGI-Application-Plugin-AutoRunmode-0.15.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="CGI::App plugin to automatically register runmodes"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/T/TH/THILO/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ >=dev-perl/CGI-Application-3.0
+"
diff --git a/dev-perl/CGI-Application-Plugin-AutoRunmode/Manifest b/dev-perl/CGI-Application-Plugin-AutoRunmode/Manifest
new file mode 100644
index 000000000..83c8c4374
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-AutoRunmode/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-AutoRunmode-0.15.tar.gz 10955 RMD160 6e182bf5e62e357436daa70dbda8fed119ac17a0 SHA1 9d2fe2e264157003cd7b9402580337114b1cfe46 SHA256 3ca3fcd2143ba526f824ec85d38c7f4cbb68c862e07860d61a8b50051ed950ff
+EBUILD CGI-Application-Plugin-AutoRunmode-0.15.ebuild 528 RMD160 e0e8e835a718d946685ea82b714738001281e980 SHA1 74ae6585315cb19f72e3ef1d27df1df55da5a48f SHA256 ba708b5e22a521fcefdebcc7ed346ee71a62e2e828e9c94a316dee27211143cf
diff --git a/dev-perl/CGI-Application-Plugin-AutoRunmode/metadata.xml b/dev-perl/CGI-Application-Plugin-AutoRunmode/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-AutoRunmode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/CGI-Application-Plugin-Config-General/CGI-Application-Plugin-Config-General-0.07.ebuild b/dev-perl/CGI-Application-Plugin-Config-General/CGI-Application-Plugin-Config-General-0.07.ebuild
new file mode 100644
index 000000000..48ac38972
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Config-General/CGI-Application-Plugin-Config-General-0.07.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Add Config::General Support to CGI::Application"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/M/MG/MGRAHAM/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ dev-perl/CGI-Application
+ dev-perl/Config-General-Match
+"
diff --git a/dev-perl/CGI-Application-Plugin-Config-General/Manifest b/dev-perl/CGI-Application-Plugin-Config-General/Manifest
new file mode 100644
index 000000000..6a58fa4ef
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Config-General/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-Config-General-0.07.tar.gz 20989 RMD160 918fe1c155c01b3e69978f4935b98cb601a87082 SHA1 6418f5835a03d6378cafec83532720020049314b SHA256 0ad729e8f8039741a280d9b6337757cb8eee7f0100f41cc25d8106dd1d8e89ef
+EBUILD CGI-Application-Plugin-Config-General-0.07.ebuild 552 RMD160 4a7856b9b44df32fce2498b783ff9496834a907c SHA1 5b473059381fe6187749ba220f0c89659da2027b SHA256 5c6f7120a7b46cdf8174b91a5eaee08124265146dec0eab5198400172814b17a
diff --git a/dev-perl/CGI-Application-Plugin-Config-General/metadata.xml b/dev-perl/CGI-Application-Plugin-Config-General/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Config-General/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/CGI-Application-Plugin-Redirect/CGI-Application-Plugin-Redirect-1.00.ebuild b/dev-perl/CGI-Application-Plugin-Redirect/CGI-Application-Plugin-Redirect-1.00.ebuild
new file mode 100644
index 000000000..f7303223e
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Redirect/CGI-Application-Plugin-Redirect-1.00.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Easy external redirects in CGI::Application"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/C/CE/CEESHEK/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ dev-perl/CGI-Application
+"
diff --git a/dev-perl/CGI-Application-Plugin-Redirect/Manifest b/dev-perl/CGI-Application-Plugin-Redirect/Manifest
new file mode 100644
index 000000000..aaf17ab82
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Redirect/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-Redirect-1.00.tar.gz 3645 RMD160 63ccc007444dc4565899298abcf305de3e771c52 SHA1 3d97505a63a31c768090aa12cb81e3672cbbf786 SHA256 5b568a8ca0496be03515aacef8b11b46d15ddcf78a8e4026beacda5fb33f8a4f
+EBUILD CGI-Application-Plugin-Redirect-1.00.ebuild 517 RMD160 877694116940d8cb002819b21afa3ed7be957557 SHA1 00ce72b0a5649615512baea00f9a297712a1798f SHA256 5afb5ef48b5f9271834b05f9f9af1794dcc2de3f2f7962725f7710864edfabb7
diff --git a/dev-perl/CGI-Application-Plugin-Redirect/metadata.xml b/dev-perl/CGI-Application-Plugin-Redirect/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Redirect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/CGI-Application-Plugin-Session/CGI-Application-Plugin-Session-1.03.ebuild b/dev-perl/CGI-Application-Plugin-Session/CGI-Application-Plugin-Session-1.03.ebuild
new file mode 100644
index 000000000..e6cb1d492
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Session/CGI-Application-Plugin-Session-1.03.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Add CGI::Session support to CGI::Application"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/C/CE/CEESHEK/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ >=dev-perl/CGI-Application-3.21
+ >=dev-perl/CGI-Session-3.95
+"
diff --git a/dev-perl/CGI-Application-Plugin-Session/Manifest b/dev-perl/CGI-Application-Plugin-Session/Manifest
new file mode 100644
index 000000000..b5749980c
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Session/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-Session-1.03.tar.gz 13599 RMD160 1c832cc0f376842affc9ca9ebe82dd68a50566f7 SHA1 fc1d6b39ed842369170a8752ee6b73d99d49a9fc SHA256 7dd7eb41bfb4d70a3a9b29213de21d33bc308ed0f2ccaca64570bfca79f532be
+EBUILD CGI-Application-Plugin-Session-1.03.ebuild 554 RMD160 1a9ad1434d8d8a3627085f17fb38e2d7c89caad7 SHA1 c96adfc0417ed4d499a9397478c5c620932f0250 SHA256 84c73dc7e1e089a2a6b7bb86633a50b1064ed35c8fbc02c7b27b40dd5ce5376c
diff --git a/dev-perl/CGI-Application-Plugin-Session/metadata.xml b/dev-perl/CGI-Application-Plugin-Session/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Session/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/CGI-Application-Plugin-TT/CGI-Application-Plugin-TT-1.04.ebuild b/dev-perl/CGI-Application-Plugin-TT/CGI-Application-Plugin-TT-1.04.ebuild
new file mode 100644
index 000000000..3d9449860
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-TT/CGI-Application-Plugin-TT-1.04.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Add Template Toolkit support to CGI::Application"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/C/CE/CEESHEK/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ >=dev-perl/CGI-Application-4.0
+ >=dev-perl/Template-Toolkit-2.0
+"
diff --git a/dev-perl/CGI-Application-Plugin-TT/Manifest b/dev-perl/CGI-Application-Plugin-TT/Manifest
new file mode 100644
index 000000000..32fdcab67
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-TT/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Application-Plugin-TT-1.04.tar.gz 15189 RMD160 7c9f037430be1511e241f388f8ae6ddfa8404244 SHA1 8457506a05277b125cb3f8367150ff8f3c97a4f5 SHA256 51d7ed3417190c4b4e4825b6560bee24bcc833b7d4bf6f600671d479b86c53e7
+EBUILD CGI-Application-Plugin-TT-1.04.ebuild 561 RMD160 9db4630fd5139220c0d024e6d1f731d042c38dfb SHA1 e5aac3150fa5225a1b9d08d3b05408b19b4fa6d2 SHA256 424a13c95de2d5be388bb93538398c0fdb0066b4abec9a0c43154d4f2a77e36e
diff --git a/dev-perl/CGI-Application-Plugin-TT/metadata.xml b/dev-perl/CGI-Application-Plugin-TT/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-TT/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-perl/Config-General-Match/Config-General-Match-0.05.ebuild b/dev-perl/Config-General-Match/Config-General-Match-0.05.ebuild
new file mode 100644
index 000000000..a48ee5ca2
--- /dev/null
+++ b/dev-perl/Config-General-Match/Config-General-Match-0.05.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Add <Location> and <LocationMatch> style matching toi Config::General"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/M/MG/MGRAHAM/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc sparc-fbsd x86 x86-fbsd"
+RESTRICT="nomirror"
+
+IUSE=""
+DEPEND="
+ dev-perl/config-general
+"
diff --git a/dev-perl/Config-General-Match/Manifest b/dev-perl/Config-General-Match/Manifest
new file mode 100644
index 000000000..39bca420d
--- /dev/null
+++ b/dev-perl/Config-General-Match/Manifest
@@ -0,0 +1,2 @@
+DIST Config-General-Match-0.05.tar.gz 17968 RMD160 40c211450af329afe40c96930198e4c8277c5f18 SHA1 4a6def273d6525786ec4386adee027145ffd7053 SHA256 464fcb0bd83876c4fbfebcef5593ce1f6958d667e132f6ed2e63baaa19d5799d
+EBUILD Config-General-Match-0.05.ebuild 542 RMD160 8df94faee53a858236d532d76c796d417c84c92e SHA1 5d63c4d137557c9a13731ba68f43acd44f4c4139 SHA256 bf0877418875d946808bf8e68a525530b616793d6a32d32225d7d3245d1e0e1f
diff --git a/dev-perl/Config-General-Match/metadata.xml b/dev-perl/Config-General-Match/metadata.xml
new file mode 100644
index 000000000..7262de9a9
--- /dev/null
+++ b/dev-perl/Config-General-Match/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mb@italpro.net</email>
+ <name>Michele Beltrame</name>
+ </maintainer>
+</pkgmetadata>