summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Abbott <dabbott@gentoo.org>2009-11-12 10:45:55 -0500
committerDavid Abbott <dabbott@gentoo.org>2009-11-12 10:45:55 -0500
commit3ffbeb3e0894e01d02fecc09cf6d4f4d52e167d9 (patch)
tree5a38c049f7c4c613a45fbf74d1156710aec860fe
parentFixed repoman errors (diff)
downloadperl-overlay-3ffbeb3e0894e01d02fecc09cf6d4f4d52e167d9.tar.gz
perl-overlay-3ffbeb3e0894e01d02fecc09cf6d4f4d52e167d9.tar.bz2
perl-overlay-3ffbeb3e0894e01d02fecc09cf6d4f4d52e167d9.zip
Updated for bash-3.2 features, enabled taint mode.
-rw-r--r--mail-filter/spamassassin/Manifest2
-rw-r--r--mail-filter/spamassassin/spamassassin-3.2.5-r1.ebuild23
2 files changed, 9 insertions, 16 deletions
diff --git a/mail-filter/spamassassin/Manifest b/mail-filter/spamassassin/Manifest
index 682626892..bb4613fd9 100644
--- a/mail-filter/spamassassin/Manifest
+++ b/mail-filter/spamassassin/Manifest
@@ -6,5 +6,5 @@ AUX 3.2.2-upstream-5574-testcase.patch 1611 RMD160 e94baa4f60c825777744ffcd58fdc
AUX secrets.cf 664 RMD160 afb1212a464bd7053c1301c1a1e670b73216528a SHA1 a742beddf850e55bc4454a7548dc43c36f8e9760 SHA256 9f134c7b857b21689f612fc6d131f719e5a65e2ba341b282e7aa57402c854139
AUX spamassassin-3.2.5-DESTDIR.patch 8856 RMD160 c7aa95f1ddc21e7668266fe3eb00342ba5569c8c SHA1 045a446362b8b0491164a53cff18391c49fe6786 SHA256 f73e3d63b7fd79c364799cd1e3525369ac483019e55c079f33529b6ce81c9264
DIST Mail-SpamAssassin-3.2.5.tar.bz2 1011883 RMD160 444baab6d966d4366834b82cde34c81e3e521144 SHA1 32b701ffc68f7975eded107c456b902bc710d8b2 SHA256 baaab5e4da7d3b0e04c0db579bdb44bbd6be916d29540682346eccead23f6c8a
-EBUILD spamassassin-3.2.5-r1.ebuild 5201 RMD160 5f6eb856d9bef3212f8b0d741272ab5c661fc216 SHA1 6ccf60e11abcf5bbd7e2d414837d7e9518c44fce SHA256 048c61563bb9ec125f22953260d26e4a30ce0502dbcd5b90a06b08bbdbe0d4d4
+EBUILD spamassassin-3.2.5-r1.ebuild 4849 RMD160 403dbccdc9382479fe9012b1bc17425f716889cf SHA1 0a33370db554d9e3204884a9b89c17cfa94e5637 SHA256 4278143bbb043499aafbab7829910eb87fb4adc5dfc2d2f321dfd46d9635934a
MISC metadata.xml 397 RMD160 57fce2ddbc573f348530f856bc0735ba1aae08b9 SHA1 ffab343d82e13c81c74ecb9d0724634a4df755d8 SHA256 6b960f56b7be9f2ecb4b7023b54e20fc6d5583d8ff9ea0b1a4a987c6d86b0a0a
diff --git a/mail-filter/spamassassin/spamassassin-3.2.5-r1.ebuild b/mail-filter/spamassassin/spamassassin-3.2.5-r1.ebuild
index 7a91665f7..9135e41ff 100644
--- a/mail-filter/spamassassin/spamassassin-3.2.5-r1.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.2.5-r1.ebuild
@@ -66,23 +66,16 @@ src_configure() {
# If ssl is enabled, spamc can be built with ssl support
if use ssl; then
- myconf="${myconf} ENABLE_SSL=yes"
+ myconf+=" ENABLE_SSL=yes"
else
- myconf="${myconf} ENABLE_SSL=no"
+ myconf+=" ENABLE_SSL=no"
fi
# Set the path to the Perl executable explictly. This will be used to
# create the initial sharpbang line in the scripts and might cause
# a versioned app name end in there, see
# <http://bugs.gentoo.org/show_bug.cgi?id=62276>
- myconf="${myconf} PERL_BIN=/usr/bin/perl"
-
- # If you are going to enable taint mode, make sure that the bug where
- # spamd doesn't start when the PATH contains . is addressed, and make
- # sure you deal with versions of razor <2.36-r1 not being taint-safe.
- # <http://bugzilla.spamassassin.org/show_bug.cgi?id=2511> and
- # <http://spamassassin.org/released/Razor2.patch>.
- myconf="${myconf} PERL_TAINT=no"
+ myconf+=" PERL_BIN=/usr/bin/perl"
# Add Gentoo tag to make it easier for the upstream devs to spot
# possible modifications or patches.
@@ -101,7 +94,7 @@ src_compile() {
# Run the autoconf stuff now, just to make the build sequence look more
# familiar to the user :) Plus feeding the VERSION_STRING skips some
# calls to Perl.
- make spamc/Makefile VERSION_STRING="${version_str}"
+ make spamc/Makefile VERSION_STRING="${version_str}" || die
# Now compile all the stuff selected.
perl-module_src_compile
@@ -119,20 +112,20 @@ src_install () {
perl-module_src_install
# Create the stub dir used by sa-update and friends
- dodir /var/lib/spamassassin
+ dodir /var/lib/spamassassin || die
# Move spamd to sbin where it belongs.
dodir /usr/sbin
mv "${D}"/usr/bin/spamd "${D}"/usr/sbin/spamd || die
if use qmail; then
- dobin spamc/qmail-spamc
+ dobin spamc/qmail-spamc || die
fi
- dosym /etc/mail/spamassassin /etc/spamassassin
+ dosym /etc/mail/spamassassin /etc/spamassassin || die
# Disable plugin by default
- sed -i -e 's/^loadplugin/\#loadplugin/g' "${D}"/etc/mail/spamassassin/init.pre
+ sed -i -e 's/^loadplugin/\#loadplugin/g' "${D}"/etc/mail/spamassassin/init.pre || die
# Add the init and config scripts.
newinitd "${FILESDIR}"/3.0.0-spamd.init spamd || die