summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-03-30 18:17:19 +0200
committerTorsten Veller <tove@gentoo.org>2010-03-30 18:17:19 +0200
commit9a858e11f1525b39acdb03070b9304fd5871a762 (patch)
tree98ae076faf47a29cc80de727e05ace04031f9ee2
parentMask perl-5.12.0 (diff)
downloadperl-overlay-9a858e11f1525b39acdb03070b9304fd5871a762.tar.gz
perl-overlay-9a858e11f1525b39acdb03070b9304fd5871a762.tar.bz2
perl-overlay-9a858e11f1525b39acdb03070b9304fd5871a762.zip
dev-lang/perl-5.12.0-rc1: First test version
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
-rw-r--r--dev-lang/perl/ChangeLog11
-rw-r--r--dev-lang/perl/Manifest15
-rw-r--r--dev-lang/perl/metadata.xml12
-rw-r--r--dev-lang/perl/perl-5.12.0_rc1.ebuild617
4 files changed, 655 insertions, 0 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
new file mode 100644
index 000000000..97ad8007a
--- /dev/null
+++ b/dev-lang/perl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lang/perl
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*perl-5.12.0_rc1 (30 Mar 2010)
+
+ 30 Mar 2010; Torsten Veller <tove@gentoo.org> +perl-5.12.0_rc1.ebuild,
+ +metadata.xml:
+ First test version. Might be broken. New perl-5.12.0 bugs should block bug
+ #312061
+
diff --git a/dev-lang/perl/Manifest b/dev-lang/perl/Manifest
new file mode 100644
index 000000000..e50b9134a
--- /dev/null
+++ b/dev-lang/perl/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST perl-5.12.0-RC1-1.tar.bz2 2779 RMD160 ce0972a5e3705f63e7432e725fc2bcd4067eb78b SHA1 4c86de75f11bdad1a7c079f880038b8bb99555a7 SHA256 4249751bf30a0f3b7db4c8e626a0ed4c77dd146e7195046196a185e5dfc3c066
+DIST perl-5.12.0-RC1.tar.gz 15131799 RMD160 b8d53ee41a1b9f4256115ccbf5a274cee33263a3 SHA1 d2616e5c193377901cc930290168d08f10b3bd1d SHA256 b3612ad69e130835d490f01857278b1ba3da1855988f48ef534e2f51750f35ce
+EBUILD perl-5.12.0_rc1.ebuild 18384 RMD160 b96b658454014ec5fabb9dcd80c771b5bcf0c50b SHA1 60d90c3744641e4d6fcca2cb72e0ca5ddaae0447 SHA256 2106577441899a5f7769269a7232a8d80b6a2ed2aaa9582228a386397aa4471f
+MISC ChangeLog 324 RMD160 f394a9acc3cf423ad7e22495fae2cdf95f82772b SHA1 e4d6d0f6466e604f37554333c83ebc6bd9e666e7 SHA256 2889dc3ead699608f69701347ac0a09b91e17412bfe7eb7ff2a4bd0abaa7d607
+MISC metadata.xml 367 RMD160 c415adb4b9b5147edb358eb9809b649fc0b43876 SHA1 d9e529ec0c023a577b3110a46f8d41578f7baed0 SHA256 4cb776e7da908573000d278ca4b9b1d1ba8556deb361cf80f6e8af226a2c9cdb
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkuyJA8ACgkQV3J2n04EauwLeACfbh6QYWOaQLp/vDoqFaOH/qGq
+IpAAnjZ5B03r9Xc80AOwiFFOYSgpbxdE
+=eJL/
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/perl/metadata.xml b/dev-lang/perl/metadata.xml
new file mode 100644
index 000000000..a6186e468
--- /dev/null
+++ b/dev-lang/perl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <use>
+ <flag name='ithreads'>Enable Perl threads, has some compatibility problems</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-lang/perl/perl-5.12.0_rc1.ebuild b/dev-lang/perl/perl-5.12.0_rc1.ebuild
new file mode 100644
index 000000000..98362085b
--- /dev/null
+++ b/dev-lang/perl/perl-5.12.0_rc1.ebuild
@@ -0,0 +1,617 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.10.1.ebuild,v 1.20 2010/03/14 15:51:19 aballier Exp $
+
+EAPI=2
+
+inherit eutils alternatives flag-o-matic toolchain-funcs multilib
+
+PATCH_VER=1
+
+PERL_OLDVERSEN=""
+
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
+MY_PV="${PV%_rc*}"
+
+DESCRIPTION="Larry Wall's Practical Extraction and Report Language"
+
+S="${WORKDIR}/${MY_P}"
+SRC_URI="
+ mirror://cpan/authors/id/J/JE/JESSE/${MY_P}.tar.gz
+ http://dev.gentoo.org/~tove/files/${MY_P}-${PATCH_VER}.tar.bz2"
+# mirror://cpan/src/${MY_P}.tar.bz2
+# mirror://gentoo/${MY_P}-${PATCH_VER}.tar.bz2
+HOMEPAGE="http://www.perl.org/"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="berkdb build debug doc gdbm ithreads"
+
+COMMON_DEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ >=sys-devel/libperl-5.10.1
+ !!<sys-devel/libperl-5.10.1
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${COMMON_DEPEND}
+ elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs )"
+RDEPEND="${COMMON_DEPEND}"
+PDEPEND=">=app-admin/perl-cleaner-2_pre090920"
+
+dual_scripts() {
+ src_remove_dual_scripts perl-core/Archive-Tar 1.54 ptar ptardiff
+ src_remove_dual_scripts perl-core/Digest-SHA 5.47 shasum
+ src_remove_dual_scripts perl-core/CPAN 1.9456 cpan
+ src_remove_dual_scripts perl-core/CPANPLUS 0.90 cpanp cpan2dist cpanp-run-perl
+ src_remove_dual_scripts perl-core/Encode 2.39 enc2xs piconv
+ src_remove_dual_scripts perl-core/ExtUtils-MakeMaker 6.56 instmodsh
+ src_remove_dual_scripts perl-core/Module-Build 0.3603 config_data
+ src_remove_dual_scripts perl-core/Module-CoreList 2.27 corelist
+ src_remove_dual_scripts perl-core/PodParser 1.37 pod2usage podchecker podselect
+ src_remove_dual_scripts perl-core/Test-Harness 3.17 prove
+ src_remove_dual_scripts perl-core/podlators 2.3.1 pod2man pod2text
+}
+
+pkg_setup() {
+ LIBPERL="libperl$(get_libname ${MY_PV})"
+
+ if use ithreads ; then
+ ewarn "THREADS WARNING:"
+ ewarn "PLEASE NOTE: You are compiling ${MY_P} with"
+ ewarn "interpreter-level threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ echo
+ fi
+ if has_version "~dev-lang/perl-5.8.8" ; then
+ ewarn "UPDATE THE PERL MODULES:"
+ ewarn "After updating dev-lang/perl you must reinstall"
+ ewarn "the installed perl modules."
+ ewarn "Use: perl-cleaner --all"
+ elif has_version dev-lang/perl ; then
+ # doesnot work
+ #if ! has_version dev-lang/perl[ithreads=,debug=] ; then
+ #if ! has_version dev-lang/perl[ithreads=] || ! has_version dev-lang/perl[debug=] ; then
+ if ( use ithreads && ! has_version dev-lang/perl[ithreads] ) || \
+ ( ! use ithreads && has_version dev-lang/perl[ithreads] ) || \
+ ( use debug && ! has_version dev-lang/perl[debug] ) || \
+ ( ! use debug && has_version dev-lang/perl[debug] ) ; then
+ ewarn "TOGGLED USE-FLAGS WARNING:"
+ ewarn "You changed one of the use-flags ithreads or debug."
+ ewarn "You must rebuild all perl-modules installed."
+ ewarn "Use: perl-cleaner --modules ; perl-cleaner --force --libperl"
+ fi
+ fi
+ dual_scripts
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/perl-patch" \
+ EPATCH_SUFFIX="diff" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ # pod/perltoc.pod fails
+ # lib/ExtUtils/t/Embed.t fails
+ ln -s ${LIBPERL} libperl$(get_libname ${SHORT_PV})
+ ln -s ${LIBPERL} libperl$(get_libname )
+}
+
+myconf() {
+ # the myconf array is declared in src_configure
+ myconf=( "${myconf[@]}" "$@" )
+}
+
+src_configure() {
+ declare -a myconf
+
+ # some arches and -O do not mix :)
+ use arm && replace-flags -O? -O1
+ use ppc && replace-flags -O? -O1
+ use ia64 && replace-flags -O? -O1
+ # Perl has problems compiling with -Os in your flags with glibc
+ use elibc_uclibc || replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags "-malign-double"
+ # Fixes bug #97645
+ use ppc && filter-flags "-mpowerpc-gpopt"
+ # Fixes bug #143895 on gcc-4.1.1
+ filter-flags "-fsched2-use-superblocks"
+
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ use mips && myconf -Dd_u32align
+
+ use sparc && myconf -Ud_longdbl
+
+ export LC_ALL="C"
+
+ # 266337
+ export BUILD_BZIP2=0
+ export BZIP2_INCLUDE=/usr/include
+ export BZIP2_LIB=/usr/$(get_libdir)
+ cat <<-EOF > "${S}/cpan/Compress-Raw-Zlib/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = /usr/include
+ LIB = /usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+
+ case ${CHOST} in
+ *-freebsd*) osname="freebsd" ;;
+ *-dragonfly*) osname="dragonfly" ;;
+ *-netbsd*) osname="netbsd" ;;
+ *-openbsd*) osname="openbsd" ;;
+ *-darwin*) osname="darwin" ;;
+ *) osname="linux" ;;
+ esac
+
+ if use ithreads ; then
+ mythreading="-multi"
+ myconf -Dusethreads
+ myarch=${CHOST}
+ myarch="${myarch%%-*}-${osname}-thread"
+ else
+ myarch=${CHOST}
+ myarch="${myarch%%-*}-${osname}"
+ fi
+ if use debug ; then
+ myarch="${myarch}-debug"
+ fi
+
+ # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
+
+ myndbm='U'
+ mygdbm='U'
+ mydb='U'
+
+ if use gdbm ; then
+ mygdbm='D'
+ myndbm='D'
+ fi
+ if use berkdb ; then
+ mydb='D'
+ has_version '=sys-libs/db-1*' && myndbm='D'
+ fi
+
+ myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
+
+ if use alpha && [[ "$(tc-getCC)" = "ccc" ]] ; then
+ ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ myconf -Ui_db -Ui_ndbm
+ fi
+
+ if use debug ; then
+ append-cflags "-g"
+ myconf -DDEBUGGING
+ fi
+
+ if [[ -n ${PERL_OLDVERSEN} ]] ; then
+ local inclist=$(for v in ${PERL_OLDVERSEN}; do echo -n "${v} ${v}/${myarch}${mythreading}"; done )
+ myconf -Dinc_version_list="$inclist"
+ fi
+ [[ -n "${ABI}" ]] && myconf "-Dusrinc=$(get_ml_incdir)"
+
+ [[ ${ELIBC} == "FreeBSD" ]] && myconf "-Dlibc=/usr/$(get_libdir)/libc.a"
+
+ if [[ $(get_libdir) != "lib" ]] ; then
+ # We need to use " and not ', as the written config.sh use ' ...
+ myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
+ fi
+
+ sh Configure \
+ -des \
+ -Duseshrplib \
+ -Darchname="${myarch}" \
+ -Dcc="$(tc-getCC)" \
+ -Doptimize="${CFLAGS}" \
+ -Dscriptdir=/usr/bin \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefix='/usr' \
+ -Dprivlib="/usr/$(get_libdir)/perl5/${MY_PV}" \
+ -Darchlib="/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}" \
+ -Dvendorlib="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}" \
+ -Dvendorarch="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}/${myarch}${mythreading}" \
+ -Dsitelib="/usr/$(get_libdir)/perl5/site_perl/${MY_PV}" \
+ -Dsitearch="/usr/$(get_libdir)/perl5/site_perl/${MY_PV}/${myarch}${mythreading}" \
+ -Dman1dir=/usr/share/man/man1 \
+ -Dman3dir=/usr/share/man/man3 \
+ -Dinstallman1dir=/usr/share/man/man1 \
+ -Dinstallman3dir=/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dlibperl="${LIBPERL}" \
+ -Dlocincpth=' ' \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dcf_by='Gentoo' \
+ -Dmyhostname='localhost' \
+ -Dperladmin='root@localhost' \
+ -Dinstallusrbinperl='n' \
+ -Ud_csh \
+ -Uusenm \
+ "${myconf[@]}" || die "Unable to configure"
+}
+
+src_test() {
+ use elibc_uclibc && export MAKEOPTS="${MAKEOPTS} -j1"
+ TEST_JOBS=$(echo -j1 ${MAKEOPTS} | sed -r 's/.*(-j[[:space:]]*|--jobs=)([[:digit:]]+).*/\2/' ) \
+ make test_harness || die "test failed"
+}
+
+src_install() {
+ export LC_ALL="C"
+ local i
+ local coredir="/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}/CORE"
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/$(get_libdir)/perl5/site_perl/${MY_PV}/${myarch}${mythreading}
+
+ local installtarget=install
+ if use build ; then
+ installtarget=install.perl
+ fi
+ make DESTDIR="${D}" ${installtarget} || die "Unable to make ${installtarget}"
+
+ rm -f "${D}"/usr/bin/perl
+ ln -s perl${MY_PV} "${D}"/usr/bin/perl
+
+ dolib.so "${D}"/${coredir}/${LIBPERL} || die
+ dosym ${LIBPERL} /usr/$(get_libdir)/libperl$(get_libname ${SHORT_PV}) || die
+ dosym ${LIBPERL} /usr/$(get_libdir)/libperl$(get_libname) || die
+ rm -f "${D}"/${coredir}/${LIBPERL}
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname ${SHORT_PV})
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname)
+
+ rm -rf "${D}"/usr/share/man/man3 || die "Unable to remove module man pages"
+# cp -f utils/h2ph utils/h2ph_patched
+# epatch "${FILESDIR}"/${PN}-h2ph-ansi-header.patch
+#
+# LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+# -a -d "${D}"/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading} <<EOF
+#asm/termios.h
+#syscall.h
+#syslimits.h
+#syslog.h
+#sys/ioctl.h
+#sys/socket.h
+#sys/time.h
+#wait.h
+#EOF
+
+# vvv still needed?
+# # This is to fix a missing c flag for backwards compat
+# for i in $(find "${D}"/usr/$(get_libdir)/perl5 -iname "Config.pm" ) ; do
+# sed -i \
+# -e "s:ccflags=':ccflags='-DPERL5 :" \
+# -e "s:cppflags=':cppflags='-DPERL5 :" \
+# "${i}" || die "Sed failed"
+# done
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/$(get_libdir)/perl5/${MY_PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/$(get_libdir)/perl5/${MY_PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+ # This removes ${D} from Config.pm and .packlist
+ for i in $(find "${D}" -iname "Config.pm" -o -iname ".packlist" ) ; do
+ einfo "Removing ${D} from ${i}..."
+ sed -i -e "s:${D}::" "${i}" || die "Sed failed"
+ done
+
+ # Note: find out from psm why we would need/want this.
+ # ( use berkdb && has_version '=sys-libs/db-1*' ) ||
+ # find "${D}" -name "*NDBM*" | xargs rm -f
+
+ dodoc Changes* README AUTHORS || die
+
+ if use doc ; then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+
+ dual_scripts
+
+ if use build ; then
+ src_remove_extra_files
+ fi
+}
+
+pkg_postinst() {
+ local INC DIR file
+
+ dual_scripts
+
+ INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${MY_PV}'|etc|local|perl$/; print "$line\n" }')
+ if [[ "${ROOT}" = "/" ]] ; then
+ ebegin "Removing old .ph files"
+ for DIR in ${INC} ; do
+ if [[ -d "${ROOT}/${DIR}" ]] ; then
+ for file in $(find "${ROOT}/${DIR}" -name "*.ph" -type f ) ; do
+ rm -f "${ROOT}/${file}"
+ einfo "<< ${file}"
+ done
+ fi
+ done
+ # Silently remove the now empty dirs
+ for DIR in ${INC} ; do
+ if [[ -d "${ROOT}/${DIR}" ]] ; then
+ find "${ROOT}/${DIR}" -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
+ fi
+ done
+ ebegin "Generating ConfigLocal.pm (ignore any error)"
+ enc2xs -C
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include
+ h2ph -Q *
+ h2ph -Q -r sys/* arpa/* netinet/* bits/* security/* asm/* gnu/* linux/*
+ fi
+
+# This has been moved into a function because rumor has it that a future release
+# of portage will allow us to check what version was just removed - which means
+# we will be able to invoke this only as needed :)
+ # Tried doing this via -z, but $INC is too big...
+ if [[ "${INC}x" != "x" ]]; then
+ cleaner_msg
+ epause 5
+ fi
+}
+
+pkg_postrm(){
+ ${IS_PERL} && dual_scripts
+}
+
+cleaner_msg() {
+ eerror "You have had multiple versions of perl. It is recommended"
+ eerror "that you run perl-cleaner now. perl-cleaner will"
+ eerror "assist with this transition. This script is capable"
+ eerror "of cleaning out old .ph files, rebuilding modules for "
+ eerror "your new version of perl, as well as re-emerging"
+ eerror "applications that compiled against your old libperl$(get_libname)"
+ eerror
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run perl-cleaner and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+}
+
+src_remove_dual_scripts() {
+ local i pkg ver ff
+ pkg="$1"
+ ver="$2"
+ shift 2
+ if has "${EBUILD_PHASE:-none}" "postinst" "postrm" ;then
+ for i in "$@" ; do
+ ff=`echo ${ROOT}/usr/share/man/man1/${i}-${ver}-${P}.1*`
+ ff=${ff##*.1}
+ alternatives_auto_makesym "/usr/bin/${i}" "/usr/bin/${i}-[0-9]*"
+ alternatives_auto_makesym "/usr/share/man/man1/${i}.1${ff}" "/usr/share/man/man1/${i}-[0-9]*"
+ done
+ elif has "${EBUILD_PHASE:-none}" "setup" ; then
+ for i in "$@" ; do
+ if [[ -f ${ROOT}/usr/bin/${i} && ! -h ${ROOT}/usr/bin/${i} ]] ; then
+ has_version ${pkg} && ewarn "You must reinstall $pkg !"
+ break
+ fi
+ done
+ else
+ for i in "$@" ; do
+ mv "${D}"/usr/bin/${i}{,-${ver}-${P}} || die
+ mv "${D}"/usr/share/man/man1/${i}{.1,-${ver}-${P}.1} || \
+ echo "/usr/share/man/man1/${i}.1 does not exist!"
+ done
+ fi
+}
+
+src_remove_extra_files() {
+ local prefix="./usr" # ./ is important
+ local bindir="${prefix}/bin"
+ local libdir="${prefix}/$(get_libdir)"
+ local perlroot="${libdir}/perl5" # perl installs per-arch dirs
+ local prV="${perlroot}/${MY_PV}"
+ local prVA="${prV}/${myarch}${mythreading}"
+
+ # I made this list from the Mandr*, Debian and ex-Connectiva perl-base list
+ # Then, I added several files to get GNU autotools running
+ # FIXME: should this be in a separated file to be sourced?
+ local MINIMAL_PERL_INSTALL="
+ ${bindir}/h2ph
+ ${bindir}/perl
+ ${bindir}/perl${MY_PV}
+ ${bindir}/pod2man
+ ${libdir}/${LIBPERL}
+ ${libdir}/libperl$(get_libname)
+ ${libdir}/libperl$(get_libname ${SHORT_PV})
+ ${prV}/attributes.pm
+ ${prV}/AutoLoader.pm
+ ${prV}/autouse.pm
+ ${prV}/base.pm
+ ${prV}/bigint.pm
+ ${prV}/bignum.pm
+ ${prV}/bigrat.pm
+ ${prV}/blib.pm
+ ${prV}/bytes_heavy.pl
+ ${prV}/bytes.pm
+ ${prV}/Carp/Heavy.pm
+ ${prV}/Carp.pm
+ ${prV}/charnames.pm
+ ${prV}/Class/Struct.pm
+ ${prV}/constant.pm
+ ${prV}/diagnostics.pm
+ ${prV}/DirHandle.pm
+ ${prV}/Exporter/Heavy.pm
+ ${prV}/Exporter.pm
+ ${prV}/ExtUtils/Command.pm
+ ${prV}/ExtUtils/Constant.pm
+ ${prV}/ExtUtils/Embed.pm
+ ${prV}/ExtUtils/Installed.pm
+ ${prV}/ExtUtils/Install.pm
+ ${prV}/ExtUtils/Liblist.pm
+ ${prV}/ExtUtils/MakeMaker.pm
+ ${prV}/ExtUtils/Manifest.pm
+ ${prV}/ExtUtils/Mkbootstrap.pm
+ ${prV}/ExtUtils/Mksymlists.pm
+ ${prV}/ExtUtils/MM_Any.pm
+ ${prV}/ExtUtils/MM_MacOS.pm
+ ${prV}/ExtUtils/MM.pm
+ ${prV}/ExtUtils/MM_Unix.pm
+ ${prV}/ExtUtils/MY.pm
+ ${prV}/ExtUtils/Packlist.pm
+ ${prV}/ExtUtils/testlib.pm
+ ${prV}/ExtUtils/Miniperl.pm
+ ${prV}/ExtUtils/Command/MM.pm
+ ${prV}/ExtUtils/Constant/Base.pm
+ ${prV}/ExtUtils/Constant/Utils.pm
+ ${prV}/ExtUtils/Constant/XS.pm
+ ${prV}/ExtUtils/Liblist/Kid.pm
+ ${prV}/ExtUtils/MakeMaker/bytes.pm
+ ${prV}/ExtUtils/MakeMaker/vmsish.pm
+ ${prV}/fields.pm
+ ${prV}/File/Basename.pm
+ ${prV}/File/Compare.pm
+ ${prV}/File/Copy.pm
+ ${prV}/File/Find.pm
+ ${prV}/FileHandle.pm
+ ${prV}/File/Path.pm
+ ${prV}/File/Spec.pm
+ ${prV}/File/Spec/Unix.pm
+ ${prV}/File/stat.pm
+ ${prV}/filetest.pm
+ ${prVA}/attrs.pm
+ ${prVA}/auto/attrs
+ ${prVA}/auto/Cwd/Cwd$(get_libname)
+ ${prVA}/auto/Data/Dumper/Dumper$(get_libname)
+ ${prVA}/auto/DynaLoader/dl_findfile.al
+ ${prVA}/auto/Fcntl/Fcntl$(get_libname)
+ ${prVA}/auto/File/Glob/Glob$(get_libname)
+ ${prVA}/auto/IO/IO$(get_libname)
+ ${prVA}/auto/POSIX/autosplit.ix
+ ${prVA}/auto/POSIX/fstat.al
+ ${prVA}/auto/POSIX/load_imports.al
+ ${prVA}/auto/POSIX/POSIX.bs
+ ${prVA}/auto/POSIX/POSIX$(get_libname)
+ ${prVA}/auto/POSIX/stat.al
+ ${prVA}/auto/POSIX/tmpfile.al
+ ${prVA}/auto/re/re$(get_libname)
+ ${prVA}/auto/Socket/Socket$(get_libname)
+ ${prVA}/auto/Storable/autosplit.ix
+ ${prVA}/auto/Storable/_retrieve.al
+ ${prVA}/auto/Storable/retrieve.al
+ ${prVA}/auto/Storable/Storable$(get_libname)
+ ${prVA}/auto/Storable/_store.al
+ ${prVA}/auto/Storable/store.al
+ ${prVA}/B/Deparse.pm
+ ${prVA}/B.pm
+ ${prVA}/Config.pm
+ ${prVA}/Config_heavy.pl
+ ${prVA}/CORE/libperl$(get_libname)
+ ${prVA}/Cwd.pm
+ ${prVA}/Data/Dumper.pm
+ ${prVA}/DynaLoader.pm
+ ${prVA}/encoding.pm
+ ${prVA}/Errno.pm
+ ${prVA}/Fcntl.pm
+ ${prVA}/File/Glob.pm
+ ${prVA}/_h2ph_pre.ph
+ ${prVA}/IO/File.pm
+ ${prVA}/IO/Handle.pm
+ ${prVA}/IO/Pipe.pm
+ ${prVA}/IO.pm
+ ${prVA}/IO/Seekable.pm
+ ${prVA}/IO/Select.pm
+ ${prVA}/IO/Socket.pm
+ ${prVA}/lib.pm
+ ${prVA}/NDBM_File.pm
+ ${prVA}/ops.pm
+ ${prVA}/POSIX.pm
+ ${prVA}/re.pm
+ ${prVA}/Socket.pm
+ ${prVA}/Storable.pm
+ ${prVA}/threads
+ ${prVA}/threads.pm
+ ${prVA}/XSLoader.pm
+ ${prV}/Getopt/Long.pm
+ ${prV}/Getopt/Std.pm
+ ${prV}/if.pm
+ ${prV}/integer.pm
+ ${prV}/IO/Socket/INET.pm
+ ${prV}/IO/Socket/UNIX.pm
+ ${prV}/IPC/Open2.pm
+ ${prV}/IPC/Open3.pm
+ ${prV}/less.pm
+ ${prV}/List/Util.pm
+ ${prV}/locale.pm
+ ${prV}/open.pm
+ ${prV}/overload.pm
+ ${prV}/Pod/InputObjects.pm
+ ${prV}/Pod/Man.pm
+ ${prV}/Pod/ParseLink.pm
+ ${prV}/Pod/Parser.pm
+ ${prV}/Pod/Select.pm
+ ${prV}/Pod/Text.pm
+ ${prV}/Pod/Usage.pm
+ ${prV}/PerlIO.pm
+ ${prV}/Scalar/Util.pm
+ ${prV}/SelectSaver.pm
+ ${prV}/sigtrap.pm
+ ${prV}/sort.pm
+ ${prV}/stat.pl
+ ${prV}/strict.pm
+ ${prV}/subs.pm
+ ${prV}/Symbol.pm
+ ${prV}/Text/ParseWords.pm
+ ${prV}/Text/Tabs.pm
+ ${prV}/Text/Wrap.pm
+ ${prV}/Time/Local.pm
+ ${prV}/unicore/Canonical.pl
+ ${prV}/unicore/Exact.pl
+ ${prV}/unicore/lib/gc_sc/Digit.pl
+ ${prV}/unicore/lib/gc_sc/Word.pl
+ ${prV}/unicore/PVA.pl
+ ${prV}/unicore/To/Fold.pl
+ ${prV}/unicore/To/Lower.pl
+ ${prV}/unicore/To/Upper.pl
+ ${prV}/utf8_heavy.pl
+ ${prV}/utf8.pm
+ ${prV}/vars.pm
+ ${prV}/vmsish.pm
+ ${prV}/warnings
+ ${prV}/warnings.pm
+ ${prV}/warnings/register.pm"
+
+ pushd "${D}" > /dev/null
+ # Remove cruft
+ einfo "Removing files that are not in the minimal install"
+ echo "${MINIMAL_PERL_INSTALL}"
+ for f in $(find . -type f ) ; do
+ has "${f}" ${MINIMAL_PERL_INSTALL} || rm -f "${f}"
+ done
+ # Remove empty directories
+ find . -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
+ popd > /dev/null
+}