summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2009-09-07 21:10:58 +1200
committerKent Fredric <kentfredric@gmail.com>2010-11-18 17:16:45 +1300
commitc1cd5c1e4ff12a2e16cbef98ca85a3fd64bd9184 (patch)
treec59d9eca0d5f1bdf7030f9494b405367fd9dd4f2
parent[newversion,keywordmasked] virtual/perl-ExtUtils-MakeMaker-6.57_pre06 for tes... (diff)
downloadperl-overlay-c1cd5c1e4ff12a2e16cbef98ca85a3fd64bd9184.tar.gz
perl-overlay-c1cd5c1e4ff12a2e16cbef98ca85a3fd64bd9184.tar.bz2
perl-overlay-c1cd5c1e4ff12a2e16cbef98ca85a3fd64bd9184.zip
Parrot added
-rw-r--r--dev-lang/parrot/ChangeLog10
-rw-r--r--dev-lang/parrot/Manifest3
-rw-r--r--dev-lang/parrot/metadata.xml14
-rw-r--r--dev-lang/parrot/parrot-9999.ebuild83
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
new file mode 100644
index 000000000..1dfa201ae
--- /dev/null
+++ b/dev-lang/parrot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/parrot
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.27 2009/11/02 18:49:36 patrick Exp $
+
+*parrot-9999 (07 Sep 2009)
+
+ 07 Sep 2009; Kent Fredric <kentfredric@gmail.com> +parrot-9999.ebuild,
+ +metadata.xml:
+ First Parrot SCM Build
+
diff --git a/dev-lang/parrot/Manifest b/dev-lang/parrot/Manifest
new file mode 100644
index 000000000..1e1404386
--- /dev/null
+++ b/dev-lang/parrot/Manifest
@@ -0,0 +1,3 @@
+EBUILD parrot-9999.ebuild 2196 RMD160 9fc0441a22e2878e6d2c3a030bdaac2a9533a232 SHA1 bc0c3c73af8d837add5e787d9b437dd84becd8d1 SHA256 e519b6b2abde30b1a392ddb5f13410da958ab86a90a7e7c8add014e7c9dc50ad
+MISC ChangeLog 349 RMD160 18804430dce9c5f3cfb71100172d2dd635374474 SHA1 538ef7c05944fd6ad3b3ad95453e69c61d93cdcd SHA256 da867c80c1ddd115408964f4343073cf3a9a9ffcabc06f29580316e3a43f11fb
+MISC metadata.xml 416 RMD160 4bde7340f08e18774bd7c3e886d553f583cfdbc8 SHA1 e4da362ef03600e7777cff90655c8800924392b6 SHA256 e69ff9f47630519c5b8faf7286dea363c749704ecf127ad281937c601e5a2a3e
diff --git a/dev-lang/parrot/metadata.xml b/dev-lang/parrot/metadata.xml
new file mode 100644
index 000000000..dbac9b340
--- /dev/null
+++ b/dev-lang/parrot/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>kentfredric@gmail.com</email>
+ <name>Kent Fredric</name>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/dev-lang/parrot/parrot-9999.ebuild b/dev-lang/parrot/parrot-9999.ebuild
new file mode 100644
index 000000000..1b9745c6b
--- /dev/null
+++ b/dev-lang/parrot/parrot-9999.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+ESVN_REPO_URI="https://svn.parrot.org/parrot/trunk"
+ESVN_RESTRICT="export"
+inherit subversion;
+
+DESCRIPTION="A virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI=""
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="opengl nls doc examples gdbm gmp ssl unicode pcre"
+
+RDEPEND="
+ opengl? ( virtual/glut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )
+"
+
+DEPEND="
+ dev-lang/perl[doc?]
+ ${RDEPEND}
+"
+
+src_unpack(){
+ # This is pretty nasty,
+ # but svn builds need to have a working ability to call
+ # 'svn info' to get revision data
+ subversion_src_unpack
+ cd "${wc_path}" || die "${ESVN}: can't chdir to ${wc_path}"
+
+ local S="${S}/${S_dest}"
+ mkdir -p "${S}"
+
+ # export to the ${WORKDIR}
+ #* "svn export" has a bug. see http://bugs.gentoo.org/119236
+ #* svn export . "${S}" || die "${ESVN}: can't export to ${S}."
+ rsync -rlpgo . "${S}" || die "${ESVN}: can't export to ${S}."
+
+}
+src_prepare() {
+ sed -e "s:/lib/:/$(get_libdir)/:" -i "${S}/tools/dev/install_files.pl"
+}
+
+src_configure() {
+ myconf=""
+ use unicode || myconf="$myconf --without-icu"
+ use ssl || myconf="$myconf --without-crypto"
+ use gdbm || myconf="$myconf --without-gdbm"
+ use nls || myconf="$myconf --without-gettext"
+ use gmp || myconf="$myconf --without-gmp"
+ use opengl || myconf="$myconf --without-opengl"
+ use pcre || myconf="$myconf --without-pcre"
+
+ perl Configure.pl --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --sysconfdir=/etc \
+ --sharedstatedir=/var/lib/parrot \
+ $myconf
+}
+src_compile() {
+ local parrotv=$( ./parrot_config revision );
+ einfo "Building parrot $parrotv";
+ emake || die
+ use doc && make html
+ local parrotv=$( ./parrot_config revision );
+ einfo "Successfully build $parrotv";
+}
+src_install() {
+ emake install-dev DESTDIR="${D}" DOC_DIR="/usr/share/doc/${P}" || die
+}
+src_test() {
+ emake coretest || die "Tests Failed"
+}