summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2009-08-27 08:58:46 +1200
committerKent Fredric <kentfredric@gmail.com>2009-08-27 08:58:46 +1200
commita6d565109aff334347e022c74593a409936dcb1a (patch)
treeefa7542228c805463acc1307340739dd50e3c766 /app-editors
parentBumped virtual/perl-threads-shared (diff)
downloadperl-overlay-a6d565109aff334347e022c74593a409936dcb1a.tar.gz
perl-overlay-a6d565109aff334347e022c74593a409936dcb1a.tar.bz2
perl-overlay-a6d565109aff334347e022c74593a409936dcb1a.zip
Tweaked padre to get tests going and building in odd X11 situations.
(Portage version: 2.2_rc40/git/Linux x86_64) (Unsigned Manifest commit)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/padre/ChangeLog5
-rw-r--r--app-editors/padre/Manifest4
-rw-r--r--app-editors/padre/padre-0.44.ebuild30
3 files changed, 35 insertions, 4 deletions
diff --git a/app-editors/padre/ChangeLog b/app-editors/padre/ChangeLog
index 8dea00ee3..bb06af1fd 100644
--- a/app-editors/padre/ChangeLog
+++ b/app-editors/padre/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Aug 2009; Kent Fredric <kentfredric@gmail.com> padre-0.44.ebuild:
+ Managed to add tests and get them to run properly regardless of your X
+ settings. If you don't have 'xset' installed ( which is used to test if X
+ works or not ), then tests that need X won't run.
+
*padre-0.44 (25 Aug 2009)
25 Aug 2009; Kent Fredric <kentfredric@gmail.com> +padre-0.44.ebuild:
diff --git a/app-editors/padre/Manifest b/app-editors/padre/Manifest
index 6a064aa73..a72a45ed3 100644
--- a/app-editors/padre/Manifest
+++ b/app-editors/padre/Manifest
@@ -1,6 +1,6 @@
DIST Padre-0.42.tar.gz 579114 RMD160 55e4a9f60a459fad8894e153bd5173f4369a5c88 SHA1 e313e62430b54a1a5440ba2d0fa023af561511fc SHA256 36df4a0b82011db57e2e22181fb6f19296293cf3e5d5e0f2d28b785eb777d95a
DIST Padre-0.44.tar.gz 862586 RMD160 9215724e77a700d70aaa76e1222479e340ea2f24 SHA1 65e5ed0653866f13ead9ee4a59fa290d71882ced SHA256 61d82377d044b167ca3c5c449ad34138fb3e6b2961fe540d5e6cf28a1979e1bd
EBUILD padre-0.42.ebuild 2179 RMD160 c5230d6e6a4b39b755b49cc7c1aa414ab68fe189 SHA1 7393c10daa633a81dd4ca62eec9ffaa0890a8c62 SHA256 12fcd9c382581000e7182f92fe7c06eac3431c0ebdfda7f3c09be0fe2b410de2
-EBUILD padre-0.44.ebuild 2206 RMD160 060abcb774294492108342b8101e9ff2c70b035c SHA1 c5c11da99dfb24cd4fa7f793f0fe4904f0db89ab SHA256 49ce39da15c4c4b6ccaf05468a0a5f82edd9886c5a95b1c9a087492c13b333cf
-MISC ChangeLog 1228 RMD160 59843afa14846868ea15133b6786e400d061cb72 SHA1 2f2f272acbb56c634a16710e5d4e84e96e3e4a50 SHA256 c6428461b7e63c705f1f2d5c9905bb5532bc4a6c9ba251d76487c9bfc6e01d89
+EBUILD padre-0.44.ebuild 2711 RMD160 1bc98b8df3824c210a8a59b9de5d627de5ab2700 SHA1 0764cae8fcdd4bade47d8b88f39e1f72f8a7e783 SHA256 454dadad0b366e7a70cdbc678c4660500f538ba4920919e1615cb48a49ac9fa7
+MISC ChangeLog 1502 RMD160 c29057ee3bff444a8b186a4891237dfe073af831 SHA1 4c050ae862a61819af7eb5a59753c9058dda32d4 SHA256 c7bc572e0ca7ebd06d28bff1c45c0a092b2e1ebae0f992b9d4691b6d0a19f7d6
MISC metadata.xml 158 RMD160 03e4d8164c58bc61660cbaf489d4e3652de0feb7 SHA1 9a84117c6fb70288426e20c84deaf16f4381a549 SHA256 1fef4c0af5f71b777110f54d9dfbd27d6c85c750fca007f4a2fb38345ebbb710
diff --git a/app-editors/padre/padre-0.44.ebuild b/app-editors/padre/padre-0.44.ebuild
index 431ffa966..0ee4c65a9 100644
--- a/app-editors/padre/padre-0.44.ebuild
+++ b/app-editors/padre/padre-0.44.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="http://padre.perlide.org/"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
DEPEND="
>=dev-perl/Locale-Msgfmt-0.14
@@ -80,7 +80,33 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+x11_works(){
+ # If there is no xdpyinfo,
+ # it will return 127
+ xset -q 1>/dev/null 2>&1
+ WORKS="$?"
+ if [[ "$WORKS" == "0" ]] ; then
+ einfo "X11 Works!"
+ else
+ einfo "X11 doesnt work"
+ fi
+ einfo "Display at: '${DISPLAY}'"
+ return $WORKS
+}
+
src_configure(){
- unset DISPLAY
+ DISPLAY_COPY="$DISPLAY"
+ unset DISPLAY;
perl-module_src_configure
+ if use test && [[ "$DISPLAY_COPY" != "" ]]; then
+ einfo "Bringing back Display Settings for later "
+ export DISPLAY="$DISPLAY_COPY"
+ fi
+}
+src_test(){
+ if ! x11_works; then
+ unset DISPLAY
+ fi
+ perl-module_src_test
}
+SRC_TEST=do